LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-23-2006, 11:26 PM   #1
Spiritfall23
LQ Newbie
 
Registered: May 2006
Posts: 3

Rep: Reputation: 0
Fedora Core 5 .. problems with glib


i install glib-2.8.6 .. but when i try to install any program wich depends on glib .. it say`s that i have glib-1.2.2 .. it doesn-t find the new version .. what can i do ??
 
Old 05-24-2006, 01:30 AM   #2
phoenix49
Member
 
Registered: Jun 2005
Location: Azerbaijan/Baku
Distribution: Fedora Core 6 "Zod"
Posts: 179

Rep: Reputation: 30
Quote:
Originally Posted by Spiritfall23
i install glib-2.8.6 .. but when i try to install any program wich depends on glib .. it say`s that i have glib-1.2.2 .. it doesn-t find the new version .. what can i do ??
Which program do you mean under "any" ? Some old programs can't detect newer versions of glib, and exitin with such errors.
 
Old 05-24-2006, 02:05 AM   #3
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
1. how did you install glib-2.8.6?
2. how are you installing the "any" package?

Chances are you need to redo the install via yum or add the path to glib-2.8.6 to the PKG_CONFIG_PATH environment variable. (Suspect the former as a yum upgrade to glib would have removed the earlier version.) I'm guessing: there just isn't enough info to be definitive here. Always give concrete examples and report the exact error message.
 
Old 05-24-2006, 10:06 AM   #4
Spiritfall23
LQ Newbie
 
Registered: May 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Hmm .. ok .. i receive this error .. when i try to install xmms .. (basic installation: ./configure , make , make install ) and i receive this error .. at ./configure
 
Old 05-24-2006, 02:53 PM   #5
phoenix49
Member
 
Registered: Jun 2005
Location: Azerbaijan/Baku
Distribution: Fedora Core 6 "Zod"
Posts: 179

Rep: Reputation: 30
For xmms try to install regular package, have you yumex installed? and have you livna repos? Goto rpm.livna.org, there's instructions how to setup livna repos, and don't forget to install yumex. As root:

yum install yumex

Yumex is a graphical frontend for yum, there you can select which packages to install and remove
 
Old 05-24-2006, 06:07 PM   #6
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
OK. That was one question out of two answered. (Did you do this as a hypothetical example, or did you actually do this? You see, if this was actually done I'd like to have seen a pasting of the relevant lines of output from configure. That would make the example "concrete".)

While the answer given helps, I really need the first question answered too.

Phoenix: while I suspect you're on the right track, installing xmms is not the point. The point is to be able to compile source code linked to glib, so that the "configure" script will locate the more recent version of glib installed.
 
Old 05-27-2006, 02:20 AM   #7
jlo_sandog
Member
 
Registered: Jul 2005
Location: USA
Distribution: F10 (x86_64)
Posts: 549

Rep: Reputation: 32
on fedora there are 2 glibs. The latest are glib-1.2.10-18.2.2, and glib2-2.10.2-1.fc5.1. To compile you will need the -devel libs. (glib-devel, and glib2-devel). You can get them via yum.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 5 .. problems with glib Spiritfall23 Linux - Software 2 05-24-2006 01:53 PM
gtk and glib 1.2 for fedora core 3 syseeker Linux - Software 2 04-13-2006 11:36 PM
Fedora Core 3 Glib issues checarsner Linux - Software 8 06-10-2005 09:27 AM
Can't install glib 1.2.10 on Fedora Core 3 sureshot324 Linux - Software 3 11-26-2004 06:12 AM
Severe problems with Fedora Core 1 and Fedora Core 2 installatiom TheOneKEA Fedora - Installation 2 07-14-2004 03:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration