-   Linux - Newbie (
-   -   fedora core 3 installation kernel panic - not syncing (

woutervw 01-20-2005 02:48 PM

fedora core 3 installation kernel panic - not syncing
Hello there

I just bought a new machine:
* MSI 915P Neo2 mobo
* Intel Prescott 3.2 socket 775 1M L2 cache
* 1024 MB DDRII533 RAM
* ASUS Extreme6600 (Nvidea Geforce)
* Maxtor HDD SATA 250 GB (Primary Master)
* MSI DVD-writer (Third Master)

I tried to install fedora core 3 but got a kernel panic. This is also the case with knoppix (kernel 2.6.9 and suse 9.2)

If I boot with option mem=1024 It seems to go over the kernel panic, but I get nothing more then:

"Uncompressing the kernel...OK ;-) Booting the kernel" with a blinking underscore on the second line...

In an other tread I read about MAXTOR problems with CD drives on the same cable, mine isn't, but the only way to see the DVD is to set the SATA MAXTOR to IDE... :-(((

here comes the kernel panic, Anybody any ID?

CPU: 0
EIP: 0030:[<c00f0488>] Not tainted VLI
EFLAGS: 00010246 (2.6.9-1.667)
EIP is at 0xc00f0488
eax: 0000b100 ebx: 00000000 ecx: 00002504 edx: 25808086
esi: 00000000 edi: c03798cc ebp: 00000000 esp: dfc87f70
ds: 007b es: 007b ss: 0068
Process Swapper (pid: 1, treadinfo=dfc87000 task=dfcb1730)
Stack: b1000400 c00f026b c00f028d 00000400 000098cc 00002570 0100b102 8086c00f
00540000 0246c00f c02a4cd0 00000060 dfc87fbe dfcab400 00000000 00000000
c02a51b9 dfc87fbe dfc87fbf c03c6d86 dfc87fc0 dfc87fc0 c03d1674 00000000
Call Trace:
[<c02a4cd0>] pci_bios_find_device+0x19/0x38
[<c02a51b9>] pcibios_sort+0xc9/0x14b
[<c03c6d86>] pcibios_allocate_resources+0xeb/0xfc
[<c03c77e7>] pcibios_init+0x65/0x68
[<c03b1702>] do_initcalls+0x49/0x8e
[<c010051b>] init+0xc1/0x1f3
[<c010045a>] init+0x0/0x1f3
[<c01041d5>] kernel_thread_helper+0x5/0xb
Code: 81 fe 00 ff 75 05 8a c1 ee eb 11 66 81 fe 01 ff 75 07 66 8b c1 66 ef eb 03
8b c1 ef 66 9d 66 5a 58 f8 c3 c3 c3 66 50 66 53 b7 00 <2e> 8a 83 96 04 00 00 66
5b 8a d8 66 58 c3 00 01 02 03 04 05 06
<0>Kernel panic - not syncing: Attempted to kill init!

So with kernel 2.4 nothing's wrong, it's only kernel 2.6.........

Thanks for the help!!!


sewer_monkey 02-05-2005 05:25 PM

What bootloader are you using? It seems to be the kernel has issues with the initial RAMdisk image (initrd), which is why it's complaining about init... I may be wrong.

woutervw 02-06-2005 11:57 AM

I didn't used any boot loader yet, just the installation CD.
My disk was low level formated (just new from the store)

I now run Slackware (kernel 2.4.29) and it runs just fine with LILO in the MBR (first tried LILO in the boot partition, but that didn't do the trick --> "L 99 99 99 99...").

I now know that nor kernel 2.4.26, nor kernel 2.6.xx support my SATA disk (250 GB Maxtor) or my onboard LAN (Gigabyte). I hope that a newer release of kernel 2.6 will help me with these problems, but in the mean time, I'll continue using 2.4.29 with an extra LAN because the onboard LAN is still not supported... :-s

rem 02-12-2005 04:34 PM

fedora core 3 installation kernel panic
I bought a new machine last month and had similar results trying to install either Fedora Core 3 or Debian. With Fedora I get

Call Trace:
[<0222dd34>] pci_bios_find_device+0x1d/0x3e
[<021041d9>] kernel_thread_helper+0x5/0xb

Code: 2e 8a 83 96 04 00 00 66 5b 8a d8 66 58 c3 00 01 02 03 04 05
<0>Kernel Panic: Attempted to kill init!

The machine has a 3.4GHz P4 on an MSI mother board with DVD and TV capabilities.

It also has cold swappable hard drives, one with Mandrake which nicely comes up, and one with XP.

I'd love to find out why Fedora and Debian can't work on it. Maybe someone will have a clue! (hope, hope)

mgerste 02-20-2005 03:30 AM


I have the same problem with a new P4 3GHZ, MSI Neo 916G and a Maxtor Diamon 80 GB. Have you found a solution to install Fedora?

battaboy 02-21-2005 12:52 PM

kernel panic

i have a similar problem. I have installed fedora within vmware 4.0 and it appeared that the fedora installation went successfully. upon reboot, i receive the kernel panic - not syning; attempting to kill init

I am stuck, any ideas on how to resolve??

thanks in advance.

scowles 02-22-2005 07:13 PM

FWIW: I have the same problem. I have tried every kernel command line parameter I can think of and still get the kernel panic. I regret the day I bought this MSI MB with the the 915P chipset. These MB's have got to be the most "linux" incompatible MB's I have ever seen.

laxtlo 02-23-2005 11:51 AM


same problem here

Call Trace:
[<0222dd34>] pci_bios_find_device+0x1d/0x3e
[<021041d9>] kernel_thread_helper+0x5/0xb

Code: 2e 8a 83 96 04 00 00 66 5b 8a d8 66 58 c3 00 01 02 03 04 05
<0>Kernel Panic: Attempted to kill init!

i have tried suse 8.2/fedora 1,2,3 + test versions/redhat 4 Ws nothing works ;(

MSI NEON 2 platinium

jaedus 03-03-2005 02:30 PM

I see that the last post on this topic is just a few days ago, but is there any chance you guys have found anything useful? I'll keep searching google and post back if I find anything, but hopefully one of you has already found a fix. :)

laxtlo 03-04-2005 09:13 AM

no solution i think MSI SUCKS HARD !!! ;)

jaedus 03-04-2005 04:48 PM

Ok, found the solutions, the article on this page:
tipped me off to the obvious fix. As with most software manufacturers the fixes are often in the newer versions. :)
Upgrade to Vmware 4.5.2 and you're off to the races boys :)

cheesle 03-09-2005 04:33 AM

Kernel Panic - Dont Panic!
Here's my solution (suggest you try the same especially if system is hanging when trying to install Fedora X).

My machine was running Fedora Core 1 just fine. I upgraded to Fedora Core 3. Then after running the Kernel update (up2date) every time I rebooted I had various Kernel Panics which was very very very annoying.

Thinking it was Fedora 3 clashing with my motherboard I downloaded and installed version 2 (same results) and also version 1 (also same annoying hang on install).

After trying the 3 versions of Fedora I was fairly sure it was hardware related so buy process of elimination I finally discovered it was my memory which was causing the headache. Wish I tried my memory before buying a new harddrive (such is life!).

So the moral of the story is if your getting Kernel panics then I strongly suggest testing your system memory. I used software called Amidiag (dos version). My memory was failing on the pattern test.

Hope this helps ;)

mgerste 03-09-2005 04:41 AM

I think it's an Fedora related problem. SUSE Linux 9.0 ist booting fine?!

mgerste 03-19-2005 03:44 AM

Found the solution!
Try to boot with "F4" (Kernel Options) #linux pci=nosort text
Now Fedora can be installed.
The next problem is to get X running on the 915G chipset.

jaedus 03-19-2005 10:41 AM

or....upgrade vmware :) Hehe, wow you guys are sure working hard to not upgrade your version of vmware. Too much $$ ?

All times are GMT -5. The time now is 02:23 PM.