LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   FEDORA core 3 display problems (https://www.linuxquestions.org/questions/linux-newbie-8/fedora-core-3-display-problems-292434/)

mabus92920 02-19-2005 08:19 PM

FEDORA core 3 display problems
 
Ey guys.. I have a problem with my fedora 3. The thing is it doesn't show the GUI properly (ex you have to put your mouse over some menus to show what it is)...and another one is when it boots, the only portion loaded well is the one with a progress bar, then the rest are blacked out.

during installation, it detected my monitor as AOC D556, and my video card respectively. I tried re-installing and configuring it to a different setting (that was "Generic ... 1024x768"),yet this didn't work either.

I had this problem before when I first installed fedora 3, and I was able to fix it by chaning the color settings, but now..that doesn't work anymore.

How do I fix this problem ?? and also, I know there's a way to boot linux like how is on the first boot, but I forgot how to do that.. can anyone tell me how??? I need that so I can try out other monitor settings.

How about changing monitor from console? how do I get a list of supported monitors from there??

please post your replies..thanks .

caps_phisto 02-19-2005 11:03 PM

I would try this (only if you can get a GUI though)

1. open a terminal
2. su to root (if needed)
3. Type system-config-display (this will get you to a screen similar to the first boot process)

Configuring a video card at the command line I couldn't even fathom. My only guess is that you could try to manually edit /etc/X11/xorg.conf, but that might get you inot more trouble...

mabus92920 02-20-2005 11:53 PM

Oh..thanks for the tip man.. I'll keep you posted.

ArthurDent 02-21-2005 09:46 AM

Masbus,

Can you post your system specs. I was getting exactly the same problem and in the end I gave up and went back to FC2 figuring it was a hardware issue and that FC3 was just never going to work on my machine (although interestingly I did get FC3 to work on an even lower spec machine - just verrrrry slooooowly....).

I will post my system specs when I get a chance to post from that machine (I can't remember them off the top of my head but I think I have an Intel i810 on-board graphics card and 256M memeory - I'll check)....

I would be very interested in be able to upgrade to FC3 myself.

Cheers

Mark

mabus92920 02-21-2005 09:15 PM

eu ArthurDent..its MABUS..

man.. I guess I had a corrupted FC3 download. Someone told me that even the cd's pass media check, there's also a chance that some packages might be corrupted..well..I'll post it here when I solved the problem

my specs are intel 810 onboard , AOC Spectrum 5en monitor, pentium 650, and 640 SDRAM. thats it..

it used to work good during my first install but I had to reinstall coz I damaged my root filesystem. after that, I had the display problem

ArthurDent 02-22-2005 05:30 AM

Hmmm. Interesting.....

We both have an Intel i810 on-board graphics card.

I have tried installing FC3 from both downloaded CDs (MD5Sum checked and then "Media Checked" once burned) AND from a Magazine Coverdisk CDROM. I get the same results no matter which media I use.

If I try to do a fresh install I either get a scrambled screen or - if I manage to get through the istall - it chokes on the post-install configuration phase (just after the licence agreement bit).

If I try to do an "upgrade" from a working FC2 install I get a system that seem to work at first glance, but then gives the same problems you describe (i.e you have to mouse over menus and dialogue boxes before they will appear). It is completeley unworkable.

Has anyone managed to get FC3 up and running using an i810 graphics card?

caps_phisto 02-26-2005 08:34 AM

I've only gotten it to work on a Dell computer. Dell sent out a BIOS upgrade. This allowed the BIOS to set the internal card from 1 MB to 8 MB memory. After thant it all went well. Of course I was having that problem back with Fedora Core 2 and my problem was slightly different. I did not get a GUI at all. But, hey if there is a setting like that in your BIOS give it a whirl.

mabus92920 02-27-2005 08:12 PM

ey ArthurDent.. actually it used to work for me during the first install. everything worked perfectly with intel 810. The thing is, when I re-installed, the problem came.

some of my friends say that it could be a corrupted download. I'm trying to get a new copy and re-install again.

ArthurDent 02-28-2005 03:36 AM

Well as I said above I have done the install (several times) using both thoroughly checked downloaded media AND commercially produced (Magazine cover DVD) media. So I don't think that's the problem...

chris318 02-28-2005 03:56 AM

The problem is Xorg. It has a nasty bug witn the integrated intel chipsets, which was finally fixed in Xorg 6.8.2. The other Xorg work is 2d accel is disabled. If you don't want to upgrade to Xorg 6.8.2 then just add the option "noaccel" under device in the /etc/X11/xorg.conf and the visual corruption should go away.

mabus92920 02-28-2005 04:42 AM

oh..thanks for that info man.. ..damn.. I knew I was right. I always thought it would be a conflict between FC3's packages and intel 810

ArthurDent 03-01-2005 04:27 PM

Chris

You're a star! Thank you so much! I thought that I would never get FC3 going on this box - and such a simple solution.

Sorry it's taken a while to reply but tonight was the first chance I got to try to re-do the install (and this time change the xorg.conf file before rebooting).

Thanks again

Mark

mabus92920 03-02-2005 07:11 AM

ey guys.. where di you download xorg 6.8.2? where can I find a good source for updates such as that one?

ArthurDent 03-02-2005 09:03 AM

Well I didn't try. I just followed Chris318's suggestion and edited my /etc/X11/xorg.conf file as he suggests. Try it - it works!

Personally I don't think I would try to upgrade to Xorg 6.8.2 because it has only just been released and, at the moment, is only available as source. Compling and installing Xorg from source is not a task to be undertaken lightly. I'm sure Fedora will put the rpm binaries on up2date in due course and I will get them from there when they're ready.

mabus92920 03-02-2005 08:33 PM

yah..I'm thinking of doing that also. thanks for the tips guys.

so where do you usually download fedora updates ?


All times are GMT -5. The time now is 12:59 PM.