-   Linux - Newbie (
-   -   Fedora 9 X86/64 live CD freezes when I run installer (

WiglyWorm 05-18-2008 10:16 PM

Fedora 9 X86/64 live CD freezes when I run installer
I am a crossover user and am most interested in keeping Windows active, at least while I learn Linux (but probably into the forseeable future: gaming). I've been trying to install Linux on my PC for a while now, but I've been running in to problems.

With the Fedora 8 installer I was unable to get past the keyboard selection screen. It would freeze when I selected my keyboard and hit next. On Fedora 9, it freezes after I enter the root password and click next.

Ubuntu was able to run fine, but I couldn't get my RAID setup to work, so I was hoping I could get somewhere with Fedora. Can anyone lend some insight?


WiglyWorm 05-19-2008 11:05 AM

a) bumb

b) Does anyone know what the installer is trying to do at either of these points, so I can try to figure out what may be causing the crash?

vertigo88x 05-19-2008 06:58 PM

on what computer are you trying to install it. fedora is ussually bleeding edge, which means you don't always get the most stable environment.

one thing you can try is, instead of double clicking on the install to icon to install, launch a terminal, and type '/usr/bin/liveinst' i just thought of this, and have never tried it myself, but it might give you some output as to what it is doing or maybe some errors.

BallsOfSteel 05-19-2008 07:51 PM

I was having a problem installing F9 as well. I'd have problems getting past the partitioning stage. I went to a text based install and that worked just fine. However, when I went to get into gdm, it would freeze. All of those problems were with an install DVD.

I had ZERO problems getting the Live CD to boot through virtualization. That's the price you pay for bleeding edge, though.


WiglyWorm 05-19-2008 09:29 PM

My PC is home built, but the components are as follows:

Intel Q6600
nVidia 780i motherboard
nVidia 8800 GTS
some Sony DVD burner

I'll try the console based install now.

For the record, the boot works and the OS seems fine until I try the installer.

come to think of it, I'm running a significant overclock on my processor, I should probably take my processor back to stock as well. I'll let you guys know how it goes.

Edit: Forgot to mention, I'm running RAID 0.

Also I think this looks interesting, hopefully it will lend a clue. Here is the output to the console:


[fedora@localhost ~]$ /usr/bin/liveinst
FATAL: Module md not found.
  /dev/sda3: read failed after 0 of 4096 at 225706967040: Input/output error
  /dev/sda3: read failed after 0 of 4096 at 225707024384: Input/output error
  No volume groups found
Probing for video card:  nVidia Corporation GeForce 8800 GTS 512
22:48:38 Starting graphical installation...
Loading /lib/kbd/keymaps/i386/qwerty/
/dev/sdb: "nvidia" and "jmicron" formats discovered (using jmicron)!
/dev/sda: "nvidia" and "jmicron" formats discovered (using jmicron)!

I never got this before, but now that I'm running from the command line, I get a message saying that the device mapper/jmicron_GRAID was unreadable and new partitions must be initialized.

This, of course, isn't going to work very well with my goal of keeping windows for the time being.

vertigo88x 05-19-2008 10:34 PM

from the looks of it. it is a problem with the hard drive, i am not familiar with RAID so i cannot help you.

WiglyWorm 05-20-2008 10:09 AM

Well at least we uncovered part of the issue. Seems Fedora doesn't do any better of a job at detecting my RAID then Ubuntu did.

vertigo88x 05-20-2008 02:45 PM

maybe this from the fedora 9 installation guide might be of some help.

All times are GMT -5. The time now is 08:39 AM.