-   Linux - Newbie (
-   -   Fedora 8 Installation Problem (

gabelh 08-22-2008 04:25 PM

Fedora 8 Installation Problem
I tried my hand at running this one up the flagpole at FedoraForum but thus far it yielded no results so I'm giving it a whirl here. Due to my very rudimentary knowledge of *NIX operating systems I really have no idea where to start on troubleshooting this. It seems as though the installer either cannot recognize my cd/dvd drive or possibly the hard drive but I also have no drivers for these devices.
I would be grateful for any insight on this item.

Hey folks,

First, let me begin by saying that I am a Fedora newbie. I have minimal experience with any command based O/S so this is an adventure for me in and of itself.

Without further adieu here is my dilemma;

I am trying to install a Fedora kiosk setup that launches Firefox for our time management program. Basically, employees sign in and clock in/out and that's it. No web browsing or other shenanigans permitted. I have successfully configured such a kiosk already and am now trying to duplicate this with another machine.

The computer in question is nothing spectacular, it's using an Intel D845-WN motherboard, ATA hard drive and fairly low-end stock components. It's a few years old but was previously operational with Windows XP.

I have formatted the hard drive and popped in the Fedora 8 installation CD - which worked successfully on the kiosk I most recently configured - and the installation screen pops up and asks me what I'd like to do. I elect to Install or Upgrade an existing system and move to the next step. I choose English as my language, US as my keyboard and Local CD/DVD as the installation source. Here's where the bottom drops out.

I am prompted that my device's drivers cannot be found and to select from a list or use a driver disk. I do not have a driver disk so I choose the former. It doesn't matter what driver option I select once I see the list, the installation screen goes wonky and throws up a lot of numbers and letters in no particular order on the screen and locks up. At this point my only option is to restart the machine manually.

What I'm really looking for is some info on whether or not this motherboard may be an issue or if perhaps I need some form of driver to put on a disk and use when prompted by the install. I should also mention that I can install Fedora 5 on this machine successfully but once the installation finishes and the system restarts, I get the error message "Error loading operating system" which isn't very encouraging, either.

Any information would be greatly appreciated!


keratos 08-22-2008 05:09 PM

(p.s. I have used *nix , inc.Fedora, for over 20 years - but the 1st lesson to learn my friend is to post a good question, thus thereby assuring oneself of a good response)

gabelh 08-22-2008 05:58 PM


First, thanks the response albeit in this case I'm not sure it's pertinent. I'm not saying that to be cheeky, either. I understand you want more details and if you need hardware specifics I can hunt them down for you but these pc's were in place well before I started here so I'll have to do some digging to find them. The other part of my confusion here is that I simply cannot advance very far in the installation process. If I could get far enough along to receive error messages it would probably be easier to give more info on my end but as soon as I select a driver from the list, I'm locked up and have to begin all over again.

I guess the first thing I might benefit from is if this driver prompt I'm receiving is due to the cd/dvd device not being found or if it's the hard drive. Unfortunately, the best description I can give is what I provided in my previous posting where I choose the installation source as Local CD/DVD and am then told a driver could not be found and to either select one or use the disk. This particular driver list appears to be a hard drive selection, if that helps. I would be thrilled if I could go any farther than that even if I just received more errors, at least that would be progress.

Lastly, I'm not certain this is a hardware issue and here's my reasoning: Could it be possible that I'm having this problem because of the hard drive's formatting rather than a driver issue? It was last known as an NTFS partition when I formatted it to clear it of XP and I haven't found any mention of this on the web to say whether or not if this is my roadblock. Anyway, I did read the thread you linked very thoroughly but for the specifics of this issue I'm not sure what exactly I can provide to be more detailed in my explanation. If someone could point out essential details though I will gladly provide them. Again, I know very, very little about this O/S so what some of you may expect to be a no-brainer may be greek to me.


knudfl 08-22-2008 06:12 PM

Welcome to Linux Questions !

The Fedora 8 install menu :
1) Install or upgrade Fedora
2) Install or upgrade Fedora (text mode)

Please try 2) .. it may be a graphical issue.

I see no other options for now. (I started
the install DVD in "Virtualbox" so I can
actually see this text and the install menu
at the same time.)

Good Luck !

PS.: The question from the Fedora installer :
Load extra drivers ... just answer no, usually
all drivers are there, for all computers, let
us say older than 1 year.

keratos 08-22-2008 06:52 PM

agree with knudfl

if your box is pretty standard stuff (SiS/Intel/Via motherboard chipsets + VGA, IDE disks, IDE CDROM, USB or serial wired keyboard/mouse) then you dont need to load any drivers.

Please provide more detail on what the EXACT procedure is you are following, beginning with what and where you downloaded fedora from , through to the errors on the screen.

Have you read this...

(p.s. the hard drive formatting is irrelevant)

jay73 08-22-2008 08:05 PM

Try booting with these options:
linux all-generic-ide irqpoll

gabelh 08-26-2008 10:52 AM

Alright, I had a chance upon returning to work yesterday to revisit this item and here are the details. First, we didn't download Fedora 8, we purchased CD's from I will mention that I used these exact discs to install another client and that worked so I'm fairly certain the media isn't the issue. The exact steps I am taking to perform the Fedora 8 install:

1. I boot the machine and it boots to the CD first which takes me immediately to a screen prompting me with the following options;

Welcome to Fedora 8!

Install or Upgrade an Existing System
Install or Upgrade an Existing System [Text Mode]
Rescue Install System
Boot From Local Drive
Memory Test

*Press [Tab] to Edit Options

2. I have tried both Install or Upgrade an Existing System as well as Install or Upgrade an Existing System [Text Mode] but the result is the same. I also tried Jay73's recommendation of pressing Tab to edit my option and used the option he provided above (linux all-generic-ide irqpoll) and still reached the same point in the install.

3. Upon selecting an install type, a lot of text scrolls down the screen at a high speed.

4. The next screen I see says Welcome to Fedora 8 for I386 at the top. This screen has a blue background and a gray foreground and prompts me to choose a Language. I select English and then press Enter.

5. I am then prompted for "What Type of Keyboard Do You Have?", US is already selected so I press enter to continue.

6. I am prompted for Installation Method -- "What Type of Media Contains The Packages To Be Installed?" and my options are Local CD/DVD, Hard Drive, NFS Directory, FTP, HTTP.

7. I select Local CD/DVD and press Enter.

8. This screen looks like the others but says "No Driver Found" at the top and gives this as a description: Unable to find any devices of the type needed for this installation type. Would you like to manually select your driver type or use a driver disk? It gives me three options, Select Driver, Use a Driver Disk, Back.

9. I do not have a disk for any drivers for the cd drive so I choose to select a driver. Regardless of which driver I select - and I have tried them all - the screen locks up showing me "===Memory Map=== and a lot of number sequences and part of the previous install screen.

I hope this helps to shine a little light on the issue. I feel like perhaps it cannot locate the cd drive on this machine but given the age of the hardware and the simplicity of the machine I find that difficult to believe as well.

Thanks much for the help!


AwesomeMachine 08-26-2008 11:03 AM

I'd try debian.

gabelh 08-26-2008 11:37 AM

Well, that little exercise of typing it all out proved very beneficial. As it turns out, the CD drive these two machines were using (identical configurations) were so generic that I guess Fedora simply could not recognize them. I yanked a drive on the basis of suspicion from another machine and swapped it out. The install is running just fine now. It's always the little things that get me in the end.

I thank you for your responses.

keratos 08-26-2008 02:00 PM

section 6.26

cannot understand what the issue was.

must be your hardware and/or cable/CDROM jumper setup ??

All times are GMT -5. The time now is 04:02 AM.