-   Linux - Newbie (
-   -   Fedora 8 and ECS mobo install drive mapping problems (

ShadStar 03-23-2008 01:32 PM

Fedora 8 and ECS mobo install drive mapping problems
Hi guys

It's been a while but I need some help again. To cut a long story short I am having problems getting Fedore Core 8 to dual-boot beyond stage 2. Forgive the long post, I am just trying to pass on as much detail as possible...

I am using an ECS (Elitegroup) C19-A SLI mobo with two ide and four sata interfaces. Two (and only two) of my sata interfaces are set as a raid 0 (stripe), the rest are mapped as standard channel devices in the bios.

Brief description of my drive layout:
IDE drives:
Channel 0 Master: WD 232Gb IDE drive (Windoze... sorry...)
Channel 0 Slave: Pioneer DVR110 dvd-rw
Channel 1 Master: Generic dvd-rw
Channel 1 Slave: Maxtor 80Gb IDE drive

SATA drives:
IDE Mapped Channel 2 master: WD 200Gb sata drive (just for data, formatted as ntfs)

Of the three remaining sata channels, only TWO are mapped as raid 0 to two Excelstor 80Gb sata drives. These are not mapped through the bios but are mapped through the on=board raid controller. I use the raid drives for video editing and only ever store data on it.

The drive I am TRYING to install Fedore on to is the Maxtor 80Gb IDE drive on Channel 1, which I have partitioned (as a primary partition using the installer) in 3 parts: 200mb /boot partition (ext3), 1023Mb swap partition and the rest of the space partitioned as / using the ext3 file system.

The problem is that at install-time the Maxtor drive is mapped as hd2,0 sde1, sde3 and sde4.

Fedora will successfully install to the Maxtor drive using sde1/3/4 and will successfully write the boot loader to my original mbr no problem (I get a stage 1 boot and the grub menu so that works okay.) But on re-boot, as far as I can tell from the boot-time messages at stage 2, Linux now detects my drives in a completely different order than it did at install time.
The Maxtor drive is now detected and mapped as sdb1/3/4 and not sde1/3/4. The raid is now being mapped to sde1 and sde2 and of course when the kernel tries to access sde4 to find root it cannot access it because it doesn't exist.

Can I just mention at this point that I have tried a re-install and at the grub configuration stage I tried changing the drive order in the drive list so that the Maxtor is SECOND in the drive list BEFORE the install started (as suggested on-screen). This made matters worse and results in a non-bootable system as grub now maps root as hd1,0 instead of 2,0 so it fails to detect stage 2 altogether because it is looking at the wrong drive on re-boot). I have now gone back to leaving the drive list alone.

I can boot using the install disk (rescue mode) and get access to the installed system with the chroot /mnt/sysimage command, and I can then navigate the whole of the / partition no problem. I just can't get stage 2 to boot from the correct drive so that Linux will boot properly.

I have tried editing grub.conf and forcing the kernel to mount /dev/sdb4 but it still fails, and then tries to continue from "LABEL-SWAP-sde3" (I don't know how to change or edit labels...)

This is confusing me. Why should the kernel boot sequence detect and re-map drives differently from the installer? How can I stop it trying to go to sde3 which doesn't exist.

Forgive my plain ignorance, I am still really new to Linux and my knowledge is still quite limited, so I am not overly-familiar how linux works, I also know very few bash commands. But hopefully I am learning as I go...

Please point me in the right direction here, I woul VERY much appreciate it. How dumb am I being here, would installing linux on my primary drive be a better option? It would certainly get around the re-map problem.

Thanks in advance.

ronlau9 03-23-2008 03:06 PM

With boot loader do you use Suse . If so in suse 10.3 in yast you edit the boat loader and change it to meet you,re wisches
In suse 10.3 in the same option it is also possible to ask fore a new boot loader proposel
There might be a problem because a slave is never a boot able devices
I can imagine that this option are also suse 10.2 because it were already there in suse 9.3

all the best

ShadStar 03-23-2008 04:38 PM


Originally Posted by ronlau9 (Post 3097932)
With boot loader do you use Suse . If so in suse 10.3 in yast you edit the boat loader and change it to meet you,re wisches
In suse 10.3 in the same option it is also possible to ask fore a new boot loader proposel
There might be a problem because a slave is never a boot able devices
I can imagine that this option are also suse 10.2 because it were already there in suse 9.3

all the best

Hi, thanks for the reply (sorry another long post...)

No, I am using the installer that came with the Fedora 8 distro (anaconda), which sets up the grub bootloader for me. I did try to boot into the Fedora Rescue Mode via the dvd and update/re-install the bootloader. But whenever I try this it tells me that no kernel files are installed and will not update the bootloader. This is probably due to the drives being re-mapped during the detection process so the upgrader cannot find the correct drive with the kernel on it.

I may play with the suse 10.3 live cd and create a custom bootloader that way, grub is easier to play with in Suse than in Fedora I noticed. Thanks for the suggestion.

In desperation I also tried installing the grub boot loader onto the linux boot partition on the Maxtor drive, dd'ing it onto a floppy (bs=512 count=1) as a .bin file, placing it on my Windows 'C' drive and adding it as a boot option in the Windows boot.ini file, and then booting via the Windows ntloader interface. Worked perfectly and booted right into stage 2 but with the same problem, as soon as it hits Linux it is detecting the drives differently at boot than it did at install so it looks for the wrong drive to load the kernel from.

Maybe you are right about the drive being slave but I seem to remember booting Suse from a slave drive the last time I tried this (different motherboard though...)

I have tried editing the grub.conf file in rescue mode but it seems I may have to alter the association for 'label=swap-fde3' to try and re-map it to sdb4 (I notice during boot just before it fails, the kernel tries to resume from "swap".) However I don't know which file to edit to alter the association though, or if I should even try it. I am not that experienced with altering critical linux files, in particular Fedora files.

I think I am almost there though as I can actually get the kernel to uncompress and execute during grub stage 2, however I have to work out why the drives get changed around during the detection process. I cannot understand why they should be detected differently when booting compared to when the installer is running.

During install my drives are mapped as follows:
(Note when installing I boot directly from the distro dvd straight into the installer menu...)
CH0 Master mapped as sdd
CH1 Slave mapped as sde
CH2 Master mapped as sda
Raid mapped as sdb and sdc (2 x raid drives)

During normal boot my drives are mapped as follows:
CH0 Master mapped as sda
CH1 Slave mapped as sdb
CH2 Master mapped as sdc
Raid mapped as sdd and sde (2 x raid drives)

This is confusing me. As mentioned I have tried altering the drive order in the grub setup part of the installation to match the bios settings but it just results in an un-bootable system for some reason.

I've been at this for a while now and I think maybe I should just insert a couple of partitions into my primary drive and use that instead, however I don't like to be beaten ;-)

Over to you guys again...


ShadStar 03-23-2008 04:48 PM

Sorry, just an observation if it is of any help. I just ran a copy of explore2fs under windows and noticed that it does actually detect my Maxtor Linux drive as sdb NOT sde. Partition Magic also confirms that the Maxtor is the second drive.

This leads to another question, WHY does grub make an entry for this drive as (hd2,0) and WHY does it actually work? If I change it to (hd1,0) as it should be the system becomes un-bootable.

Whenever I use the Fedora anaconda installer it lists my Maxtor drive as (hd2,0) [sde]. This detection actually occurs BEFORE I get to configure grub, by which stage it already has the incorrect drive referrences.

This definitely seems to be the cause of the problem as it is referencing all the boot information (and labels) as sde instead of sdb, if anybody can throw light on this little mystery I would be eternally grateful...

Is there a bug in the anaconda hardware detection?


ShadStar 03-23-2008 05:53 PM

Well, that kinda confirms things...

I just booted from a Suse 10.3 dvd distro and investigated my Fedora installation.

First, it wouldn't boot using the "other options" option from the rescue menu.

Second, and more inportantly, it identified ALL of my drives CORRECTLY (Maxtor is identified as sdb and NOT sde.)

I am very suspicious at this stage of the anaconda hardware detection routines, but you guys may be able to throw better judgement on that one as I am not experienced enough to read or understand the source code (I may still be missing something obvious here...)

I will try a full install of Suse 10.3 under the same conditions and let you guys know what the score is.

Watch this space...


ShadStar 03-23-2008 07:46 PM

Okay, that worked then. OpenSuse 10.3 DVD distro detected and installed to the correct drive (sdb), installed a correct grub loader and booted painlessly to the Suse desktop without me having to change a thing (using the same physical drive setup as mentioned in my first post, no changes.)

The problem seems to be, as I suspected from the start, the Fedora anaconda installer is mapping my Maxtor drive as sde and not sdb.

During the proper boot process the drives are being detected correctly, however the drive-mappings in the boot-loader are pointing to the wrong drives due to wrong mapping at the install stage, ultimately causing a boot failure at stage 2.

Unfortunately because I am reasonably new to Linux I do not know how to correct this at the moment, but I am sure that the more advanced users out there will know how to get around this.

I think I may be missing something obvious here, like changing the order of the drive letters in the grub setup part of the anaconda installer maybe?

Please post any thoughts on this, I would still like to solve this one.


alan_ri 03-23-2008 08:03 PM

Will you try to install Fedora 8 on the hard drive without /boot as separate partition?

ShadStar 03-23-2008 10:18 PM


Originally Posted by alan_ri (Post 3098155)
Will you try to install Fedora 8 on the hard drive without /boot as separate partition?


Okay, I will try that. Please bear with me though as I need to catch up on some sleep. I will post back here as soon as I am conscious again :-)


ShadStar 03-24-2008 07:12 AM


Originally Posted by alan_ri (Post 3098155)
Will you try to install Fedora 8 on the hard drive without /boot as separate partition?

Hi, I am back and rested, and the story continues...

Okay, I tried your suggestion here and... it didn't work. I tried making the first partition as / and then I put a small swap partition at the end. I also tried with one single partition and let anaconda install a "virtual" swap partition. Neither option worked.

I seem to be running into the same problem, somewhere within the linux boot sequence it is determined to continue loading from what it has mapped as sde. The root of the problem here is the installer initially detecting and mapping my drives in the wrong order, which is then getting written to the bootloader.

I'm going to go back to my original install model and investigate a bit more to see exactly where this is happening...

Please keep the suggestions coming, I am still enjoying this challenge for the moment...


alan_ri 03-24-2008 12:34 PM

I belive this link will be useful to you.

ShadStar 03-24-2008 01:42 PM


Originally Posted by alan_ri (Post 3098866)
I belive this link will be useful to you.

Thank you, very helpful info in that thread. I also signed up to the forum as well. Appreciate it.

For anybody else reading this, just to let you know, I re-installed Fedora appending 'linux nodmraid' (thinking it may be the raid causing the mapping problem). That made things interesting because the Linux raid driver was obviously not loaded and it detected my raid drives as two ordinary drives with invalid boot partitions... and it STILL mapped the Maxtor to sde during install.

Maybe I should go back to OpenSuse... ;-)


ShadStar 03-25-2008 05:10 PM


Just some info for future readers of this thread, seems I have a problem with the raid driver not being installed at boot-time. It is loaded during install-time and then NOT being loaded during normal boot. This is what is causing the drive mis-map. Why the default anaconda raid driver is not being installed at boot-time... I don't know is the honest answer here. Suggestions welcomed on that one...

Still working on the problem with some (intermittent) help in the Fedora forums, and if I ever solve this one I will post a reply here.

If anybody can pitch in then please do, I only have a limited knowledge of how Linux works (although I am learning a lot more during this exercise). I do have a reasonable working knowledge of hardware and pc platforms, and I do have experience with working with Windows, I am just new to Linux so I am struggling a bit trying to find my way around.

Pointers and suggestions still very gratefully accepted at this stage...

Stevie (ShadStar)

alan_ri 03-25-2008 05:31 PM


Originally Posted by ShadStar (Post 3098926)

Maybe I should go back to OpenSuse... ;-)

If I may say my opinion,don't go back,stay with Fedora.I'm with you on this one,it's just that I only have one hard(IDE)disk,so,I never had to worry about other drives.I only had one problem with Anaconda when I tried to set /home as separate partition,so I'm learning too now,but I belive we will find a solution.:cool:

ShadStar 03-26-2008 03:16 PM


Originally Posted by alan_ri (Post 3100268)
If I may say my opinion,don't go back,stay with Fedora.I'm with you on this one,it's just that I only have one hard(IDE)disk,so,I never had to worry about other drives.I only had one problem with Anaconda when I tried to set /home as separate partition,so I'm learning too now,but I belive we will find a solution.:cool:

Thanks for the support, I appreciate it. I would like to stay with Fedora and I am going to do my very best to solve this little problem.

For the benefit of all, let me fill you in briefly with the latest situation.

My motherboard uses the nForce 4 Ultra Intel chipset variant.

I have tried numerous installs (around about 9 now) with various different approaches. The last one I did I tried disabling the raid controller and unplugging the raid drives, leaving me with just the ide and sata drives. This created another problem on install where my sata drive was being mapped as sda and the ide drives were sdb and sdc. On re-boot the sata drive was being mapped as sdc and the two ide drives as sda and sdb. Same problem as I had with the raid plugged in, different drive mapping.

I did find another thread at, and although it doesn't deal specifically with my problem, it does deal with the same problem of raid not being recognised on re-boot.

Noting that there was a known bug with previous kernels (FC6 distro in particular), and following some advice I got on the Fedora forums, I did update the kernel to using the yum update command from within rescue mode (my network controller is configuring okay so I do have internet access in rescue mode.) That didn't solve anything and it still did not load the raid drivers at boot-time. Even doing a FULL yum update (about 1 hour on my system) did not work for me.

This has made me think that Fedora does not natively support the nForce 4 chipset. nVidia definitely don't provide drivers or support for ANY flavour of Linux on the nForce 4 Chipset (why???), but they do support the graphic drivers:confused: This means I cannot download any Linux chipset driver for my nForce motherboard.

Without this driver I think I may not be able to solve this problem, unless I can find a similar driver that will work in it's place.

So I am now going to try email contact with nVidia (I won't hold my breath...) for their suggestions, and contact my mobo manufacturer (ECS) for their suggestions. In the meantime I leave you guys with another question... actually TWO questions...

1. Is there ANY way I can force-load the same raid and sata drivers that anaconda uses for installation, to load at boot-time during a normal boot?

My thought here is that when installing for the first time, the anaconda sata and raid drives are being detected properly. They are not in bios order but they ARE being mapped as proper drives. If I can force-load the same drivers at boot-time the drives MAY get mapped the same as at install time and not swap around, and I MAY finally get a successful boot.

2. WHY does Suse work, install and re-boot just fine with no mapping problems at all and WHY is anaconda not doing the same?

I have come to a stop at the moment as I am not quite sure what to do next, apart from getting some drivers for my chipset and hopefully pointing Fedora at them during install.

I am still very much alive on this one and would very much like to solve it. I will let you know if I get any luck with drivers. Any thoughts on my two questions would be very interesting to hear and any advice still welcomed.

Stevie (ShadStar)

alan_ri 03-27-2008 11:01 AM

If you have lost+found file in /boot/grub after installation post it here.Also post the output of grub.conf and version.Did you tried after installation to manually configure grub.conf file,so that grub knows where fedora's root partition is and to add other drives if they are not there?Also check the config file in the /boot directory,to see if there is something wrong.

All times are GMT -5. The time now is 11:10 AM.