LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-15-2007, 08:58 AM   #1
ehsan_moslemi
LQ Newbie
 
Registered: Oct 2007
Posts: 2

Rep: Reputation: 0
Talking Fedora 7 general query


Hi everybody,
I've just installed fedora core 7 in my Toshiba m45-s265 laptop, and it seems great. Contrary to other versions of Linux (Mandriva) which I need to find my hardware drivers, Fedora has found all of them. the problem is that when I connect my network cable, and it indicates that wired network is enabled now, few websites are just accessible (those which are available by default in Firefox) and any other website I enter comes up with "server time out" which I guess there should be a network problem (but at the side why just fedora and gnome websites are available ...sooooo weird!)
Does anyone knows what should it be?
if you need additional information please give me detail on how to get those information cause I'm a complete dummy.
 
Old 10-15-2007, 09:48 AM   #2
selva146
Member
 
Registered: Oct 2007
Location: INDIA
Distribution: Rehat, Fedora, RHEL
Posts: 47

Rep: Reputation: 15
Hi ehsan_moslemi ,
First try to confirm that your network is up and working fine by pinging to the node in the network.

If above point is ok then, check your network configuration. check the access

check access by the ip address of the web sites

otherwise give me some more details about your problem

selvaraju s
linuxmonk.blogspot.com
 
Old 10-15-2007, 09:55 AM   #3
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
you don't have any access. The default page that loads is local, so you are not accessing the interntet there.
Like selva suggested:
If you accessing the net through a router, try "ping 192.168.1.1"
"ping www.google.com" is a pretty reliable indicator if you have access or not.
How do you access the internet?
If you don't know you might have to go into the windows network config and look how it is set up.

Last edited by oskar; 10-15-2007 at 09:57 AM.
 
Old 10-15-2007, 10:46 AM   #4
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Since you're using F7, it's likely that the NetworkManager service is not being automatically started. Try running system-config-services from a terminal window (or just look for the "Services" item in the "System" menu if you're usin a GUI), check the box by the NetworkManager item, save the configuration, and click on "Start" to start the service. That should "automate" the network setup and discovery for you.

If you prefer to do it all by hand -- which is the default for Fedora -- you need to run system-config-network to set you a basic network profile, then (as "root") run ifconfig to configure the network and ifup to use that configuration to start the network. You also need to make sure one of the DNS servers is running (named or bind) to cache your DNS look-up results.
 
Old 10-17-2007, 09:00 AM   #5
ehsan_moslemi
LQ Newbie
 
Registered: Oct 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Dear friends,
Thank you for your replies, and sorry for delay. I use my ADSL modem, which use to work with windows and no complicated configuration was needed in windows, so I assumed that in linux it'll be the same. I connected the ethernet cable to my laptop LAN and it was indicated that I'm "connected to wired network" so I decided to surf internet which I was unsuccessful at. as I described lately, it has the access to some limited websites, which now I doubt maybe it's like pre-saved on my computer as a part of linux installation.
PTrenholme,
thank you for your detailed reply. I'm trying to find the procedure steps you described. if any one can help me with the first steps or a source database where I can start to diagnose problems in linux with it, because I'm like a virgin minded person in linux field. I know that something has to be done with "SElinux" (I'm not sure about the name though). it seems it's managing some programs to run and some don't. like "msconfig" in windows. I know it sounds weird, but I'm trying to switch from windows to linux. that's why I don't know anything about linux, specially Fedora.
 
Old 10-17-2007, 11:18 AM   #6
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
With you cable plugged in, the ifconfig should display something like this:
Code:
$ /sbin/ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:11:2F:7D:E6:3C
          inet addr:192.168.1.35  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::211:2fff:fe7d:e63c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:30889 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32554 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:20729353 (19.7 MiB)  TX bytes:5203671 (4.9 MiB)
          Interrupt:22 Base address:0x8c00
where the line in red is you system's Internet address. (The 192.168.-.- addresses are non-routable addresses, commonly used for "local" networks.)

Since your network works only for some addresses, it seems likely to me either that the DNS address is not being set correctly by your ADSL router, or, more likely, that you haven't specified that eth0 should automatically set its addresses from the information provided by the router.

To check the way eth0 is configured, click on System->Administration->Network. (Where "System" is, by default, in the top menu bar on the GNOME screen.) When the network configuration screen is displayed (after you enter your "root" password), select the eth0 line and then click on the "Edit" button. Verify that the "Automatically obtain IP address settings with dhcp" radio button is selected. (And that dhcp is selected in the list-box at the end of that line.) In the text-box below the radio button, make sure that the "Automatically obtain DNS information from provider" check-box is checked. (The "provider" in this case is you ADSL router.) If you've made any changes, click the "OK" button and then -- on the previous screen -- click first on the "Save" button to save your changes, then on the "Deactivate" button, and then the "Activate" button to apply the changes. Then quit the application, and see if the Internet is fully accessible.

Last edited by PTrenholme; 10-17-2007 at 11:22 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Xubuntu User - general package management query erraticassassin Ubuntu 1 03-16-2007 01:10 PM
General query: diff bw virtual vs. resident memory Kropotkin Linux - Newbie 3 02-06-2006 07:52 PM
QUERY: what is Fedora Core 4 mystery CD? kevingpo Fedora 1 09-09-2005 08:11 AM
MySQL Upgrade in Fedora query. stefaandk Fedora 0 06-23-2005 09:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration