LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Fedora 22 - Kali 2.0 Dual Boot and Woes (https://www.linuxquestions.org/questions/linux-newbie-8/fedora-22-kali-2-0-dual-boot-and-woes-4175555610/)

village_idiot 10-08-2015 05:41 AM

Fedora 22 - Kali 2.0 Dual Boot and Woes
 
I have a Dell box (laptop) M6500 installed with Fedora 22 first and
later added Kali 2.0. After installing Kali, booting Fedora produced
a 90 second time delay during boot, displaying the message "a start job
is running dev-disk-by 1x2duuid-... followed by a countdown timer.
Once the timer ends Fedora continues to boot and then displays the
GUI. The start job message does not occur on a virgin install of
Fedora 22 or after the stand-alone Fedora install reboots. This has
only occurred after installing Kali.

In the last install of Fedora/Kali I noted the uuid of the partitions
of the Fedora install. Then after installing Kali I compared the
partitions again. The 'swap' partition UUID had changed which would
seem to be the source of the start job message when booting Fedora
in the dual boot setup.

The solution would seem to be to go to the /etc/fstab and edit the
swap partition uuid in fstab to the uuid created by Kali so Fedora
can find the swap file. That however does not stop Fedora from running
the 'start job' with the 90 second countdown timer. Alternatively since
Fedora did not seem to crash without finding the 'swap' partition I
tried commenting out the uuid line in fstab in Fedora. On the next boot
the 'start job' looking for the 'swap' partition did not occur as far
as I can tell.

Is there a way to edit fstab so Fedora will find the current 'swap'
partition? Or is this like 'grub2' where you have to run grub2-mkconfig
on a text file?

Thanks in advance.

VI

syg00 10-08-2015 05:53 AM

systemd has a real problem with failed units - particularly on boot; can be a real PITA:
- first check you don't have that UUID in the boot-loader for a resume parameter.
- try this then reboot "systemctl reset-failed"

And congratulations - 8 years registered before your first post ... ;)

village_idiot 10-08-2015 06:20 AM

Thanks for the quick reply.

On this particular box I do not have a backup. If it crashes and
burns then I have the "lab drive" for a quickie re-install.

As for the eight year lapse in posting I have been very fortunate
that those who went before me had already encountered the problems
I experienced. Dad was big on using other people's experiences and
he wasted no time in inculcating the concept and practice of that
thought process. I guess you can call me a lurker. I watch an awful
lot. Thus far I have not had a problem that 'google' did not offer
a link to a useful answer.

village_idiot 10-08-2015 07:16 AM

Problem solved. Over the course of two days I failed to notice "the short between the headsets".
Once removed, the error in the UUID entry became apparent. Corrected the error and voila, Fedora
stopped balking over the missing 'swap' partition.

VI


All times are GMT -5. The time now is 07:31 AM.