-   Linux - Newbie (
-   -   fedora 10 installation DVD stuck on anaconda load (

masterchief1995 03-12-2009 10:49 AM

fedora 10 installation DVD stuck on anaconda load
Hi, I have been using linux for a while now and wanted to put fedora 10 on my desktop

-Dell Inspiron 2300
-256 MB of RAM
-15 GB partition available
-unsure of graphics card but I know that it is good
-Intel Inside Pentium 4 processor

I hope my computer is able to run it

Anyways, I am stuck at the part where anaconda is loading. There is no next button

Any help is greatly appreciated!:D

EDIT: Dell Dimension 2300

PTrenholme 03-12-2009 11:42 AM

Can you become more sure about your graphics card? If it is, for example, a nVidia card it may require a propitiatory driver. Anaconda will try to find a FOSS driver, but will not notice that the driver fails to work, and your install will hang.

When the install starts you should see a screen where you can "press tab to set options." At that scree,if you press "Escape" insteas of "Tab," you can enter the "linux text" command to have Anacondia run in text mode. That can get you installed, although you'll be limited to run level 3 and no graphics until you install install the correct driver and change the default run level. You may also find that your wireless connection is not available in run level 3.

Instead of all that, I'd suggest you download and burn several different distribution's live CDs and try them 'till you find one that works.

masterchief1995 03-13-2009 09:03 AM

graphics card
I think my computer does use nvidia because that's the driver I used for my windows partition but I will try what you said. Thank you very much.:D

DarkSlayer 03-26-2009 10:39 AM


and my setup stucks on step when it ask to choose media from which i want to install Fedora (DVD/CD HDD, NFS, URL) both errors on CD/DVD and HDD.

on CD it says that no drive found with inst image
on HDD it says that error finding install.img

cheksum is ok. have both install dvds i386 and x64

here is my thread with full description of problem and my hardware

linus72 03-26-2009 12:03 PM

OK-both of you can boot from USB right?
if you can boot from USB or even floppy-we can install Fedora 10.
As an alternative-download the Fedora-10-i386-netinst.iso or the NetbootCD-2.2.iso
( )
( )
Now, if using the NetbootCD it also can net-install Debian/Ubuntu/OpenSuse/Mandriva/CentOS/and Slackware 12.2-but you gotta know all the mirrors for Slackware.
Do you have a USB port that it can boot from??
If you have USB port but can't boot from-do you have a floppy drive??
I'm assuming you have a bootable USB port-if you don't post back and I'll tell you how to with a floppy drive...
Anyway-download either one and extract the iso to a folder-in Ubuntu just right-click on the iso-select "extract here".
Go into the folder it made-for this one we're gonna do fedora10 netinstall,
in the fedora 10 folder will be 2 folders-"images" and "isolinux".
Go into the isolinux folder ( goto the top of the file browser-click "edit"-now click "select all" and then "cut") and move all that stuff back up into the fedora 10 folder-now delete the empty "isolinux" folder.
Find the isolinux.cfg file-rename it "syslinux.cfg" by right-clicking on it-"rename".
Open the syslinux.cfg with a text editor-right-click-"open with...text editor".
Now put a "/" in front of all these words-

Now-sometimes "vesamneu.c32" doesn't work-So where it says "DEFAULT /boot/vesamuenu.c32" change it to

DEFAULT /boot/vmlinuz
APPEND initrd=/boot/initrd.gz ramdisk_size=6666 root=/dev/ram0 rw noauto load=netbootcd-startup.lzm noload=002;003;004;005;006

You won't get a splash screen so just hit enter when it boots up and says "boot-"
So just put that "/" wherever you see the words above in the syslinux.cfg.
Now-there's two ways to get SYSLINUX (ldlinux.sys) onto your USB-through the terminal or manually-
Terminal first-simply type "syslinux -s /dev/sdxx" where "xx" is your USB-if your USB is sdf1 it would be "syslinux -s /dev/sdf1" that will install syslinux to the USB-BUT IF YOU DON'T KNOW YOUR USB YOU COULD INSTALL IT TO YOUR HARD DRIVE-BE CAREFUL!
The manual way is easier and safer! Download "Billix" for USB-
( )
Now, same thing-extract Billix to a folder-go into the Billix folder and find "ldlinux.sys"-this is SYSLINUX! Move/copy this into your USB by using copy/paste-now you have syslinux installed to USB!
Set the "bootable flag" on your USB by opening Gparted-select "Gparted" up top and select "devices" and you should see the usb-it should look like this(the highlighted blue line-screenshot.
Right-click on the blue line-select "manage flags" and check the "boot" flag.
Your almost done=Now you must know the URL for the full Fedora10-here's the Fedora10DVD url-
( )
Your set-reboot and download Fedora!
NetbootCD should have the mirrors for you, maybe-here's the usb install-
As before extract the netbootcd iso to a folder-if an error comes up you can use "Gmountiso"-right-click on the iso and select "open with Gmountiso"-when it opens click the "open" tab for the "mount point"-choose CDROM0 or whatever.
Now hit the mount button-Now hit the "jump to" button.
A folder will open up with the iso contents-go to the top of the browser and click "edit", "select all", and "copy"-it won't make a folder so paste the contents into an empty folder.
OK-now go into the netbootcd "boot" folder-now rename "slax.cfg" to "syslinux.cfg". Now-right-click on the new syslinux.cfg-"copy"-Now go into the syslinux folder-right click on any empty area and select "paste"-then choose "replace" when the thing pops up.
Now go back up to the top folder where the "boot", "slax", "gpl-2.0.txt", and gpl-3.0.txt" is-again paste the syslinux.cfg here.
Now-copy all that to your USB Drive-not the top folder-just the folders and files-"boot", "slax", "gpl-2.0.txt", and gpl-3.0.txt".
Now move the ldlinux.sys you got from Billix to the USB (copy/paste)
That's it Reboot and choose the fedora 10 netinstall from the netbootcd after it boots up.
Additionally you could try to get anaconda to find the iso on your HD but good luck.

linus72 03-26-2009 12:53 PM

Note that I did this in Ubuntu 8.10-but you could also do it in 8.04-even running "live" from CD on a Windows computer.
Also-I don't know if the NetbootCD-2.2 has the Fedora 10 Mirrors built in or whether it will just start Anaconda and then ask you for the mirror url's.
Additionally-you could install one of the Fedora CD's to the USB or the DVD if you have a big enough USB-but I don't know if it will install via USB??

DarkSlayer 03-26-2009 01:05 PM

@ linus72

man u r insane :P

yea i do have bootable usb port, and floppy as well

and now i'm using Windows XP x64 so i've to translate "Ubuntu" commands to Win commands :)

and now i'm really tired. i should read ur HUGE post really carefully, coz it's little bit mess for me now:)

thanks a lot !!!

linus72 03-26-2009 01:08 PM

Naw-just do the USB installs running the Ubuntu 8.04/8.10 CD live.
That way you don't touch Windows and can do all the stuff you need.
Why am I insane? Bad insane or good insane?

DarkSlayer 03-26-2009 03:27 PM

Good insane ! :)

gemmun 03-27-2009 06:22 AM

When I installed my Centos 5 I had a similar problem. Using the downloaded DVD iso image it failed. So I downloaded the multiple CD images and it worked. The disk checker/verifier built in only worked with CD installation and they had failed to remove it for the DVD distro. So it might well be the case that your DVD is not suitable. If you have the option of multiple CD installation it might work

All times are GMT -5. The time now is 07:37 PM.