LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-22-2009, 06:36 PM   #1
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 632

Rep: Reputation: 33
Fedora 10, Epson Stylus DX 4200 : not printing images from pdf


I have a document (openoffice writer) with several images (jpg and png) which I converted to a pdf-document.

When I print this document, I notice that some images are printed out but the majority is just white space... The printer skips the images and simply does not print them out.

They are clearly there in the writer document and in the pdf-document.

When I attached the printer to my usb-port, it was automatically detected and I could print immediately. Did not noticed anything wrong...

Till now.

What info can I give to find this error ? Does it have something to do with the driver (thought it was gutenprint) or with PostScript ??

Thanks for the help !
 
Old 03-22-2009, 08:40 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,229

Rep: Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522
did those .png images have a alpha channel if so that might be the problem

open them in gimp and select
image / flatten
then hit " ctrl + s " to save
then re import the oo file and reexport it to pdf

gimp will also open pdf's
 
Old 03-23-2009, 03:05 AM   #3
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 632

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by John VV View Post
did those .png images have a alpha channel if so that might be the problem

open them in gimp and select
image / flatten
then hit " ctrl + s " to save
then re import the oo file and reexport it to pdf

gimp will also open pdf's
I have Gnome but for editing images I happily use KolourPaint. I just resized and cut some images with this program.
Don't know if they have an alpha channel... must look into it.
Also I must look if it is only the png-images that are missing...

Will get back on this later on this day.
 
Old 03-23-2009, 11:47 AM   #4
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 632

Original Poster
Rep: Reputation: 33
The images that are missing are png-images. But there are png-images that are printed, and then other images that are not printed. Just miscellaneous...

Can't see a difference. Would say those who I've opened and edited with KolourPaint... but there are edited pictures that are printed also.

Pictures that I toke from google and did not edited are also not printed... and then some are.


EDIT : I now have edited 1 image with Cinepaint. This also has an option to flatten... I've re-imported the image into my writer-doc and then re-exported to pdf. I've tested a print-out with this 1 image and it printed !

So I guess I need to do this now with all my images...

Thanks for the help.

Last edited by jonaskellens; 03-23-2009 at 12:08 PM.
 
Old 03-23-2009, 01:37 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,229

Rep: Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522
in film gimp " Cinepaint" you DO NOT want or need to flatten the film sequence .

can you check the properties of those images , they MIGHT be .jpg's miss labeled as .png's
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Printing problem - EPSON STYLUS C41 SX arindom Linux - Hardware 3 03-10-2008 11:07 PM
Printing Issues with Epson Stylus C86 hitest Debian 6 12-22-2005 03:43 AM
Epson Stylus C60 - not printing (knoppix) asrisk Linux - Hardware 0 07-04-2005 07:51 AM
Printing barcodes on Epson Stylus C86 edjones Programming 1 06-30-2005 05:37 AM
Epson Stylus C60 Printing Problems HadesThunder Linux - Newbie 9 05-14-2004 08:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration