Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 06-07-2005, 06:29 PM   #1
LQ Newbie
Registered: Sep 2004
Posts: 2

Rep: Reputation: 0
Fedora 1 and True-Type font installations


I have a ClickART font CD full of True-Type fonts. (the copyright date is 1995.) I would like to install some of these fonts on a Fedora Core 1 system using Gnome.

I understand that the "easy" way to do this is to open fonts:/// and drag the font files into that window. But it will not let me do that.

I have tried copying the files to a folder on my desktop first and ensuring the permissions are properly set (or, at least, set the same as the permissions for the other font files in the fonts:/// directory), and have tried renaming the font files from husten__.ttf to Hustle.ttf, and then to Hustle (with no extension). But regardless of what I do, it will not let me copy the files into the fonts:/// directory, either by drag-and-drop, or by copy/paste (or cut/paste).

I've also tried copying the .ttf files directly into /usr/X11R6/lib/X11/fonts/TTF, which made them available to Writer, but not to GIMP, which is where I really need them.

All of this was done as root, for what it's worth.

Any information on what I can do to get these buggers installed would be most appreciated.


-- b.r.t.
Old 06-08-2005, 02:05 AM   #2
Senior Member
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
Create the directory ~/.fonts if it doesn't already exist. Copy the ttf files to that directory and then run fc-cache -v. If you look at the output of the command you should see your ~/.fonts directory being scanned and the fonts being added to the font cache.

This will enable all XFT-aware applications to use your fonts (Gimp 2.x should work fine). You may have to log out and then log in again if it doesn't work as expected.

Old 06-09-2005, 07:16 AM   #3
LQ Newbie
Registered: Sep 2004
Posts: 2

Original Poster
Rep: Reputation: 0
hw-tph --

Thank you for taking the time to respond.

I understand that the ~/ refers to my home directory. If I wish for these fonts to be available to all users, obviously I could put one of these directories out there for each user and do this. But is there a more central location I could use to avoid the duplication?


-- b.r.t.
Old 06-09-2005, 07:25 AM   #4
LQ Guru
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
You can create a directory like /usr/share/fonts/ttf/msfonts. Copy the fonts there and then do "mkfontdir" and "mkfontscale".


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
xfsft True Type font support. andy_england1985 Linux - Newbie 25 08-26-2005 03:40 PM
Slack 10, KDE and Mozilla, true type font how-to? Slovak Slackware 2 12-12-2004 12:00 PM
Web browsing - True Type font thread DrD Linux - Software 5 10-31-2004 03:39 AM
true type font on fedora 2 isso Fedora 2 06-24-2004 05:16 AM
Weird true type font... can't be installed?? romasport Linux - General 1 03-20-2004 01:51 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:02 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration