-   Linux - Newbie (
-   -   fdisk and cfdisk problems (

LokiPartera 10-25-2002 08:30 PM

fdisk and cfdisk problems
I have a machine that was running RH 7.2, I'm trying to put a full install of Gentoo on it right now. Install went fine till time to partition the hard drive...

fdisk and cfdisk think my 20GB hd is 233 MB total in size with no partitions. It had a standard RH partition setup before I tried to install Gentoo.

Don't really know what direction to go in to try and fix this..

nizo505 10-29-2002 01:43 PM

I have never used gentoo, but you might do a redhat install, and when it asks you to partition the disk (before the install), use fdisk to delete whatever partitions are already defined, and bail out of the RedHat install and try the gentoo install again. Presumably gentoo has a way to setup/partition a disk that doesn't have any partitions on it?

Thymox 10-29-2002 01:50 PM

Welcome to LQ, the pair of you.

Are you doing this on a fairly old computer, or is it fairly new? Perhaps you need to specifically tell Linux, at boot time, the physical size of your drive. If you go into your BIOS and find out it's properties (C/H/S), then you can pass those to the kernel as boot parameters.

Just a suggestion.

LokiPartera 10-30-2002 01:11 AM

Used the RH install disk to look at the partions... It sees a 20GB hard drive like it should. My computer is about 3 years old, a Compaq Presario 5868 to be exact. The hd is a Western Digital so nothing unusual there. After using the Druid partition manager in RH I tried Gentoo again to the same results. Then I tried fdisk from the RH install disk, and that didn't change anythng... I have even gone so far as to use the partition manager on a WinXP install disk <shiver>

I think it's a problem with fdisk or the gentoo install program not correctly recognizing the hard drive, unfortunately I have no clue how to fix that. Suggestions are greatly appreciated!

Great suggestion Thymox! How do I do that?

moses 10-30-2002 01:48 AM

What do you mean by "tried fdisk from RH install disk and that didn't
change anything"? Did you try writing the partition table and it failed,
or did it correctly write the partition table, but Gentoo isn't buying it?
Have you tried setting up your partitions with RH, then skipping the
partition portion of Gentoo's install?
How are you partitioning your disk? (extended partitions? DOS partitions?)
Post your partition table (from RH) here, if it's at all possible. . .

LokiPartera 10-30-2002 03:17 PM

Think I figured it out. I was writing down the partition tables to post when I noticed that the correct table from RH's fdisk was look at /dev/hdc NOT /dev/hda like it did in Gentoo. When I jumped into fdisk in Gentoo and used /dev/hdc it showed my my correct hard drive!!! Thanks for the suggestions all!

lopoetve 10-30-2002 05:13 PM

yea easy solutions! :D

btw, have you done any more work on that crappy ASM file yet?

All times are GMT -5. The time now is 03:44 AM.