LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-16-2021, 07:37 AM   #1
stao8095
LQ Newbie
 
Registered: Feb 2021
Posts: 4

Rep: Reputation: Disabled
Fcitx configure current input mehtod can not work


Every time when I click fcitx configure "Configure Current input Method" I'll get follwoing message.

You're currently running KDE, but KCModule for fcitx couldn't be found, the package name of this KCModule is usually kcm-fcitx or kde-config-fcitx. Now it will open config file with default text editor.

I've tried my best to install kcm-fcitx/kde-config-fcitx, but I could not find them.

Could you please help provide some useful information?

Thanks

By the way, it is slackware OS.
 
Old 02-17-2021, 11:29 PM   #2
Brains
Senior Member
 
Registered: Apr 2009
Distribution: Debian Testing, Gentoo
Posts: 1,293

Rep: Reputation: 352Reputation: 352Reputation: 352Reputation: 352
Firefox search tool found nothing regarding fcitx in this webpage.
And this place has a github link to the source, looks like you have to compile from source. It also says it is dependent on KDE4. Current version of KDE Plasma is 5.20, if you are running KDE Plasma 5, you're out of luck.
 
Old 02-18-2021, 08:05 AM   #3
michsailboats
LQ Newbie
 
Registered: Feb 2021
Location: Paspébiac
Distribution: Bodhi Linux
Posts: 1

Rep: Reputation: Disabled
If you have slackware running properly you might have pkgtool. So do the following

$sudo pkgtool

Find the directory tree that gives you input method and language setting options and tweak to your liking on the language pair(s).

I am using Debian and would simply use

$sudo apt-get update
$sudo apt-get install kcm-fcitx/kde-config-fcitx

to install everything that you've mentioned in your post.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fcitx can not input Chinese huangxiaohui Linux - Newbie 0 12-11-2012 03:44 AM
emacs can't use fcitx input method flyer103 Slackware 1 05-11-2011 03:05 AM
Fcitx: How does one configure Fcitx? The input and control panels too small to read. harryhaller Slackware 11 06-09-2008 12:37 AM
why couldn t input chinese with fcitx? ukyo Debian 0 03-27-2006 10:41 PM
FCITX failed to input on VECTOR linux 4.3! prctom Linux - Software 0 10-01-2004 10:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration