LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   FC3 mouse problem w/ KVM (https://www.linuxquestions.org/questions/linux-newbie-8/fc3-mouse-problem-w-kvm-254538/)

nerfball 11-13-2004 09:21 PM

FC3 mouse problem w/ KVM
 
I'm having a problem with a PS/2 mouse and Fedora Core 3. I am running multiple PC's from one Belkin KVM switch. When I switch between PC's I loose mouse control in FC3. Kind of annoying to say the least.

I did a search and found some similar problems in other threads but no one seemed to find an answer. Can somone help me out with this glitch? :scratch:

Thanks!

nerfball 11-14-2004 08:03 AM

No one has a thought on this? Please? I would rather not have to use a seperate mouse for the Linux machine.

michaelshiloh 11-15-2004 08:59 PM

solution for erratic mouse with kvm switch
 
take a look at this:

http://www.idevelopment.info/data/Un...elkinKVM.shtml

(I didn't write it, but just stumbled upon it right before I stumbled upon your question)

If this works, drop me a note.

Michael

nerfball 11-16-2004 06:08 AM

Yeah, I had already tried that... it has no effect. At this point I think I'm just going to try getting a different KVM switch, if it works then I know what is causing it, if not then I just return it. Nothing lost except some troubleshooting time.

Thanks though!

protonos 11-26-2004 07:13 AM

Hi,

I have the same problem when switching from a windows box to a FEDORA 64 core 3.
The only solution I found for not to reboot the machine is, when on fedora, unplug the mouse from the KVM (BELKIN) and plug it anew.
I'm strongly interested in finding a solution as I plan to use 4 fedora boxes on a KVM.
Thanx

WL

Micro 12-06-2004 05:54 PM

Belkin 4port KVM/ fedcore3/XP/rh9/win2k Mouse problems
 
This is intresting now when I switch from anywhere to RH9 the ctrl alt f5 then the ctrl alt f7 works. However when I tried the same going from anywhere to Fedora Core 3 it doesn't. One other note as far as RH9 goes when you switch to it you can also do ctrl esc to bring up main menu then using keyboard arrows go to system settings and run the mouse program just hit tab twice then enter. Once you run it once from KDE atleast there will be a shortcut on the main menu. As far as Fedora core 3 goes I have a Microsoft USB optical wheel mouse. Of course the belkin KVM is all PS/2 So I had to use the PS/2 to Usb converter. So low and behold when I switch to Fedora I just pull out the Usb end from the coverter and plug it back in and it works. While this is good there has to be a reason why this happens. While trying to troubleshoot this in RH9 I noticed when I exited KDE and from the command line the console mouse was still running it also was erratic. So from the command line I ran setup. When the setup program ran I choose mouse and did the same as if I was back in KDE and it worked. Whats intresting is that when I switch from one microsoft product to another I never have a problem. The only thing I can figure is that it must have somthing to do with the way the mouse driver interacts with the OS on both Fedora and Redhat 9. I dont think it is a GUI thing or even an X thing unless its how those two interact with the mouse driver. I think what happens when you switch the mouse driver on the linux side no matter the distro sees the PS/2 mouse as dissconected and when you switch back it does not sync up right. The only thing I can figure is that microsoft has written there drivers to point to a null of some sort so that when switched back it was as if it had been connected the whole time. Or more likely they sync up on boot and just always assume its connected. The funny thing is I had it working once and forgot how I did it.



Need hardware help visit http://www.microtrip.net

Brian1 12-06-2004 06:17 PM

A few things I read about. Switch to alt-ctrl-F1 before leaving your linux box. Then when you return you can hit alt-ctrl-F7 to get back to the gui portion.

One problem I had with my cybex 8 port unit was when going from my winblows 2000 box to linux, I would get the letter q after anything I typed when I stopped for about 2 seconds. I backspaced the q it would return. Never had the problem before but I just remembered I added the correct drivers for the multimedia keyboard. Went back to the winblows box changed it back to a standard 104 keyboard and never had the problem again. It was a Logitech wireless keyboard.

Brian1

J.W. 12-06-2004 07:31 PM

I had problems with a Belkin KVM too, and regardless of whether I started in Windows or Linux, I could only switch over to the other OS one time - I could never get it to successfully switch back. Maybe there were/are ways to configure things so that the problem wouldn't occur, but I just got so fed up with dealing with it that I took a more drastic route, and replaced the Belkin with a Trendware model. No problems since then. YMMV. -- J.W.


All times are GMT -5. The time now is 09:41 PM.