LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-19-2005, 02:51 AM   #1
chylde
LQ Newbie
 
Registered: May 2005
Location: NC
Distribution: Slackware, now FreeBSD
Posts: 23

Rep: Reputation: 15
Question FC3, installing a new xscreensaver


[root@localhost i386]# rpm -iv xscreensaver-base-4.21-1.i386.rpm
Preparing packages for installation...
file /etc/pam.d/xscreensaver from install of xscreensaver-base-4.21-1 conflicts with file from package xscreensaver-4.18-4
file /usr/X11R6/lib/X11/app-defaults/XScreenSaver from install of xscreensaver-base-4.21-1 conflicts with file from package xscreensaver-4.18-4

I want to install xscreensaver 4.21-1, I built all the RPMS from a .tar file. The last time i tried to do a replace file, it messed up my xscreensaver badly, i couldn't get any screensavers to run.

Any help would be greatly appreciated.
 
Old 06-19-2005, 05:36 PM   #2
rkettle
Member
 
Registered: Jun 2005
Posts: 204

Rep: Reputation: 30
remove your ealier version and reinstall

Regards
Richard
 
Old 06-20-2005, 12:19 AM   #3
chylde
LQ Newbie
 
Registered: May 2005
Location: NC
Distribution: Slackware, now FreeBSD
Posts: 23

Original Poster
Rep: Reputation: 15
Yeah, i tried that, using the rpm -ev xscreensaver, this is the response i get.

[chylde@localhost ~]$ rpm -ev xscreensaver
error: Failed dependencies:
xscreensaver is needed by (installed) kdeartwork-3.3.1-1.i386
So, should i use a force command, or should i uninstall kdeartwork? I tried to do do it, while KDE wasn't up and running. Thanks so much, tho, I should have put that in my first post.

Chylde
 
Old 06-21-2005, 01:36 AM   #4
chylde
LQ Newbie
 
Registered: May 2005
Location: NC
Distribution: Slackware, now FreeBSD
Posts: 23

Original Poster
Rep: Reputation: 15
Ok, this is the result I got from trying to use yum, to uninstall xscreensaver 4.18-4:

[root@localhost chylde]# yum remove xscreensaver.i386
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package xscreensaver.i386 1:4.18-4 set to be erased
--> Running transaction check
Setting up Repos
http://mirror.netglobalis.net/pub/fe...ta/repomd.xml: [Errno 4] IOError: <urlopen error (110, 'Connection timed out')>
Trying other mirror.
base 100% |=========================| 1.1 kB 00:00
updates-released 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2622/2622
primary.xml.gz 100% |=========================| 330 kB 00:02
MD Read : ################################################## 848/848
updates-re: ################################################## 848/848
--> Processing Dependency: xscreensaver for package: kdeartwork
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kdeartwork.i386 0:3.3.1-1 set to be erased
--> Running transaction check

Dependencies Resolved
Transaction Listing:
Remove: xscreensaver.i386 1:4.18-4
Remove: kdeartwork.i386 0:3.3.1-1
Total download size: 0
Is this ok [y/N]: N
Exiting on user Command
Complete!
[root@localhost chylde]#

My questions is, should i just uninstall kdeartwork, and reinstall it after i uninstall xscreensaver 4.18-4, then install xscreensaver 4.21-1?
 
Old 06-21-2005, 02:01 AM   #5
mvan83
LQ Newbie
 
Registered: Jun 2005
Distribution: Fedora
Posts: 19

Rep: Reputation: 0
Re: FC3, installing a new xscreensaver

Quote:
Originally posted by chylde
[root@localhost i386]# rpm -iv xscreensaver-base-4.21-1.i386.rpm
Preparing packages for installation...
file /etc/pam.d/xscreensaver from install of xscreensaver-base-4.21-1 conflicts with file from package xscreensaver-4.18-4
file /usr/X11R6/lib/X11/app-defaults/XScreenSaver from install of xscreensaver-base-4.21-1 conflicts with file from package xscreensaver-4.18-4

I want to install xscreensaver 4.21-1, I built all the RPMS from a .tar file. The last time i tried to do a replace file, it messed up my xscreensaver badly, i couldn't get any screensavers to run.

Any help would be greatly appreciated.
Have you tried running rpm -Uv xscreensaver-base-4.21-1.i386.rpm ? That's what you're supposed to do to upgrade an existing package via rpm. It should handle removing old unnecessary files from the old package (while leaving any config files, etc.).
 
Old 06-22-2005, 01:47 AM   #6
chylde
LQ Newbie
 
Registered: May 2005
Location: NC
Distribution: Slackware, now FreeBSD
Posts: 23

Original Poster
Rep: Reputation: 15
Yeah, I did that, but the first time, all my screensavers just went blank, they wouldn't even run in test anymore. I see now what I did wrong. I forgot to run the ln command, to relink.
Hehe, I guess that's the price you pay for being a newbie, lol. Thanks a lot guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] installing FC3 politik Linux - Newbie 11 06-15-2005 11:23 PM
installing IE in FC3 dr_zayus69 Linux - Software 9 01-26-2005 07:52 PM
FC3 not installing Redwraith111 Fedora 5 12-26-2004 08:50 PM
Installing reiser4 under fc3 aesahaettr Fedora 2 12-01-2004 10:30 PM
xscreensaver installed, but no xscreensaver-demo command? dalesan Linux - Software 7 09-01-2004 02:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration