-   Linux - Newbie (
-   -   FC2 yum updated to 2.1.11 need new yum.conf? (

peregrine2 11-26-2004 12:02 AM

FC2 yum updated to 2.1.11 need new yum.conf?
I ran my usual update for FC2 and along with everything else, yum was updated from 2.07 to 2.1.11. Now I cannot use yum. Instead of downloading headers it tries to set up an Update Process which it cannot do.
[root@vectra karen]# yum update
Setting up Update Process
Setting up Repo: dag
Cannot open/read repomd.xml file for repository: dag
failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
From searching the forums, I understand this version requires a different format for the yum.conf file. What is my best option? Can I uninstall 2.1.11 and reinstall 2.0.7 without causing any problems? If it is best to keep the later version of yum, I will have to replace my yum.conf file since it no longer works. Would I use the one from or for FC3 even though I am running FC2? Also there is now a yum.repos.d directory that is empty. Any advice will be appreciated.
I reverted to yum2. 0.7 , I will stay there until I upgrade to FC3

Rockfish 12-02-2004 07:14 AM

yum 2.1.12 vs 2.07
I encountered pretty much the same problem and tried to run it down last night. The quick description is that yum updated yum to a 2.1 version, and now yum won't work because all the repositories you have in your yum.conf are not set up with the repomd stuff. So, what to do?

After visiting all the repositories in my yum.conf, I found that only ATrpms had yum 2.1.12. The at-stable site was set up properly for 2.1.12, but none of the other sites I visited were. I decided to downgrade yum to 2.07 and comment out the at-stable site (in yum.conf) for the time being. An alternative would be to stay at yum 2.1.12 and use only the ATrpms sites. I hope this helps.


All times are GMT -5. The time now is 06:46 PM.