-   Linux - Newbie (
-   -   fc17 yum software update fails (

pbseisman 08-17-2012 11:48 AM

fc17 yum software update fails

This is my first post. I have been using linux for some months now, recntly upgrading to Fedora Core 17. I am running fc17 x86_64 on my laptop. Only recently, when I come to run "Software Updates" or do a yum update as root, the process fails with the message:

# yum update
Loaded plugins: langpacks, presto, refresh-packagekit
fedora/metalink | 29 kB 00:00
Traceback (most recent call last):
File "/bin/yum", line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/", line 319, in user_main
errcode = main(args)
File "/usr/share/yum-cli/", line 144, in main
result, resultmsgs = base.doCommands()
File "/usr/share/yum-cli/", line 485, in doCommands
return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
File "/usr/share/yum-cli/", line 405, in doCommand
return base.updatePkgs(extcmds, update_to=(basecmd == 'update-to'))
File "/usr/share/yum-cli/", line 890, in updatePkgs
File "/usr/lib/python2.7/site-packages/yum/", line 4364, in update
updates = self.up.getUpdatesTuples()
File "/usr/lib/python2.7/site-packages/yum/", line 1032, in <lambda>
up = property(fget=lambda self: self._getUpdates(),
File "/usr/lib/python2.7/site-packages/yum/", line 837, in _getUpdates
self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(), self.pkgSack.simplePkgList())
File "/usr/lib/python2.7/site-packages/yum/", line 1013, in <lambda>
pkgSack = property(fget=lambda self: self._getSacks(),
File "/usr/lib/python2.7/site-packages/yum/", line 777, in _getSacks
File "/usr/lib/python2.7/site-packages/yum/", line 302, in populateSack
File "/usr/lib/python2.7/site-packages/yum/", line 127, in doSetup
File "/usr/lib/python2.7/site-packages/yum/", line 83, in retrieveAllMD
if repo._async and repo._commonLoadRepoXML(repo):
File "/usr/lib/python2.7/site-packages/yum/", line 1329, in _commonLoadRepoXML
result = self._getFileRepoXML(local, text)
File "/usr/lib/python2.7/site-packages/yum/", line 1107, in _getFileRepoXML
size=102400) # setting max size as 100K
File "/usr/lib/python2.7/site-packages/yum/", line 920, in _getFile
result = self.grab.urlgrab(misc.to_utf8(relative), local,
File "/usr/lib/python2.7/site-packages/yum/", line 606, in <lambda>
grab = property(lambda self: self._getgrab())
File "/usr/lib/python2.7/site-packages/yum/", line 601, in _getgrab
File "/usr/lib/python2.7/site-packages/yum/", line 566, in _setupGrab
urls = self.urls
File "/usr/lib/python2.7/site-packages/yum/", line 786, in <lambda>
urls = property(fget=lambda self: self._geturls(),
File "/usr/lib/python2.7/site-packages/yum/", line 783, in _geturls
File "/usr/lib/python2.7/site-packages/yum/", line 729, in _baseurlSetup
File "/usr/lib/python2.7/site-packages/yum/", line 826, in <lambda>
metalink_data = property(fget=lambda self: self._getMetalink(),
File "/usr/lib/python2.7/site-packages/yum/", line 799, in _getMetalink
result = ug.urlgrab(url, local, + "/metalink")
File "/usr/lib/python2.7/site-packages/urlgrabber/", line 1127, in urlgrab
return self._retry(opts, retryfunc, url, filename)
File "/usr/lib/python2.7/site-packages/urlgrabber/", line 1021, in _retry
r = apply(func, (opts,) + args, {})
File "/usr/lib/python2.7/site-packages/urlgrabber/", line 1118, in retryfunc
_TH.update(url, fo._amount_read - fo._reget_length, time.time() - tm, None)
File "/usr/lib/python2.7/site-packages/urlgrabber/", line 2293, in update
File "/usr/lib/python2.7/site-packages/urlgrabber/", line 2273, in load
_TH.hosts[host] = int(speed), int(fail), int(ts)
ValueError: invalid literal for int() with base 10: '-->'

I have tried running yum clean all, with no results.

Any help would be appriciated.

John VV 08-17-2012 08:54 PM

HOW exactly did you " recntly upgrading to Fedora Core 17"


by the way fedora DROPPED the "core" way WAY back in fedora 6
there is on OS called fedora core the last one was "fedora core 6 "

was this a fedora 16 that you ran "preupgrade" on
used the DVD to upgrade fedora 16
a new install of fedora 17

python errors are often caused by manually installing a conflicting version of python
the older pthon 2 in the fedora 17 update repo IS the version REQUIRED ( yum is still using python 2 and NOT the 3 that is ALSO installed)

pbseisman 08-18-2012 03:25 AM

Hi, Thanks for getting back.

I have previously been running Fedora 15, which I upgraded to Fedora 16, but then did a clean install of Fedora 17, using a DVD that I burnt from the download from the Fedora download website. I had successfully run two software updates before encontering the problem I now have.

How do I go about getting yum working properly again?

pbseisman 08-30-2012 11:38 AM

It seems that this is a tough one - I have still not found a solution for this and presumably neither has anyone else on this forum. It would seem taht my only solution is to make a clean re-install......

Habitual 08-30-2012 03:24 PM

The first command I always run is

yum update yum

yum update

John VV 08-30-2012 03:43 PM

by chance did you turn on the "rawhide" or "updates-Testing" repos?????
the normal way to find out is

su -
yum repolist all

but that will not work
so MANUALLY look in /etc/yum.repo.d/???? and list all the repos that have "enabled=1"
that is ON
"enabler=0" is off

that python error looks like it is do to a mismatch of python
a python 2.6 VS 2.7

ValueError: invalid literal for int() with base 10: '-->'

you might try manually replacing the fedora yum and rpm "rpm's"


pbseisman 09-05-2012 03:49 AM

Habitual - thanks for the suggestion but entering the command "yum update yum" produced the same error message as before, as did all yum commands.

John VV - I checked to see what repos are enabled, things looked fine. I came to the conclusion after spending hours with your suggestion of replacing the various rpm's, but must agree that that the error was one of a mismatch of python 2.6 v 2.7. Still not sure how this came about.
I have now done a clean install of Fedora 17, things are working fine now.
Thanks for the help and advice.

All times are GMT -5. The time now is 12:23 PM.