LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-28-2004, 01:26 PM   #16
satish427
Member
 
Registered: Aug 2004
Location: India
Distribution: Elx, RH9, Knoppix 3.6, FedoraCore3(test2)
Posts: 53

Rep: Reputation: 15
Unhappy


Well i just installed 2.6.8.1 and am facing the same situation
in fstab it is not loadin as unknown extension
I think i shall try the auto option given by one of the members if anyone has any other option reply soon
 
Old 09-28-2004, 11:23 PM   #17
KidKootenay
LQ Newbie
 
Registered: Apr 2004
Location: Victoria, Canada
Distribution: Gentoo
Posts: 4

Rep: Reputation: 0
Well I got this working. I don't know if its the same for the rest of you. It was really stupid of me. I need the correct kernel modules installed.
Code:
File Systems ----->
     ----->Native Language Support
                 (iso8859-1) Default NLS Option
                  <M>      Codepage 437
                                     :
                                     :
                  <M>      NLS ISO 8859-1             <--this was missing
Hope this helps some one else
 
Old 10-07-2004, 10:31 PM   #18
osuchw
LQ Newbie
 
Registered: Oct 2004
Posts: 1

Rep: Reputation: 0
Quote:
Originally posted by KidKootenay
Well I got this working. I don't know if its the same for the rest of you. It was really stupid of me. I need the correct kernel modules installed.
Code:
File Systems ----->
     ----->Native Language Support
                 (iso8859-1) Default NLS Option
                  <M>      Codepage 437
                                     :
                                     :
                  <M>      NLS ISO 8859-1             <--this was missing
Hope this helps some one else
Thanks a lot. That was a life saver
 
Old 10-17-2004, 05:59 AM   #19
gep
LQ Newbie
 
Registered: Oct 2004
Posts: 4

Rep: Reputation: 0
Hey men, i have just solved the problem. It tooks me 5 seconds, so i dont know what are you talking about. Maybe u have differ problem. So i did:

#mount -t vfat /dev/hda6 /mnt/lin
mount: wrong fs type, bad option, bad superblock on /dev/hda6,
or too many mounted file systems
#dmesg
...
...
FAT: IO charset iso8859-1 not found
#modprobe nls_iso8859-1 (You have to compile this with kernel)
#mount -t vfat /dev/hda6 /mnt/lin
#ls /mnt/lin
Hey, there are files .

P.S. kernel 2.6.8.1

Last edited by gep; 10-17-2004 at 06:00 AM.
 
Old 10-24-2004, 02:31 AM   #20
jimsaku
LQ Newbie
 
Registered: Oct 2004
Distribution: gentoo
Posts: 1

Rep: Reputation: 0
hello...

my problem was that i had

(437) Default Codepage for FAT

but i didn't have Codepage 437 compiled under native language support. i changed 437 to 850 (i live in the UK), which was already selected, and hey presto! again, a silly mistake, but i've never had to do that before...

kernel: 2.6.8-gentoo-r10
 
Old 11-11-2004, 02:10 AM   #21
heister
LQ Newbie
 
Registered: Dec 2003
Location: Malaysia
Distribution: debian
Posts: 10

Rep: Reputation: 0
Hi guys.
I am having similar problem here.
When i was using kernel 2.6.5* , the fat32 partitions worked fine.
After i upgraded the kernel to 2.6.8-1.* , Konqueror and Nautilus freeze everytime when i browse by fat32 partitions.
P/S : Command Line in Konsole works fine, but when media files with xine or xmms, it gets frozen again.
P/S : I have added the module nls-iso8859-1 in my rc.local, without compiling the kernel. It shows up in "lsmod".

Anyone can help ? Thanks in advance.
cheers.

Last edited by heister; 11-11-2004 at 02:41 AM.
 
Old 11-15-2004, 02:47 PM   #22
reetep
Member
 
Registered: Oct 2003
Location: UK
Distribution: Debian
Posts: 122

Rep: Reputation: 15
hi guys. i had the same problem. after an afternoon faffing I finally solved it like this:

http://www.linuxquestions.org/questi...=vfat+.6+mount

HTH. reetep
 
Old 12-07-2004, 07:19 AM   #23
manthis
LQ Newbie
 
Registered: Aug 2002
Location: Costa Rica
Distribution: Red Hat 9
Posts: 9

Rep: Reputation: 0
Buggy Buggy

I've been having the same problem with vfat from an usb key, It mounts well if formated with ext2 but when it comes to fat32 an error keeps popping up saying that the file system is wrong or there are too many mounted filesystems.

I'm currently runnig 2.6.8 kernel

Tried to fix the problem moving to 2.6.9 but still doesn't work

Couriously I also tried moving back to 2.6.7 kernel and works like a charm

I haven't been able to find out if it is a documented bug on kernels after 2.6.7 apparently changes have been made on the fat fs module that deal with codepages and io charsets so

Any information on the subject will be very appreciated
 
Old 12-07-2004, 07:59 AM   #24
reetep
Member
 
Registered: Oct 2003
Location: UK
Distribution: Debian
Posts: 122

Rep: Reputation: 15
well, have you followed the link in my post, and read my main post on that linked page? I only made two posts, so I'm sure you'll figure out which one.

You are right - changes were made to the fat fs module that deals with codepages, and my post describes exactly what you need to do to make it work.
 
Old 12-07-2004, 02:39 PM   #25
visaris
Member
 
Registered: Dec 2004
Distribution: gentoo
Posts: 190

Rep: Reputation: 30
I have this exact same problem too. So does my boss. I would really like to get this fixed so I can use my fat32 usb thumb drive.

I find it odd that so many people have this problem and yet, no one seems to know anything about it.

Here is the relavent section of my .config file..
Code:
#
# DOS/FAT/NT Filesystems
#
CONFIG_FAT_FS=y
CONFIG_MSDOS_FS=y
CONFIG_VFAT_FS=y
CONFIG_FAT_DEFAULT_CODEPAGE=437
CONFIG_FAT_DEFAULT_IOCHARSET="iso8859-1"
CONFIG_NTFS_FS=y
# CONFIG_NTFS_DEBUG is not set
# CONFIG_NTFS_RW is not set
And it doesn't really matter what my fstab file says. I can't even do a manual mount:

fdisk output:
Code:
root@tcm # fdisk /dev/sdb

Command (m for help): p

Disk /dev/sdb: 261 MB, 261522944 bytes
9 heads, 56 sectors/track, 1013 cylinders
Units = cylinders of 504 * 512 = 258048 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        1013      255248    b  W95 FAT32

Command (m for help):
And the mount error:
Code:
root@tcm # mount -t vfat /dev/sdb1 /mnt/tmp/
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       or too many mounted file systems
Same error with -t auto too..
I'm stumpped...
 
Old 12-07-2004, 02:43 PM   #26
visaris
Member
 
Registered: Dec 2004
Distribution: gentoo
Posts: 190

Rep: Reputation: 30
reetep,

Thanks! You fixed it!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 07:54 PM
mount fat32 emrkar Red Hat 2 01-30-2005 09:14 AM
How i can mount fat32 Sreejesh Linux - Newbie 2 09-02-2004 08:25 AM
Mount a Fat32 mehargags Linux - Hardware 2 08-17-2002 06:22 AM
mount fat32 somebody Linux - Newbie 1 03-25-2002 11:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration