LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-31-2004, 05:30 AM   #1
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Rep: Reputation: 15
FAT32 Won't Mount


It won't mount in kernels 2.6.8.1 and up. Anybody else notice this? 2.6.8.1 kernels and up also have added two new options for vfat. If anyone even knows what I'm talking about, discuss it here please. Thanks.
 
Old 08-31-2004, 05:31 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
whats the error message?
 
Old 08-31-2004, 05:55 AM   #3
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Code:
mount /dev/sda1
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       or too many mounted file systems
 
Old 08-31-2004, 07:59 AM   #4
RestInPieces
Member
 
Registered: Aug 2004
Location: In front of a CRT monitor
Distribution: Slackware-current
Posts: 108

Rep: Reputation: 15
try specifying the filesystem type.. or... if that doesn't work.. pay more attention when compiling the kernel
 
Old 09-01-2004, 05:13 AM   #5
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Does anybody know if it's the default settings that are the problem, or if it's just a bug? Thanks. I'm wondering if it's just the settings because then I can just adjust accordingly, but if it's a bug, I'll wait until it's fixed.
 
Old 09-01-2004, 06:09 AM   #6
Tectonic
LQ Newbie
 
Registered: Aug 2004
Location: Netherlands
Distribution: FreeBSD 4.6
Posts: 10

Rep: Reputation: 0
Sounds like the settings in /etc/fstab....
But if it's a bug, it's probably not a bug, but a feature

Good luck,

Tectonic
 
Old 09-01-2004, 06:32 AM   #7
Gkarfield
Member
 
Registered: Jul 2004
Location: Greece
Distribution: FreeBSD 6.2/widows[not 8 legs nor black]
Posts: 123

Rep: Reputation: 15
mount -t vfat /dev/hd<xx> <folder> (you may put uid=<username> so that user has access , not only root)

see if it works
(manualy mount, but look and fstab file, and in the type of file system set vfat)
 
Old 09-01-2004, 09:06 AM   #8
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Yeah, I'm really thinking it's a bug, or the two new features for vfat... See, the thing is, it'll work if I use 2.4.26 or 2.6.7, but as soon as I upgrade to 2.6.8.1 or 2.6.9-rc1, it won't work (and the two new features are also added to 2.6.8.1 and up). When I go back to 2.6.7 or lower, my fat32 will mount again, so it can't be my fstab. I've also tried manually mounting; doesn't work. Hoping they fix this bug soon, or, if not a bug, can someone tell me the proper settings for vfat in xconfig. Vfat support was working well before they added those two new settings. If you guys don't know what settings I'm talking about, just ask or check for yourself..
 
Old 09-01-2004, 09:26 AM   #9
kpex
Member
 
Registered: Apr 2004
Distribution: Slackware -current, Gentoo, FC3
Posts: 41

Rep: Reputation: 15
Mounting vfat works fine here with 2.6.8.1. Same options/fstab as before. Did you try Gkarfield's command suggestion?
 
Old 09-01-2004, 10:16 AM   #10
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Rep: Reputation: 30
whats your /etc/fstab look like?
 
Old 09-01-2004, 10:19 AM   #11
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Rep: Reputation: 30
I have my fat partition setup as:

/dev/hdb1 /windowsfiles vfat noauto,user 0 0

works for me...and i'm running kernel v. 2.6.8
 
Old 09-02-2004, 03:00 AM   #12
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Original Poster
Rep: Reputation: 15
Could it be because I have an ext hdd?

My fstab goes something like this: /dev/sda1 /fat32 vfat noauto,user 0 0

It's something like that. I'm not in Slack right now, so I can't copy and paste the actual, but this should be close enough.
 
Old 09-04-2004, 03:02 PM   #13
jakublgz
Member
 
Registered: Apr 2002
Location: Wood Dale IL
Distribution: redhat, slackware
Posts: 110

Rep: Reputation: 15
Hello All,
I have the same issue with mounting my vfat partitions under 2.6.8.

Error from DMESG:
hdb: IC35L120AVV207-0, ATA DISK drive
hdb: max request size: 1024KiB
hdb: 241254720 sectors (123522 MB) w/1821KiB Cache, CHS=16383/255/63, UDMA(33)
hdb: hdb1
VFS: Can't find a valid FAT filesystem on dev hdb.
VFS: Can't find a valid FAT filesystem on dev hdb.

Here is line from fstab :
/dev/hdb1 /mnt/samba/hdb vfat uid=1004,gid=100 0 2

This is Error MSG when trying to mount it manually :
mount -t vfat /dev/hdb1 /mnt/windows
mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
or too many mounted file systems

Partition Type:
fdisk -l | grep hdb
Disk /dev/hdb: 123.5 GB, 123522416640 bytes
/dev/hdb1 * 1 15956 120627328+ c W95 FAT32 (LBA)

When compiling 2.6.8 following options (regarding DOS/FAT/NT Filesystems ---> ) were chosen :
<*> MSDOS fs support
<*> VFAT (Windows-95) fs support
(437) Default codepage for FAT
(iso8859-1) Default iocharset for FAT



Everything worked just fine with the same settings on 2.4.26 27 28 but not on 2.6.8. plus I can mount it using -t msdos.

BSTRGDS<
Jakub.

Last edited by jakublgz; 09-04-2004 at 03:03 PM.
 
Old 09-05-2004, 12:18 PM   #14
Gkarfield
Member
 
Registered: Jul 2004
Location: Greece
Distribution: FreeBSD 6.2/widows[not 8 legs nor black]
Posts: 123

Rep: Reputation: 15
try auto, instead of vfat

(I have suse 9.1, I dont know if it is the same in different distros)
 
Old 09-28-2004, 02:36 AM   #15
KidKootenay
LQ Newbie
 
Registered: Apr 2004
Location: Victoria, Canada
Distribution: Gentoo
Posts: 4

Rep: Reputation: 0
I too have this exact same problem. If anyone figures this out, please post! I would really like to be able to write proper(long) file names to my fat32 partition.

I don't think this is an obious mount syntax problem. I've tried just about everthing posible for vfat in the mount man pages. Is there an option some where else (Besides DOS/FAT/NT Filesystems --->) in the kernel config that needs enabling or disabling?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 08:54 PM
mount fat32 emrkar Red Hat 2 01-30-2005 10:14 AM
How i can mount fat32 Sreejesh Linux - Newbie 2 09-02-2004 09:25 AM
Mount a Fat32 mehargags Linux - Hardware 2 08-17-2002 07:22 AM
mount fat32 somebody Linux - Newbie 1 03-25-2002 12:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration