LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2004, 01:48 AM   #1
L3go1as
LQ Newbie
 
Registered: Feb 2004
Distribution: Redhat 9.0
Posts: 6

Rep: Reputation: 0
Fat32 HDD mount problem.


Hi there, Im trying to mount a windows Fat32 drive on my redhat 9.0 box.
As you can see in the fdisk list below, the drive im trying to mount is hda1.
Any help would be much appreciated.

The error I get is
Code:
mount -t vfat /dev/hda1 /storage 
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
       or too many mounted file systems
Code:
fdisk -l
Disk /dev/hdc: 6488 MB, 6488294400 bytes
255 heads, 63 sectors/track, 788 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdc1   *         1        13    104391   83  Linux
/dev/hdc2            14       740   5839627+  83  Linux
/dev/hdc3           741       788    385560   82  Linux swap

Disk /dev/hda: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1     10011  80413326    c  Win95 FAT32 (LBA)

Last edited by L3go1as; 02-01-2004 at 01:49 AM.
 
Old 02-01-2004, 02:41 AM   #2
illtbagu
Member
 
Registered: Dec 2002
Location: Nevada
Distribution: fedora, RHEL, ubuntu, suse
Posts: 343

Rep: Reputation: 30
You know something kind of funny but when I have used /sbin/fdisk -l it always lists the drives that are currently mounted, looking at "man fdisk" it actually says this. Why then is it that when You do your fdisk -l it is listing the drive
/dev/hda1 * 1 10011 80413326 c Win95 FAT32 (LBA)
that you are claiming is not mounted. In other words I think your drive is already mounted.

Please do everyone a favor and either fill out your user profile so it shows what distro you are using or post that info along with your questions. Your distro might already be mounting your drive for you. Post your /etc/fstab file too.
 
Old 02-01-2004, 02:44 AM   #3
L3go1as
LQ Newbie
 
Registered: Feb 2004
Distribution: Redhat 9.0
Posts: 6

Original Poster
Rep: Reputation: 0
The distro that I am using was posted in the above topic, but anyhow I have updated my profile.

fstab shows

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdc3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
 
Old 02-01-2004, 03:18 AM   #4
illtbagu
Member
 
Registered: Dec 2002
Location: Nevada
Distribution: fedora, RHEL, ubuntu, suse
Posts: 343

Rep: Reputation: 30
Just type in mount at the command prompt and post your results.

What did you use to partition this drive with?

Do you have any data on this drive?
 
Old 02-01-2004, 03:34 AM   #5
L3go1as
LQ Newbie
 
Registered: Feb 2004
Distribution: Redhat 9.0
Posts: 6

Original Poster
Rep: Reputation: 0
yes I have data on this drive, that I do not wish to remove.

mount
/dev/hdc2 on / type ext3 (rw)
none on /proc type proc (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/hdc1 on /boot type ext3 (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)
 
Old 02-01-2004, 03:46 AM   #6
illtbagu
Member
 
Registered: Dec 2002
Location: Nevada
Distribution: fedora, RHEL, ubuntu, suse
Posts: 343

Rep: Reputation: 30
then try this
mount /dev/hda1 /storage
notice I took out the -t vfat let it try and guess the file system on its own.

The folder /mount exists and you are trying to mount this drive as root right?
 
Old 02-01-2004, 03:55 AM   #7
L3go1as
LQ Newbie
 
Registered: Feb 2004
Distribution: Redhat 9.0
Posts: 6

Original Poster
Rep: Reputation: 0
The folder /mount does not exist, do you mean /mnt ?
Yes I am trying to mount this while logged in as root.

Code:
mount /dev/hda1 /storage
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
       or too many mounted file systems
The thing is this, I converted this HDD from NTFS to fat32 today so I could stick it in my linux box. Could that be a problem?
 
Old 02-01-2004, 04:05 AM   #8
illtbagu
Member
 
Registered: Dec 2002
Location: Nevada
Distribution: fedora, RHEL, ubuntu, suse
Posts: 343

Rep: Reputation: 30
lets be done with this problem, do exactly as I say
create a folder in your /mnt directory named hda1
then do a
mount /dev/hda1 /mnt/hda1
then look in your /dev/hda1 folder and you should see your drive
 
Old 02-01-2004, 04:13 AM   #9
L3go1as
LQ Newbie
 
Registered: Feb 2004
Distribution: Redhat 9.0
Posts: 6

Original Poster
Rep: Reputation: 0
I've actually been using linux for awhile and am not a newbie. The above was the first thing I tried.

Code:
[root@biggles /]# cd /mnt
[root@biggles mnt]# mkdir hda1
[root@biggles mnt]# mount /dev/hda1 /mnt/hda1
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
       or too many mounted file systems
[root@biggles mnt]# cd /mnt/hda1
[root@biggles hda1]# ls -las
total 8
   4 drwxr-xr-x    2 root     root         4096 Feb  1 20:06 .
   4 drwxr-xr-x    4 root     root         4096 Feb  1 20:06 ..
 
Old 02-01-2004, 04:32 AM   #10
illtbagu
Member
 
Registered: Dec 2002
Location: Nevada
Distribution: fedora, RHEL, ubuntu, suse
Posts: 343

Rep: Reputation: 30
You said that you had converted your drive from ntfs to fat32, must have used windows to do this, you are very brave . I have never done this before, I have though converted from fat32 to ntfs so I really couldnt tell you how well this works.

I honestly dont know what is wrong you shouldnt have any problems. So I will think on this for a while in the mean time lets see what happens when you do a
df -h /dev/hda1
 
Old 02-01-2004, 04:39 AM   #11
illtbagu
Member
 
Registered: Dec 2002
Location: Nevada
Distribution: fedora, RHEL, ubuntu, suse
Posts: 343

Rep: Reputation: 30
here is another guess
/sbin/badblocks /dev/hda

do a "man badblocks" first
the manual pages said it does a non destructive read write mode by default. Im doing a test on my drive right now.
 
Old 02-01-2004, 05:03 AM   #12
L3go1as
LQ Newbie
 
Registered: Feb 2004
Distribution: Redhat 9.0
Posts: 6

Original Poster
Rep: Reputation: 0
Weird, both
df -h /dev/hda1
and
df -h /dev/hdc1

return the same thing.

Filesystem Size Used Avail Use% Mounted on
/dev/hda1 5.5G 2.9G 2.4G 55%
 
Old 02-02-2004, 01:57 PM   #13
Micah
Member
 
Registered: Apr 2002
Location: OK, USA
Distribution: Slackware64 14
Posts: 180

Rep: Reputation: 31
Here is a question for you...

Is vfat (fat32) driver installed on your linux?
(I had to recently install it in the kernel to get mine to work...)

Just a thought.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 08:54 PM
Hdd problem FAT32 bad superblock Gibsonist Linux - Hardware 1 06-30-2005 11:45 AM
How to format & mount 2nd hdd after FedCor1 has been installed on 1st hdd? clay394 Fedora 1 05-18-2004 02:50 PM
Problem formatting HDD with FAT32 rafi112 Linux - Newbie 5 02-19-2004 02:30 PM
mount a fat32 hdd..how? ironz Linux - Newbie 38 07-26-2003 08:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration