LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-27-2008, 02:33 PM   #1
smoaky
LQ Newbie
 
Registered: Jan 2006
Location: Virginia,U.S.A.!!!
Distribution: Ubuntu Studio ,Mandriva 2008
Posts: 20

Rep: Reputation: 0
Failed to start X server


I am currently running two desktops and two laptops with dual boots.One desktop with Vista and Ubuntu Studio and the other three with dual boots of XP and Mandriva 2008.
But I needed a very simple Distro with an easy to use GUI for my computer shy wife. I discovered a little know distro called "Linpus 9.4 Lite" It sports very large tabs on the desktop so that you can navigate all the various features and software of the distro.(this distro will only run on my newest and fastest PC) I do not want to use this disro on that PC though..figures huh?
Here is the problem...when I run Linpus 9.4 Lite (Live CD) on any of my other computers:
It will boot and then I get a box stating
"Failed to start X server. It is not set up correctly"
I have never had this problem on any of my computers with all the other Linux distros I have tried.
What do I need to do to correct this?
Thanks in advance
 
Old 01-27-2008, 02:53 PM   #2
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Rep: Reputation: 47
You can install any distribution and install KDE on it. Also, using KBFX, you can make the desktop look exactly the same as vista (if thats what you're going for).
 
Old 01-27-2008, 04:28 PM   #3
smoaky
LQ Newbie
 
Registered: Jan 2006
Location: Virginia,U.S.A.!!!
Distribution: Ubuntu Studio ,Mandriva 2008
Posts: 20

Original Poster
Rep: Reputation: 0
No, what I want is to configure my X server so that I can run Linpus.
Any steps on how to do that anyone?
Cheers
 
Old 01-27-2008, 05:23 PM   #4
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Rep: Reputation: 47
Post your /etc/X11/xorg.conf file.
 
Old 01-27-2008, 06:04 PM   #5
smoaky
LQ Newbie
 
Registered: Jan 2006
Location: Virginia,U.S.A.!!!
Distribution: Ubuntu Studio ,Mandriva 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Unhappy

How to? I cansee the grub loader boot up and I can F1 for help or F2 for language options and after it boots (the X server not being configured) brings me to a blank page with a flashing cursor.remember I am still a newbie at this.Sorry for the trouble.
Thank you
 
Old 01-27-2008, 08:00 PM   #6
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Rep: Reputation: 47
Well, does it "drop" you in a terminal?
 
Old 01-27-2008, 10:47 PM   #7
funnyG
LQ Newbie
 
Registered: Jun 2004
Location: Germany
Distribution: Slackware 12.2
Posts: 23

Rep: Reputation: 20
Hello smoaky,

it may be that the distro has problems with your graphics card. What is the make and model of your card?
 
Old 01-28-2008, 08:04 AM   #8
smoaky
LQ Newbie
 
Registered: Jan 2006
Location: Virginia,U.S.A.!!!
Distribution: Ubuntu Studio ,Mandriva 2008
Posts: 20

Original Poster
Rep: Reputation: 0
To phantom_cyph,
No, I get a black screen with just a flashing cursor at the top left corner. No text. This is after the box stating that X server is now disabled.
And to answer funnyG's question I have three pc's that this Distro has this X problem. The desktop uses Nvidia Graphics Card Vanta Vanta, the two Laptops use ATI mobility Radeon.
Remember I am running the "Live CD" just to get this distro up and running and will install it after I can get the X server prob fixed. No need to partition my HDD to install this if i can't get it to run.
Thanks for all the help so far guys
 
Old 01-28-2008, 08:02 PM   #9
smoaky
LQ Newbie
 
Registered: Jan 2006
Location: Virginia,U.S.A.!!!
Distribution: Ubuntu Studio ,Mandriva 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Please help...anyone????
 
Old 01-29-2008, 11:04 PM   #10
orbit
Member
 
Registered: Sep 2006
Location: Australia
Distribution: Slackware
Posts: 176

Rep: Reputation: 30
Hi Smoaky,

I have tried Linpus Linux Lite 9.4 and had exactly the same problems you are describing (tried it on radeon 9200, nvidia 6200 and nvidia 7800 ... all the same failure.

What I did to overcome this was to change terminal by pressing Ctrl+Alt+F8 (you can try F9 as well), then I changed to the /etc/X11 directory and overwrote the existing xorg.conf with the vesa xorg.conf. This enables the system to start graphically.

The exact copy commands after logging in as root were:

cd /etc/X11
cp xorg.conf.vesa xorg.conf (Y to overwrite)
startx

This loads the Linpus desktop in Vesa mode so you can have a look at it.

I am now currently working on being able to install this OS onto a HDD so that I can repair it and have it work correctly, then I will look into remastering it into another ISO so that it loads the vesa driver by default.


Hope this helps

Cheers

Orbit
 
Old 01-30-2008, 05:49 PM   #11
smoaky
LQ Newbie
 
Registered: Jan 2006
Location: Virginia,U.S.A.!!!
Distribution: Ubuntu Studio ,Mandriva 2008
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks orbit
I will give that a try and let me know how you work-around turns out
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed to start the X server imagined Linux - Newbie 22 09-25-2007 02:04 AM
failed to start x server aeiouer Ubuntu 1 06-22-2007 03:56 AM
failed to start x server kuliand Ubuntu 4 01-10-2007 03:42 AM
Failed to start FTP server - server daemon when in inetd mode. pujakofriendly Slackware 2 11-30-2006 02:58 AM
Failed to start X server wabsrck Linux - Newbie 4 11-05-2006 06:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration