LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Failed to run/usr/bin/x-terminal-emulator as user root (https://www.linuxquestions.org/questions/linux-newbie-8/failed-to-run-usr-bin-x-terminal-emulator-as-user-root-615217/)

hongnguyen70 01-21-2008 11:04 AM

Failed to run/usr/bin/x-terminal-emulator as user root
 
I have installed Debian version 4 last week and it worked fine until today. I played around at the command line and when I rebooted I could not log on any more with the root user name. It comes up with the error message
Failed to run/usr/bin/x-terminal-emulator as user root

Please help

Acron_0248 01-21-2008 11:12 AM

Hi,


A little more of information would be great, but I guess that you're trying to run the "Root terminal" from the applications menu in gnome, that should load gksu asking for your root password and then is when you see the error, is like that?

If you open a terminal as normal user type su put the root password and press enter, do you get any errors?

Is your user added to the wheel group?

Do you remember with what you played at the command line?



Regards

hongnguyen70 01-22-2008 05:19 AM

Failed to run/usr/bin/x-terminal-emulator as user root
 
when I log on at the terminal then I got that error message but if I boot to single user mood and enter the password when asked then it said file not found or something ( sorry I am off work today n not sure exactly the message ). I played alots with etc/init.d and inittab cause i tried to make the server boot to he single user mood automaticaly

Thank you for your reply and hope you can help

Acron_0248 01-23-2008 05:13 PM

Try reconfiguring gksu with dpkg-reconfigure.


However, from the inittab the changes you could made at init levels shouldn't create those errors.

If you're unsure the settings you use in the inittab, here's mine as reference:
Code:

# /etc/inittab: init(8) configuration.
# $Id: inittab,v 1.91 2002/01/25 13:35:21 miquels Exp $

# The default runlevel.
id:2:initdefault:

# Boot-time system configuration/initialization script.
# This is run first except when booting in emergency (-b) mode.
si::sysinit:/etc/init.d/rcS

# What to do in single-user mode.
~~:S:wait:/sbin/sulogin

# /etc/init.d executes the S and K scripts upon change
# of runlevel.
#
# Runlevel 0 is halt.
# Runlevel 1 is single-user.
# Runlevels 2-5 are multi-user.
# Runlevel 6 is reboot.

l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6
# Normally not reached, but fallthrough in case of emergency.
z6:6:respawn:/sbin/sulogin

# What to do when CTRL-ALT-DEL is pressed.
ca:12345:ctrlaltdel:/sbin/shutdown -t1 -a -r now

# Action on special keypress (ALT-UpArrow).
#kb::kbrequest:/bin/echo "Keyboard Request--edit /etc/inittab to let this work."

# What to do when the power fails/returns.
pf::powerwait:/etc/init.d/powerfail start
pn::powerfailnow:/etc/init.d/powerfail now
po::powerokwait:/etc/init.d/powerfail stop

# /sbin/getty invocations for the runlevels.
#
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
#
# Format:
#  <id>:<runlevels>:<action>:<process>
#
# Note that on most Debian systems tty7 is used by the X Window System,
# so if you want to add more getty's go ahead but skip tty7 if you run X.
#
1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

# Example how to put a getty on a serial line (for a terminal)
#
#T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
#T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100

# Example how to put a getty on a modem line.
#
#T3:23:respawn:/sbin/mgetty -x0 -s 57600 ttyS3

This is the default one so shouldn't give you any troubles.



Regards


All times are GMT -5. The time now is 03:25 AM.