LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Failed dependency issues installing Jive on Linux (https://www.linuxquestions.org/questions/linux-newbie-8/failed-dependency-issues-installing-jive-on-linux-779721/)

navneethr 01-04-2010 07:51 AM

Failed dependency issues installing Jive on Linux
 
Hello,

I downloaded the jive_sbs (jive_sbs_employee-4.0.0.RHEL-5.i586.rpm) and tried to install it but it failed to do so due to some dependency issues. Please see below.


[root@localhost temp]# rpm -i jive_sbs_employee-4.0.0.RHEL-5.i586.rpm
error: Failed dependencies:
krb5-libs >= 1.6 is needed by jive_sbs-4.0.0-96352.i586
keyutils-libs >= 1.2 is needed by jive_sbs-4.0.0-96352.i586
keyutils-libs < 1.3 is needed by jive_sbs-4.0.0-96352.i586
sysstat >= 5.0 is needed by jive_sbs-4.0.0-96352.i586

Please let me have the above packages for installation on my machine with the yum command so that I can proceed with the Jive installation. FYI I verified that the versions of the above packages dont exist on the system.

Regards,

Some details of my machine are as follows
uname -a gave:
Linux localhost.localdomain 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:21 EST 2007 i686 i686 i386 GNU/Linux
cat /etc/issue gave:
Red Hat Enterprise Linux Server release 5 (Tikanga)

knudfl 01-04-2010 09:35 AM

Welcome to LQ.

1) su
2) yum install krb5-libs keyutils-libs sysstat

.. Or 2a) ..
cd <path-to-directory-with-jive-package>/
yum localinstall jive_sbs_employee-4.0.0.RHEL-5.i586.rpm

It's not quite clear, what your problem is, the required
dependency versions are the default ones for RH EL 5.
They are on the install disks : krb5-libs, keyutils-libs, disk 1
.. and sysstat, disk 3.

Unless you forgot to pay Redhat or not activate your account :
Then you cannot use yum / the repo's. Seems you never updated,
i.e. your kernel is the oldest old for RH EL 5.
The current version is kernel-2.6.18-128.el5 .
.....


All times are GMT -5. The time now is 12:12 PM.