LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-12-2019, 12:49 AM   #1
55sgu
LQ Newbie
 
Registered: Jun 2019
Posts: 24

Rep: Reputation: Disabled
Exthdd won't mount on debian os


debian OS; orangepi; 2TB; (SCSI DISK) (WDC WD20 03FZEX-00SRLAO)

Trying to mount as "ro,noexec" or "rw", neither mount.

DMESG | TAIL : couldn't mount RDWR b/c of unsupported optional features (400)

"Failed to mount "exthdd". Error mounting /dev/sda1 at media/username/exthdd: command line 'mount -t "ext4" -o uhelper=udisks 2,no dev,nosuid "/dev/sda1" "media/username/exthdd - exited with non-zero exit status32: ; "mount: wrong fstype, bad options, etc etc etc........other"

Last edited by 55sgu; 06-12-2019 at 12:58 AM.
 
Old 06-12-2019, 01:05 AM   #2
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora, Alpine, Cirros, OpenSuse/SLES
Posts: 3,037

Rep: Reputation: 798Reputation: 798Reputation: 798Reputation: 798Reputation: 798Reputation: 798Reputation: 798
What is the command you use for mounting this disk?
 
Old 06-12-2019, 01:25 AM   #3
55sgu
LQ Newbie
 
Registered: Jun 2019
Posts: 24

Original Poster
Rep: Reputation: Disabled
1... mount -o ro,noexec /dev/sda1 /media
2... mount -o ro,noexec /dev/sda1 /exthdd
3... mount -o rw /dev/sda1 /media
4... mount -o rw /dev/sda1 /exthdd

tried all 4, plus clicking on the exthdd icon in file manager.

thanks.
 
Old 06-12-2019, 02:03 AM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,845

Rep: Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839
What about "lsblk -f"- use sudo in need.
 
Old 06-12-2019, 02:11 AM   #5
55sgu
LQ Newbie
 
Registered: Jun 2019
Posts: 24

Original Poster
Rep: Reputation: Disabled
I found this......

The ext4 feature (400) is the new metadata_csum feature. If this feature is enabled and old tools are used to mount the filesystem they will only be able to mount read-only.

https://ext4.wiki.kernel.org/index.p...data_Checksums

To create a ext4 filesystem without this feature:

sudo mke2fs /dev/sdb1 -O ^metadata_csum
Or turn it off on an already created filesystem:

sudo tune2fs -O ^metadata_csum /dev/sdb1
 
Old 06-12-2019, 02:22 AM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,845

Rep: Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839Reputation: 2839
Yeah, something like that was very likely. Maybe mount it as ext3 ?.
 
Old 06-12-2019, 04:29 AM   #7
55sgu
LQ Newbie
 
Registered: Jun 2019
Posts: 24

Original Poster
Rep: Reputation: Disabled
I have 1.5 Terabytes of files on there.

Could remounting it cause any files to get destroyed?

This failed: sudo tune2fs -O ^metadata_csum /dev/sdb1; I changed sdb1 to mine. Mentioned something about having a ro permission on there.

I have mounted in ro many times and sometimes when I would remount it as rw, it would still be holding on to the ro. I would restart the machine to get it to clear.

Last edited by 55sgu; 06-12-2019 at 04:30 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount -a won't mount the optical disks. stf92 Linux - Newbie 11 12-11-2010 10:02 AM
Mount. Umount. Mount. Umount. Mount. Umount. Mount.. cwizardone Slackware 10 03-22-2007 09:30 AM
automount won't, mount will (mount CDROMs) dguy Slackware 12 09-27-2006 12:29 PM
My freecom Exthdd is taking a long time to be found as /dev/sda1 fieldyweb Linux - Hardware 0 03-19-2006 11:07 AM
HELP! Error from mount: drive is write-protected... won't mount writeable. system Linux - General 2 12-27-2001 09:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration