-   Linux - Newbie (
-   -   External USB Hard Drive became read only (

nutjob16 08-21-2010 12:24 PM

External USB Hard Drive became read only
I was in the process of backing up data from my hard drive to an external usb drive when the drive suddenly became read only. Does anyone know how I can make it read/write again? I am using Debian Lenny and the drive is ntfs formatted. I have another ntfs formatted usb drive that is not effected in this way.

troop 08-21-2010 12:32 PM


mount -o remount,rw mount_point

the drive suddenly became read only
you can look at dmesg for the reason.

nutjob16 08-21-2010 12:51 PM

Thanks troop,

I tried the command and it didn't work.

I looked in dmesg and nothing really popped out at me as being the answer. I saw a line such as:
[ 43.846581] sd 1:0:0:0: [sdd] Write Protect is off

Which would indicate to me that it is in read/write mode, however it is still read only.

Could the hard drive be going?

yancek 08-21-2010 02:36 PM


I was in the process of backing up data from my hard drive to an external usb drive
How were you doing this backup? From a bash or other script? using dd command?


the drive suddenly became read only
What does that mean? How did you notice it became "suddenly" readonly?

nutjob16 08-21-2010 05:31 PM


I was just dragging and dropping files one by one with the file manager. I copied one and it worked, then I tried to copy the next one and it gave me a message, "operation not supported".

However, it appears that it is not read only. I am able to delete. Interestingly, I deleted 2 files, then I was able to copy 2 files to the drive before it gave me the "operation not supported" message.

Is there a limit to the number of files I can put on the drive?

SharpyWarpy 08-21-2010 06:51 PM

No there shouldn't be a limit on how many files unless, of course, you're out of disc space. If you were moving the files and not copying I could see the potential problem of the file being moved protected and incapable of being deleted. But you're copying so it's a mystery. You say the other external drive is set up the same way and it's not affected. I wonder if the enclosure circuitry is going bad? I've seen that happen. Just for kicks and giggles try changing enclosures and see what happens. Good Luck.

nutjob16 08-22-2010 10:18 AM


I believe I figured this out. Looks like the ntfs-3g drivers in Lenny are the problem. I tried the latest (10.04) ubuntu live cd and was able to add more files to the drive.

SharpyWarpy 08-22-2010 12:48 PM

Glad you got it sorted out. Now all you need is to update your ntfs-3g package.

All times are GMT -5. The time now is 02:53 PM.