LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-14-2017, 01:11 PM   #1
brew01
LQ Newbie
 
Registered: Nov 2017
Posts: 4

Rep: Reputation: Disabled
External monitor goes blank


I just installed Mint 18.2.
I use an external monitor attached to my laptop as my primary screen.
When I close the lid on the laptop, it shuts down the monitor display.
How can I stop this?
 
Old 11-14-2017, 02:07 PM   #2
Superspeed500
Member
 
Registered: Oct 2017
Distribution: Fedora, Ubuntu
Posts: 38

Rep: Reputation: Disabled
Laptops do by default go into sleep mode when the lid is closed. You should be able to disable this feature entirely from the power settings window of your distro. Different desktop environments have different locations for this settings. It would therefore be nice if you posted what environment you use
 
Old 11-14-2017, 03:19 PM   #3
brew01
LQ Newbie
 
Registered: Nov 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
I have installed Linux Mint 18.2 Sonya, Cinnamon Edition.

I have power options set to:
When lid is closed - Do Nothing
Perform lid-closed action even with external monitors attached - ON
 
Old 11-14-2017, 09:59 PM   #4
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
I just leave the lid open and turn off the laptop display.
 
Old 11-15-2017, 01:52 AM   #5
Superspeed500
Member
 
Registered: Oct 2017
Distribution: Fedora, Ubuntu
Posts: 38

Rep: Reputation: Disabled
Quote:
Originally Posted by brew01 View Post
Perform lid-closed action even with external monitors attached - ON
Have you tried to set the option above to off?
 
Old 11-15-2017, 01:56 AM   #6
JJJCR
Senior Member
 
Registered: Apr 2010
Posts: 1,642

Rep: Reputation: 277Reputation: 277Reputation: 277
From this link: https://forums.linuxmint.com/viewtopic.php?t=151246

To prevent suspending when running on battery power, type this command in the Terminal:
gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action blank

To prevent suspending when running on AC power, type this command:
gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action blank

To reverse the settings type these commands:
gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action 'suspend'
gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action 'suspend'
 
Old 11-15-2017, 09:05 AM   #7
brew01
LQ Newbie
 
Registered: Nov 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
changing the power setting to OFF does not help.

I am a newbie with using the terminal. Could you be more detailed in how to enter the command line.
 
Old 11-15-2017, 09:53 AM   #8
brew01
LQ Newbie
 
Registered: Nov 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
Problem seems solved? Perhaps power setting to OFF helped, and I just didn't wait long enough after closing lid.

Thanks all.

I'm still interested in learning how to enter terminal command properly. Is there a guide available?
 
Old 11-15-2017, 12:18 PM   #9
Superspeed500
Member
 
Registered: Oct 2017
Distribution: Fedora, Ubuntu
Posts: 38

Rep: Reputation: Disabled
Post

Quote:
Originally Posted by brew01 View Post
I'm still interested in learning how to enter terminal command properly. Is there a guide available?
There are many tutorials available on the internet for this purpose, for example this video by Joe Collins. There are also books that you can buy, like for example the Linux bible. Also: Search engines are your friend
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn off LVDS monitor and use ONLY external monitor instead? (xrandr doesnt work) Ernte1893 Linux - Laptop and Netbook 1 02-08-2016 06:10 PM
Laptop monitor shuts off when attempting to switch to external monitor (Debian) sgh Linux - Laptop and Netbook 4 02-20-2012 11:33 PM
External monitor goes blank cusri2004 Linux - Hardware 2 05-18-2010 06:14 PM
blank monitor? lilili Linux - Hardware 2 10-13-2007 04:01 PM
monitor off / blank R@LF Linux - Hardware 5 08-02-2003 07:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration