LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   External modem problem (https://www.linuxquestions.org/questions/linux-newbie-8/external-modem-problem-78178/)

FrankP 08-01-2003 08:00 PM

External modem problem
 
Hi,

I find this strange - I can connect ok with a 28.8 external modem, but I want 56k connection and can't get it to work.

I am using Debian woody and dialing from the command line using pon. So I'm sending this message dialed up with the ancient 28.8

But I've also been able to scavenge two yes two 3Com/USR 56k external modems and I can't get either to work, with either pon or wvdial. When the first unit failed I assumed it was just broken but now with the second I think I must have got a setting wrong.

Can anyone shed any light?

I'm not even going to ask how to get an internal modem going :-)
I'm up to my ears here in unused modem hardware so if anyone can help they are more than welcome to a spare if it is useful !!

FrankP

Thymox 08-01-2003 08:24 PM

Welcome to LQ, Frank.

Does your modem connect through the serial port? If so, are you telling your dialling program to use the correct one?
COM1 = /dev/ttyS0
COM2 = /dev/ttyS1, etc
If it is a USB modem, then you can check out the stuff from www.linux-usb.org (I think) to see if it's supported.

Good luck buddy.

FrankP 08-02-2003 05:44 PM

Thanks Thymox, yes my modem is serial on the port ttyS1.

So I use wvdial to detect it and it tries to send ATQ and returns "Modem not responding". Like I said when I got this the first time I thought I just had a dud modem but it's happened with a second 3Com/USR unit just the same so I thought I'd ask for advice.

What I've done is swap the old 28.8 modem (which works fine) for the faster 56k one but this better one refuses to work.

Thymox 08-02-2003 06:26 PM

Try minicom - it has some good tools. Or, if you know what's what, you can get kppp to query the registers and return their values - might be useful?

jailbait 08-02-2003 08:39 PM

wvdial sets the modem speed in /etc/wvdial.conf. Before any Init statements you need Baud=57600

tomp_tag 08-03-2003 04:18 AM

a nicety of wvdial's config is that it reports to you what it hears from the modem's registers. so any reported strings mean that your modem can hear and listen to your computer. Next can ypur modem talk to and listen to the internet...
'surfing' comes after some negaotiations and happens under a
protocol. so simple things first...
what does ifconfig report about ppp0? you should get your address from your IP and see his address also.
Can you ping these and maybe any other dotted quad you may know of?
Since it's an external modem, does it make any noise at all, or
maybe 'listen in by connecting a handset in series and lifting
after you think communications have just begun.
A terminal program like seyon or wvdial's terminal can be handy,
and both can record info for real guru's here to ponder.
regards, (i got dialup probs too) tomp

tomp_tag 08-03-2003 04:22 AM

uh yeah,
if you can go back and use the 28.8 anytime, then try making things equal by choking the 56K's down. set the rate in ppp-on to just 28800 and see if that is important.
sorry i didnt think before ..
tomp

FrankP 08-04-2003 11:25 AM

Thanks all for your suggestions.

I'm away for a couple of days but I'll try them out when I get back and let you know how I get on.

FrankP 08-09-2003 03:04 AM

Still the same
 
Have tried what I can but the 3Com modem isn't responding. The AT commands which the various terminal progs send (minicom, wvdial, etc.) don't get more than a flicker of LED from the modem.

From reading stuff on linmodems.org and elsewhere I reckon this modem (USRobotics Sportster) might be a winmodem and can't be configured without the right software driver.

Originally I thought only internal modems could be winmodems and that external modems could be configured with serial tools. Maybe I'm wrong about this.

Anyway, I've given up on it. Thanks for your suggestions.


All times are GMT -5. The time now is 02:15 AM.