LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-07-2005, 07:48 AM   #1
Anarchon
LQ Newbie
 
Registered: Mar 2005
Location: Belgium
Distribution: Gentoo stage3 - debian - fedora
Posts: 15

Rep: Reputation: 0
Lightbulb EXT3 but expecting EXT2 ? no boot :-(


Hello Guys,

I'm a little bit sad.
I am installing a Gentoo Stage 3 (2005.1)
and okay everything went fine until that I rebooted my machine... after all those hours of configuring and compiling I notice that he 's not booting properly!!

So he's saying this :

Checking root filesystem ...
fsck.ext3: No such file or diretory while trying to open /dev/ROOT
/dev/ROOT:
The superblock could not be read or does not describe a correct ext 2 filesystem. blablabla

So I tried running an alternate superblock .. .no change ...

I checked fstab and mstab to be sure that he's asking for the correct filesystems and yes... its clean.
I am for sure booting the correct kernell because I do it manually at Grubs prompt.

my setup should be
/dev/hda1 : ext2
/dev/hda3 : ext3

help ?? .. ??
 
Old 10-07-2005, 07:52 AM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,147

Rep: Reputation: Disabled
Your error message seems a little weird to me. Why it is trying to open /dev/ROOT ? It should be /dev/hda1. Something wrong in your GRUB configuration?
 
Old 10-07-2005, 08:00 AM   #3
Anarchon
LQ Newbie
 
Registered: Mar 2005
Location: Belgium
Distribution: Gentoo stage3 - debian - fedora
Posts: 15

Original Poster
Rep: Reputation: 0
I think i'm getting a little crazy ..
indeed .. I am unable to locate my grub.conf..
let me try that
thanks !
 
Old 10-07-2005, 08:19 AM   #4
Anarchon
LQ Newbie
 
Registered: Mar 2005
Location: Belgium
Distribution: Gentoo stage3 - debian - fedora
Posts: 15

Original Poster
Rep: Reputation: 0
Okay I fixed the Grub problem
But on start up he's still giving me the same error on my filesystem.
he does not find /dev/root
he cannot read the superblock..
What i'm wondering is if he's expecting another filesystem ..Where is he expecting it .. in the kernel ?
 
Old 10-07-2005, 08:52 AM   #5
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,147

Rep: Reputation: Disabled
Did you rewrite the GRUB to the MBR?
 
Old 10-07-2005, 07:44 PM   #6
TexasDevilDog
Member
 
Registered: Nov 2003
Posts: 54

Rep: Reputation: 15
grub should look like this

root (hd0,0) <- first hard drive, first parition, everything referenced from zero, this should point to the device and parition where /boot is at

kernel /vmlinuz-2.6.13.3 ro root=LABEL=/ <- this says what kernel to load from the /boot, in this case it is vmlinuz-2.6.13.3, also the "ro root=LABEL=/" tells the kernel to scan the drives looking for the parition labeled "/" and make that root.

initrd /initrd-2.6.13.3.img <- this says what initial ram disk to load from the /boot, the initrd file must be version that matches the kernel version

You can edit your grub boot from the menu or even type these items if you end up at a grub> prompt and then type boot
 
Old 10-10-2005, 04:35 AM   #7
Anarchon
LQ Newbie
 
Registered: Mar 2005
Location: Belgium
Distribution: Gentoo stage3 - debian - fedora
Posts: 15

Original Poster
Rep: Reputation: 0
Post

Hi guys,

thanks for the help until now. I already learned a lot.
Still I'm not able to make it work..

So I used the Gentoo install manual literally to install my machine.
What I noticed now after lot's of reboots and mounts umounts ..
(boot from the cd permits write access on my hd (If I mound my /boot as explained here : http://www.gentoo.org/doc/en/handboo...ap=4#doc_chap5

this is my Grub conf:
root (hd0,0)
kernel /kernel-2.6.12-gentoo-r10 root=/dev/hda3

(I tried various manual configs via the command line as explained above by mister Tdevil .. but all failed to boot properly.)
But when I boot via Grub he's mounting my root as being read only !! is this normal ???

This is the startup :

So he's mounting proc at /proc
sysfs at /sys
mounting /dev for udev
configuring system to use udev
populating /dev with device notes
setting /sbin/udevsend as hootplug agent
mounting devpts at /dev/pts
activating possible swap
remounting root filesystem read-only (if necessary)
Checking Rootfile system
fsck.ext3 No such file or directory while trying to openb /dev/ROOT
/dev/ROOT :
The superblock could not be read or does ot describe a correct ext2 filesystem. blablblablablabl
Filesystem could not be fixed.
Give root pw for maintenance or Ctrl D to continue


When I type in the Root password here I get a prompt.
when I type the command reboot he's telling this :
shutdown: /dev/initctl: No Such file or directory
init: /dev/initctl: No Such file or directory

I'm quite sure this is related, specially because /dev/ is perfectly reachable in maintenance mode.. where is that initctl file ???

pffioeee this was heavy typing.
thanks for helping me out ;-)
 
Old 10-10-2005, 05:42 AM   #8
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,147

Rep: Reputation: Disabled
What kernel you are using. Your own or generic? Do you use initrd?
 
Old 10-10-2005, 06:09 AM   #9
Anarchon
LQ Newbie
 
Registered: Mar 2005
Location: Belgium
Distribution: Gentoo stage3 - debian - fedora
Posts: 15

Original Poster
Rep: Reputation: 0
Well, I'm using my own kernel so no initrd ..
do you think I should recheck my kernel config and recompile?
I noticed in the dmesg this :
EXT3-fs : mounted filesystem with ordered data mode
VFS : Mounted root (ext3 filesystem) readonly.

I have nooo clue anymore ..
It would be a pitty to start all over.
 
Old 10-10-2005, 06:51 AM   #10
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,147

Rep: Reputation: Disabled
No clue here either. Root filesystem is mounted ro during boot and remounted rw later. This is normal.
 
Old 10-10-2005, 07:13 AM   #11
Anarchon
LQ Newbie
 
Registered: Mar 2005
Location: Belgium
Distribution: Gentoo stage3 - debian - fedora
Posts: 15

Original Poster
Rep: Reputation: 0
okay in that case ... Emerson, thank you very much for the help.
Devil yours has been appreciated.
I am going to start over, it has been decided.

Okay just 1 more question ... is it possible to just use ext3 for hda1 and 3 ?
 
Old 10-10-2005, 07:42 AM   #12
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,147

Rep: Reputation: Disabled
Yes it is. However, /boot is usually a small partition and having journal there does not make sense. (journalling helps to speed up the recovery when needed)
 
Old 10-10-2005, 11:50 AM   #13
TexasDevilDog
Member
 
Registered: Nov 2003
Posts: 54

Rep: Reputation: 15
Quote:
Originally posted by Anarchon
Well, I'm using my own kernel so no initrd ..
do you think I should recheck my kernel config and recompile?
I noticed in the dmesg this :
EXT3-fs : mounted filesystem with ordered data mode
VFS : Mounted root (ext3 filesystem) readonly.

I have nooo clue anymore ..
It would be a pitty to start all over.
When you compile your kernel, one output of the process is the initrd or initial ram disk. This file has modules (drivers) for devices that need to be loaded at kernel startup. Typically you load device modules from the hard drive but sometimes that doesn't work.

For example, you are running from a USB drive. The modules are on the drive but your kernel can't load the uhc and scsi modules from the drive, to access the drive. A chicken-egg thing.

If you need a module during kernel start up, you can add them to the initrd file.
 
Old 10-25-2005, 11:43 AM   #14
Radka
LQ Newbie
 
Registered: Oct 2005
Posts: 1

Rep: Reputation: 0
Hi.

I was having the same thing happen with Gentoo after I rebooted. I traced the problem to my /etc/fstab file. The default fstab file during the Gentoo install has lines something like:

/dev/hdx/BOOT /boot ext2 defaults,noatime 1 2
/dev/hdx/SWAP none swap sw 0 0
/dev/hdx/ROOT / ext3 noatime 0 1

I had just replaced the hdx or whatever it was with my devices and didn't remove the /ROOT. To fix it I booted with the live cd went back and edited the /etc/fstab file and removed the /BOOT /SWAP and /ROOT from the lines.

Hope that helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
/boot ext2 or ext3? xushi Slackware 27 07-08-2005 11:52 PM
ext2 | ext3 bruse Linux - Newbie 3 03-03-2005 08:10 AM
Ext2 or Ext3 CrAzY G Linux - Newbie 20 03-02-2004 01:25 AM
Ext2 or Ext3? Eidi Linux From Scratch 3 11-27-2003 09:21 AM
ext2 or ext3 whitefox Slackware 13 04-20-2003 12:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration