LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-13-2017, 07:25 AM   #1
michele_deb
Member
 
Registered: Feb 2017
Location: Naples (Italy)
Distribution: Ubuntu 16.04 LTS
Posts: 85

Rep: Reputation: Disabled
ext HD read only file system


Hi guys,
I am running Arch on a VM and, if I try to copy a directory (or a folder) in my external usb HD, I get: read only file system (even if I try to copy a file, already on the HD, in a folder on the same HD). I was not able to change permission. Why? What should I do?
Thanks.

Last edited by michele_deb; 03-13-2017 at 02:14 PM.
 
Old 03-13-2017, 09:18 AM   #2
jsbjsb001
Senior Member
 
Registered: Mar 2009
Location: Earth? I would say I hope so but I'm not so sure about that... I could just be a figment of your imagination too.
Distribution: Currently OpenMandriva. Previously openSUSE, PCLinuxOS, CentOS, among others over the years.
Posts: 3,438

Rep: Reputation: Disabled
Quote:
Originally Posted by michele_deb View Post
Hi guys,
I am running Arch on a VM and, if I try to copy a directory (or a folder) in my external usb HD, I get: read only file system (even if I try to copy already on the HD in a folder on the same HD). I was not able to change permission. Why? What should I do?
Thanks.
Which file system is your external USB HDD formatted with?

If it's formatted with NTFS and you did not un-mount it properly, the last time you used it; you may need to mount it in Windows, to clear the NTFS journal.
 
Old 03-13-2017, 10:24 AM   #3
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 13,611

Rep: Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364
you may need to check how it was mounted.
 
2 members found this post helpful.
Old 03-13-2017, 12:06 PM   #4
michele_deb
Member
 
Registered: Feb 2017
Location: Naples (Italy)
Distribution: Ubuntu 16.04 LTS
Posts: 85

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jsbjsb001 View Post
Which file system is your external USB HDD formatted with?

If it's formatted with NTFS and you did not un-mount it properly, the last time you used it; you may need to mount it in Windows, to clear the NTFS journal.
Well,
file system is NTFS (I checked it typing df -T in a terminal), but honestly, I don't remember if I have un-mounted not properly the last time. Does I have to mount it manually in a terminal on arch(even if I see the HD in the devices lis?)? I think the problem is that I have never mounted (in a terminal) the external HD. I read that the best way is typing:
Code:
mount -t ntfs-3g /dev/<your-NTFS-partition> /mnt/folder
. Is right?
 
Old 03-13-2017, 12:08 PM   #5
michele_deb
Member
 
Registered: Feb 2017
Location: Naples (Italy)
Distribution: Ubuntu 16.04 LTS
Posts: 85

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
you may need to check how it was mounted.
I think I have never mounted the HD. Sorry but I am new of Linux world. Can you tell me if a GUI for mount and un-mount a disk is available in arch? If yes, how to install it?
Thanks.
 
Old 03-13-2017, 12:33 PM   #6
jsbjsb001
Senior Member
 
Registered: Mar 2009
Location: Earth? I would say I hope so but I'm not so sure about that... I could just be a figment of your imagination too.
Distribution: Currently OpenMandriva. Previously openSUSE, PCLinuxOS, CentOS, among others over the years.
Posts: 3,438

Rep: Reputation: Disabled
Quote:
Originally Posted by michele_deb View Post
Well,
file system is NTFS (I checked it typing df -T in a terminal), but honestly, I don't remember if I have un-mounted not properly the last time. Does I have to mount it manually in a terminal on arch(even if I see the HD in the devices lis?)? I think the problem is that I have never mounted (in a terminal) the external HD. I read that the best way is typing:
Code:
mount -t ntfs-3g /dev/<your-NTFS-partition> /mnt/folder
. Is right?
If there is a GUI way of mounting it (and that's how you are mounting it), then, no, you do not need to mount it, in the terminal. I suspect that it was not un-mounted properly before and that's why it's, mounting the file system, as read-only (as I suggested before - post #2).

Last edited by jsbjsb001; 03-13-2017 at 12:34 PM.
 
1 members found this post helpful.
Old 03-13-2017, 12:39 PM   #7
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 13,611

Rep: Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364Reputation: 4364
you simply execute the mount command in a terminal and will see if it was mounted read only (or not)
 
1 members found this post helpful.
Old 03-13-2017, 12:46 PM   #8
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 8,444
Blog Entries: 13

Rep: Reputation: 3762Reputation: 3762Reputation: 3762Reputation: 3762Reputation: 3762Reputation: 3762Reputation: 3762Reputation: 3762Reputation: 3762Reputation: 3762Reputation: 3762
Quote:
Originally Posted by michele_deb View Post
Well,
file system is NTFS (I checked it typing df -T in a terminal), but honestly, I don't remember if I have un-mounted not properly the last time. Does I have to mount it manually in a terminal on arch(even if I see the HD in the devices lis?)? I think the problem is that I have never mounted (in a terminal) the external HD. I read that the best way is typing:
Code:
mount -t ntfs-3g /dev/<your-NTFS-partition> /mnt/folder
. Is right?
Hi,

I think the issue here is the mount command was not done using sudo. Which actually is a very typical mount command error that many of us make. Yes, even those who have been using Linux for years. We sometimes type fast, and assume stuff and then figure it out once we've been forced to stop due to that type of error.

Are you aware of the use of sudo? Which is the way to allow a regular user to have super-user privileges for the purpose of executing that command?

What you should have done was to create the /mnt/folder using sudo:
Code:
$ sudo mkdir /mnt/folder
And then issued your mount command also using sudo:
Code:
$ sudo mount -t ntfs-3g /dev/<your-NTFS-partition> /mnt/folder
When you issue a command using sudo, it should ask you for your password.

I'm not an Arch user myself, so if that is the type of distribution where you are always the root user, I do not know.

Additionally, I can move this thread to the Arch forum to give it more Arch Linux specific attention. If you'd like that, then please click the Report button and in the dialogue, just state to please move the thread.

The Arch forum is located here for any future thread questions which are Arch specific where you feel that forum may be more appropriate for your needs.

Last edited by rtmistler; 03-13-2017 at 12:47 PM.
 
1 members found this post helpful.
Old 03-13-2017, 01:07 PM   #9
michele_deb
Member
 
Registered: Feb 2017
Location: Naples (Italy)
Distribution: Ubuntu 16.04 LTS
Posts: 85

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jsbjsb001 View Post
If there is a GUI way of mounting it (and that's how you are mounting it), then, no, you do not need to mount it, in the terminal. I suspect that it was not un-mounted properly before and that's why it's, mounting the file system, as read-only (as I suggested before - post #2).
Thanks a lot jsbjsb001,
I was able to fix the problem. I try to explain:

1) First of all, typing the command lsblk -f, I checked which is the name of the NTFS partition (sdd1 in my case).
2) I could see the ext HD mounted (somenthing like "MICHELE HD EXT") on the desktop (most likely because of udisks2 already installed, I suppose. Does udisks mount automatically the HD?) and, for this reason, I have just un-mounted it, clicking with right mouse botton.
3) Than, I have created a dir in /mnt named hdext (mkdir /mnt/hdext), and typed mount /dev/sdd1 /mnt/hdext

Now I can write in the disk (lunch and ./install from a folder, for instance). So, the problem was not the way I have unmounted the HD.
I don't know if, the above, is a spartan way of doing.
 
Old 03-13-2017, 01:20 PM   #10
jsbjsb001
Senior Member
 
Registered: Mar 2009
Location: Earth? I would say I hope so but I'm not so sure about that... I could just be a figment of your imagination too.
Distribution: Currently OpenMandriva. Previously openSUSE, PCLinuxOS, CentOS, among others over the years.
Posts: 3,438

Rep: Reputation: Disabled
Quote:
Originally Posted by michele_deb View Post
Thanks a lot jsbjsb001,
I was able to fix the problem. I try to explain:

1) First of all, typing the command lsblk -f, I checked which is the name of the NTFS partition (sdd1 in my case).
2) I could see the ext HD mounted (somenthing like "MICHELE HD EXT") on the desktop (most likely because of udisks2 already installed, I suppose. Does udisks mount automatically the HD?) and, for this reason, I have just un-mounted it, clicking with right mouse botton.
3) Than, I have created a dir in /mnt named hdext (mkdir /mnt/hdext), and typed mount /dev/sdd1 /mnt/hdext

Now I can write in the disk (lunch and ./install from a folder, for instance). So, the problem was not the way I have unmounted the HD.
I don't know if, the above, is a spartan way of doing.
USB (and alike) normally, mount on-demand (like when you click, on your USB device, in the GUI). The reason I was suggesting what I was, was because, if it's not un-mounted properly, Linux will normally as a safety measure, mount the file system as read-only (to prevent damage to it).

Glad to hear you've fixed it, good job!
 
1 members found this post helpful.
Old 03-13-2017, 01:22 PM   #11
michele_deb
Member
 
Registered: Feb 2017
Location: Naples (Italy)
Distribution: Ubuntu 16.04 LTS
Posts: 85

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rtmistler View Post
Hi,

I think the issue here is the mount command was not done using sudo. Which actually is a very typical mount command error that many of us make. Yes, even those who have been using Linux for years. We sometimes type fast, and assume stuff and then figure it out once we've been forced to stop due to that type of error.

Are you aware of the use of sudo? Which is the way to allow a regular user to have super-user privileges for the purpose of executing that command?

What you should have done was to create the /mnt/folder using sudo:
Code:
$ sudo mkdir /mnt/folder
And then issued your mount command also using sudo:
Code:
$ sudo mount -t ntfs-3g /dev/<your-NTFS-partition> /mnt/folder
When you issue a command using sudo, it should ask you for your password.

I'm not an Arch user myself, so if that is the type of distribution where you are always the root user, I do not know.

Additionally, I can move this thread to the Arch forum to give it more Arch Linux specific attention. If you'd like that, then please click the Report button and in the dialogue, just state to please move the thread.

The Arch forum is located here for any future thread questions which are Arch specific where you feel that forum may be more appropriate for your needs.
Thanks a lot for your help rtmistler.
As you can see in my last post (#9), I found a solution. I hope ahahahah! Well, I was in a terminal as root, for this reason I did not type the sudo command before mkdir and mount . What is strange for me, and don't understand is:
if I could see the HD icon on the desktop and in devices list, it means that the HD was mounted. Is right? If yes, why I was not able to write on the disk?

Last edited by michele_deb; 03-13-2017 at 02:04 PM.
 
Old 03-13-2017, 01:26 PM   #12
michele_deb
Member
 
Registered: Feb 2017
Location: Naples (Italy)
Distribution: Ubuntu 16.04 LTS
Posts: 85

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jsbjsb001 View Post
USB (and alike) normally, mount on-demand (like when you click, on your USB device, in the GUI). The reason I was suggesting what I was, was because, if it's not un-mounted properly, Linux will normally as a safety measure, mount the file system as read-only (to prevent damage to it).

Glad to hear you've fixed it, good job!
OK! Now a lot of stuff is more clear. I hope the solution I found, can help other users.
 
Old 03-14-2017, 11:09 AM   #13
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,234

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
Hi michele_deb:

For automatic mounting via GUI, depending on the DE you use (I use both LXDE and Gnome on different machines with Arch), the file manager usually takes care of it (pcmanfm is my favourite). Make sure the option for automounting removeable media is checked.

I think you mentioned at the outset that you are running Arch in a VM - also make sure you have USB settings configured correctly in the VM management utility.

Cheers - glad to hear you're up and running.
 
1 members found this post helpful.
Old 03-14-2017, 11:21 AM   #14
michele_deb
Member
 
Registered: Feb 2017
Location: Naples (Italy)
Distribution: Ubuntu 16.04 LTS
Posts: 85

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Rickkkk View Post
Hi michele_deb:

For automatic mounting via GUI, depending on the DE you use (I use both LXDE and Gnome on different machines with Arch), the file manager usually takes care of it (pcmanfm is my favourite). Make sure the option for automounting removeable media is checked.

I think you mentioned at the outset that you are running Arch in a VM - also make sure you have USB settings configured correctly in the VM management utility.

Cheers - glad to hear you're up and running.
Hi Rickkkk,
my DE is xfce4. Where I have to check whether the automounting is checked? pcmanfm comes with basic installation of arch?
Thank you
 
Old 03-14-2017, 11:59 AM   #15
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,234

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
Quote:
Originally Posted by michele_deb View Post
Hi Rickkkk,
my DE is xfce4. Where I have to check whether the automounting is checked? pcmanfm comes with basic installation of arch?
Thank you
Hi michele - pcmanfm comes by default with the lxde DE. Arch itself doesn't even come with any default DE or WM or even X - just a CLI. You choose what you want to add (one of the reasons I prefer Arch).

xfce4 uses Thunar, if I remember properly. In Thunar, go to Edit / Preferences / Advanced tab, click "Enable Volume Management", "Configure" and then click the appropriate boxes in the dialogue that opens up.

Hope this helps - Cheers !

Last edited by Rickkkk; 03-14-2017 at 12:01 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
which errors are critical for integrity of ext[234] file system? m4rtin Linux - Server 1 04-19-2012 02:10 AM
Read Only File System? Can't read superblock! haughjd Linux - Software 4 01-15-2008 09:27 AM
File system damage ext mandrake 10.0 and VMware gaelen Mandriva 1 04-09-2005 12:09 PM
Modifying kernel to support old ext file system mrogersii Linux - Hardware 1 12-09-2004 08:10 PM
Change from Read only to Read Write File System? justiceisblind Linux - Newbie 3 03-03-2002 08:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration