-   Linux - Newbie (
-   -   .exe association is killing me. (

mkesling 02-15-2012 05:54 PM

.exe association is killing me.
Installed fedora 16 for the first time. When I run a install for some software Ive installed ok on red hat 5.0. I get the error ďwish80.exe: command not foundĒ. wish80.exe is in a tcl bin directory in the install directory. It is NOT a Windows program.

When I right click-properties on wish80.exe it says DOS/Windows executable. So Iím googleing away looking at everything about file associations and how to change them, installing tcl, and some other stuff and nothing does the trick. Paths are all good. Everything is executable.

So I figure :-P Iíll open a file browser and double click on wish80.exe to see what will happen. It thinks itís an executable archive and presents me with a bunch of lovely error messages saying itís not an archive and zip problem whatever.

I tried losing .exe extensions on the file and in the install script. I installed ActiveState tcl and tried changing the install script to use it. Nothing works although I created a lot of interesting errors. BTW, wish executes fine. I just wasnít able to get the install running with it.

By this time Iíve installed so much junk and changed way to many settings so I fiqure Iíve really screwed the pooch so did a complete reinstall. Same problem. Still havenít fiqured out how to dump the .exe associations.

Bottom line is I canít seem to get my installer to execute.

Anybody know how to fix this?

eeekster 02-15-2012 06:02 PM

What does the file command say about wish80.exe?

mkesling 02-15-2012 06:14 PM

/cdrom/tools/linux/tcltk/bin/wish80.exe: Command not found.

mkesling 02-15-2012 06:16 PM

whoops, meant to say

[root@genesis6 cdrom]# file /cdrom/tools/linux/tcltk/bin/wish80.exe
/cdrom/tools/linux/tcltk/bin/wish80.exe: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.0.0, stripped

malekmustaq 02-15-2012 08:27 PM


Are you in need of some scientific tool or are you doing plain installation? This exe I suppose is windows-particular-software-install, which means the least that it is intended for fedora running over a VM, or a software intended for windows adoption. There has to be a counterpart linux-install for the software you want to install, it should be found side by side to that in the form of *.tar.gz or *bz2, etc. but not *exe.

Just my opinion.

Thank you.

John VV 02-15-2012 08:27 PM

RHEL5 and fedora 16 are SO different that a program for RHEL4(other post) & RHEL5 might not run on fedora 16

think of it this way
will all windows 98(16 or 32 bit) or xp (32bit) programs run on windows7 -64 bit

if you want tcl on fedora then install it using the fedora16 repos

yum search tcl
-- from that list ---
yum install tcl tcl-devel

chrism01 02-15-2012 11:54 PM


Post #4 shows a Linux ELF exe ...
File Extensions have no meaning in Linux (although they do to people)

malekmustaq 02-18-2012 02:40 AM

Yes, and LSB at that.

Really confusing why should it bear such an extension if it is needless at all.

chrism01 02-19-2012 08:25 PM

Probably someone with an MSWin background ... ;)

All times are GMT -5. The time now is 09:09 PM.