LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   evolution setup assistant in ubuntu (https://www.linuxquestions.org/questions/linux-newbie-8/evolution-setup-assistant-in-ubuntu-823461/)

linuxlover.chaitanya 08-05-2010 01:02 AM

Find out the permissions on the postfix directory.

Xanios 08-05-2010 01:04 AM

hmm, check out my #150 post :X sorry

linuxlover.chaitanya 08-05-2010 01:07 AM

Quote:

Originally Posted by Xanios (Post 4056372)
Hmm, when i was trying to delete the file:

Code:

xanios@ubuntu:~$ rm -r /etc/postfix/sasl_passwd
rm: remove write-protected regular file `/etc/postfix/sasl_passwd'? [i pressed 'enter' here]

in my previous sasl_passwd file, the password is my REAL password for gmail account. that should be okay right? or should i just put 'password' instead?

You can stop postfix service and then delete the file. And then create file using echo command and you will need your real gmail account password to authenticate.

Xanios 08-05-2010 01:19 AM

stopped postfix and tried to delete the file, it still remains.

Xanios 08-05-2010 01:21 AM

there's an additional sasl_password file i had, do i have to remove that? that file won't affect the way sasl_passwd works?

Xanios 08-05-2010 01:48 AM

i realised one thing:

Code:

xanios@ubuntu:~$ telnet smtp.gmail.com 587
Trying 74.125.127.109...
telnet: Unable to connect to remote host: Connection refused

Is it because of this i keep get connection refused?
how to resolve..i'm still looking

linuxlover.chaitanya 08-05-2010 01:54 AM

http://ubuntu-tutorials.com/2008/11/...-smtpgmailcom/

linuxlover.chaitanya 08-05-2010 01:56 AM

I can telnet to smtp.gmail.com on 587 port successfully. You could have been denied for your excessive requests.

Xanios 08-05-2010 02:02 AM

Excessive requests? x_x

in the link they used relayhost = [smtp.gmail.com]:587, should i just change back to that?

add on:

tried that. still connection refused.

maybe my port 587 is blocked.

Xanios 08-05-2010 02:22 AM

i added this to master.cf:

Code:

#628      inet  n      -      -      -      -      qmqpd
pickup    fifo  n      -      -      60      1      pickup
cleanup  unix  n      -      -      -      0      cleanup
qmgr      fifo  n      -      n      300    1      qmgr
#qmgr    fifo  n      -      -      300    1      oqmgr
tlsmgr    unix  -      -      -      1000?  1      tlsmgr
rewrite  unix  -      -      -      -      -      trivial-rewrite
bounce    unix  -      -      -      -      0      bounce
defer    unix  -      -      -      -      0      bounce
trace    unix  -      -      -      -      0      bounce
verify    unix  -      -      -      -      1      verify
flush    unix  n      -      -      1000?  0      flush
proxymap  unix  -      -      n      -      -      proxymap
proxywrite unix -      -      n      -      1      proxymap
smtp      unix  -      -      -      -      -      smtp
587      inet  n      -      n      -      -      smtpd

the one that is in bold. saw it on the web that by adding that line would open a port 587, still my telnet to 587 failed.

stumped.

linuxlover.chaitanya 08-05-2010 02:25 AM

You can change back. But it would not matter. Port number is at their end and not yours. And I can telnet from my end. Google has policy where in they treat some number of requests in a particular amount of time to be spam. So you have to limit that. Not just google but most of the SMTP relays have relay limits per user or per IP. After that the requests are either banned or termed spam. This is done to prevent spams and bulk mails.

linuxlover.chaitanya 08-05-2010 02:26 AM

No you are not getting the point. It not the port at your end. It is the port at googles end.

Xanios 08-05-2010 02:26 AM

But how to limit that?x_x

linuxlover.chaitanya 08-05-2010 02:30 AM

You do not limit that. Its them who limit the requests for spam and bulk mailing. You can not control the server at their end and neither can you do anything about the policies. Those policies are there to prevent their servers from being misused for spamming.

Xanios 08-05-2010 02:31 AM

Oh okay.
So, is there no other way to solve the error?
Connection refused.


All times are GMT -5. The time now is 12:12 AM.