LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   evolution setup assistant in ubuntu (https://www.linuxquestions.org/questions/linux-newbie-8/evolution-setup-assistant-in-ubuntu-823461/)

Xanios 08-01-2010 10:40 PM

evolution setup assistant in ubuntu
 
i wanted to use this as an email server to receive and send emails from ubuntu server. i had nagios installed on my ubuntu, installed postfix too, so i thought i could somehow make use of this evolution setup assistant

but one thing i'm not sure is this:
take a look at this: http://www.zolved.com/synapse/view_c...ount_in_Ubuntu

Under the receiving email, the server is shown as email.iptouch.com , what should i replace this with? And also under sending email, the server i should put as what?

my ubuntu hostname is ubuntu. username is xanios

linuxlover.chaitanya 08-02-2010 12:45 AM

Am I missing something or do I not understand you? You want to use your own Ubuntu server for sending and receiving mails, is not it? Then why evolution? You need to configure your Ubuntu server first for the job. And then your evolution client.
As for the evolution configuration,
receiving server is your imap or pop3 server that you have been assigned by the mail provider. And sending server is the smtp server name. Both should be provided by the mail provider itself.

Xanios 08-02-2010 01:06 AM

I want use Evolution cause i thought after installing postfix in ubuntu, i must have a smtp server. So i thought Evolution could be the smtp server.

What should be the server name? i mentioned in the first post. should i put the server name using my ubuntu hostname? eg. ubuntu. So server name is ubuntu.

linuxlover.chaitanya 08-02-2010 01:25 AM

You need to read more. Evolution is the email client. Not a mail server. Postfix is the smtp server. You do not need to install it if you do not intend to host a mail service.
Where do you have your email hosted? Or you use a mail service from gmail, yahoo or such?

Xanios 08-02-2010 01:39 AM

Hmm. First i just want to try send mail on the localhost (ubuntu machine) When that works, i want to try other mail services like hotmail,gmail etc. I'm using Nagios on ubuntu 9.10. Send email notifications when server is down in nagios

linuxlover.chaitanya 08-02-2010 01:44 AM

I am still not able to understand you then. If you have postfix installed, then you only have smtp server. Not the IMAP or POP3. SMTP will just allow you to send emails not receive them. Evolution will need both sending server as well as receiving server. And if you need to just send mails, postfix should be enough.
Read postfix documentation on how to configure it and then use mutt or email command line clients to send mails to check your configuration.
The default configuration for postfix should allow you to send and receive mails on localhost as far as my knowledge goes about postfix.

Xanios 08-02-2010 01:49 AM

Hi Chaitanya,

Yeah i did read documentation on postfix and have configured it.

But i'm faced with this issue:
Could you take a look at this thread?
> http://www.linuxquestions.org/questi...ostfix-823443/

linuxlover.chaitanya 08-02-2010 02:05 AM

You can not directly send mails from your internal server to gmail without any internet records. It will not work that way. To send mails to external server, you will need to use relay for the purpose. Check the documentation on how to set a SMTP relay with authentication in postfix.
I do not have lot of experience with postfix and have not used it extensively. So my help is going to be very limited.

Xanios 08-02-2010 02:07 AM

I know i can't just directly send mails to gmail/hotmail etc. For now i just wanted to let Nagios notify me when services are down in localhost (by sending an email to localhost). That will do for me (:

linuxlover.chaitanya 08-02-2010 02:16 AM

For that you will need to set Nagios to send emails where you want it to and from which server.

EricTRA 08-02-2010 02:18 AM

Hi,

Just like linuxlover.chaitanya indicated, you'll first need to get the facts straight in order to understand how the mail system works. Here are some links to help you on your way:
Creating a Linux mail server (has a great image of the data-flow the mail follows)
Creating a Linux mail server II (very extensive guide)
http://ubuntuforums.org/archive/index.php/t-706606.html (almost copy/paste solution ONLY to send out mail to GMail)

I suggest you read the first link to get some understanding on the issue. If you want fast result so that you can get your Nagios notifications out the door, then follow the last link, and after that read the first to understand what you did ;)

Kind regards,

Eric

Xanios 08-02-2010 02:47 AM

Hi Eric,

Those are useful links. Thank you.

By the way, i created CA certificate (in the last link) but i typed some fields wrongly for the certificate, so how to delete the created CA certificate?

I tried to use this command again:

Code:

/usr/lib/ssl/misc/CA.pl -newca
But it didnt prompt me to create a CA certificate anymore. The first time i typed it it will ask me for it.

EricTRA 08-02-2010 03:25 AM

Hi,

To find out where your CA certificate is saved you can check your openssl.conf. I guess, since you're using Ubuntu that you can find it in /etc/ssl/.
Run this:
Code:

cat /etc/ssl/openssl.cnf | grep CA
You'll notice the header [ CA_defaults ]
Code:

[ CA_default ]
dir            = /etc/ssl/CA          # Where everything is kept
certificate    = $dir/cacert.pem      # The CA certificate

Delete the cacert.pem file and create a new one. You could also change the openssl.conf file to automatically present your data as default.

Kind regards,

Eric

Xanios 08-02-2010 03:44 AM

Hi,

thanks :)

hmm, is this the right command to delete it:

Code:

rm -f -r $dir/cacert.pem
Just want to be sure. thanks again

EricTRA 08-02-2010 03:47 AM

Hello,

No, the $dir variable only exist within the shell where openssl gets executed. You'll have to provide the full path or cd into the directory where the file is.
Code:

rm -r /etc/ssl/CA/cacert.pm
or
Code:

cd /etc/ssl/CA
rm cacert.pm

Kind regards,

Eric

linuxlover.chaitanya 08-02-2010 03:48 AM

Yes you can delete it that way. You need to be sure you give the command on the right directory.

Eric beat me with the typing speed.

Xanios 08-02-2010 03:50 AM

Hi,

it still doesn't get deleted. $dir/cacert.pem still remains.

EricTRA 08-02-2010 03:55 AM

Hello,

Are you logged in as root or as regular user? If regular user try executing the command with sudo?
Code:

sudo rm -r /etc/ssl/CA/cacert.pm
Kind regards,

Eric

Xanios 08-02-2010 04:02 AM

still can't.

Code:

xanios@ubuntu:~$ sudo rm -r /etc/ssl/CA/cacert.pm
[sudo] password for xanios:
rm: cannot remove `/etc/ssl/CA/cacert.pm': No such file or directory

does it mean i have to delete it using this:

Code:

sudo rm -r /etc/ssl/CA/$dir/cacert.pem

linuxlover.chaitanya 08-02-2010 04:04 AM

That is what I said. You need to be sure of the location of the certificate and at which location you give the command. It says there is no file you are trying to delete. Either the location is incorrect or the filename. verify both.

Xanios 08-02-2010 04:08 AM

Hi,

When i first created the CA Certificate, i issued the command at home directory:

Code:

xanios@ubuntu:~$ /usr/lib/ssl/misc/CA.pl -newca
i supposed that is called home directory. so by right when i delete the certificate from the same home directory, it should work.

EricTRA 08-02-2010 04:21 AM

Hello,

When you create a certificate with OpenSSL it uses the /etc/ssl/openssl.conf file to get the preferences. Did you check that file as I posted for the location of where the CA certificate will be saved? Check the directory as linuxlover.chaitanya indicated:
Code:

ls -al /etc/ssl/CA
to see if the file exists.

One thing comes to mind. When you executed the command did you accept the default or did you provide a name for the certificate? The first question when you run
Code:

/usr/lib/ssl/misc/CA.pl -newca
is to provide a filename or press enter to create.

If you typed a name for the certificate then of course cacert will not exist. Post the output of the command typed above to see what's in that directory.

Kind regards,

Eric

Xanios 08-02-2010 04:23 AM

Hi,

Code:

xaniosg@ubuntu:~$ sudo ls -al /etc/ssl/CA
[sudo] password for xanios:
ls: cannot access /etc/ssl/CA: No such file or directory

I did not provide a name for the certificate, i just press 'enter'. So it's the default one.

Code:

[ CA_default ]
dir                = ./demoCA                # Where everything is kept
certificate        = $dir/cacert.pem <<        # The CA certificate


linuxlover.chaitanya 08-02-2010 04:36 AM

Your directory where certificate is located is demoCA

Xanios 08-02-2010 04:40 AM

Hello,

Okay thanks, didn't notice it.

So i should go into demoCA first and delete the file which is:

Code:

xanios@ubuntu:~$ cd demoCA
xanios@ubuntu:~/demoCA$ sudo rm -r /etc/ssl/CA/cacert.pm
[sudo] password for xanios:
rm: cannot remove `/etc/ssl/CA/cacert.pm': No such file or directory

cd [something] is to go into a directory right.
but why they still give me 'cannot remove...'
Sorry, quite new in linux

EricTRA 08-02-2010 04:42 AM

Hi,

Beaten by linuxlover.chaitanya this time :)

As indicated before, the openssl.conf file holds your default configuration and it says it's saving in ./demoCA. This means that where you execute the command to create the certificate, that's where a directory demoCA will be created holding your certificate files.

Since you executed the command in your home directory you should have that demoCA directory there.

Kind regards,

Eric

EricTRA 08-02-2010 04:43 AM

Quote:

Originally Posted by Xanios (Post 4052409)
Hello,

Okay thanks, didn't notice it.

So i should go into demoCA first and delete the file which is:

Code:

xanios@ubuntu:~$ cd demoCA
xanios@ubuntu:~/demoCA$ sudo rm -r /etc/ssl/CA/cacert.pm
[sudo] password for xanios:
rm: cannot remove `/etc/ssl/CA/cacert.pm': No such file or directory

cd [something] is to go into a directory right.
but why they still give me 'cannot remove...'
Sorry, quite new in linux

Hi,

When in the demoCA directory type:
Code:

ls -al
and post the output here.

Kind regards,

Eric

EricTRA 08-02-2010 04:45 AM

Oops,

Just noticed:

When you're in the demoCA dir just type:
Code:

sudo rm -r cacert.pem
and not
Code:

sudo rm -r /etc/ssl/CA/cacert.pm
Kind regards,

Eric

Xanios 08-02-2010 04:46 AM

Hi,

this is the output:

Code:

xanios@ubuntu:~/demoCA$ ls -al
total 44
drwxr-xr-x  6 xanios xanios 4096 2010-08-02 00:43 .
drwxr-xr-x 41 xanios xanios 4096 2010-08-02 00:44 ..
-rw-r--r--  1 xanios xanios 3477 2010-08-02 00:43 cacert.pem
-rw-r--r--  1 xanios xanios  704 2010-08-02 00:43 careq.pem
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 certs
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 crl
-rw-r--r--  1 xanios xanios    3 2010-08-02 02:27 crlnumber
-rw-r--r--  1 xanios xanios    0 2010-08-02 02:27 index.txt
-rw-r--r--  1 xanios xanios  21 2010-08-02 00:43 index.txt.attr
-rw-r--r--  1 xanios xanios    0 2010-08-02 00:41 index.txt.old
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:43 newcerts
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 private
-rw-r--r--  1 xanios xanios  17 2010-08-02 00:43 serial


linuxlover.chaitanya 08-02-2010 04:48 AM

Quote:

Originally Posted by Xanios (Post 4052409)
Hello,

Okay thanks, didn't notice it.

So i should go into demoCA first and delete the file which is:

Code:

xanios@ubuntu:~$ cd demoCA
xanios@ubuntu:~/demoCA$ sudo rm -r /etc/ssl/CA/cacert.pm
[sudo] password for xanios:
rm: cannot remove `/etc/ssl/CA/cacert.pm': No such file or directory

cd [something] is to go into a directory right.
but why they still give me 'cannot remove...'
Sorry, quite new in linux

You are still deleting the file from /etc/ssl/CA directory. You need to delete file from demoCA directory.

cd to demoCA with
cd demoCA and now
rm -v cacert.pem

Xanios 08-02-2010 04:49 AM

Hi Eric,

i typed sudo rm -r cacert.pem

Code:

xanios@ubuntu:~/demoCA$ sudo rm -r cacert.pem
the certificate still remains.

Code:

xanios@ubuntu:~/demoCA$ cat /etc/ssl/openssl.cnf | grep CA
default_ca        = CA_default                # The default ca section
[ CA_default ]
dir                = ./demoCA                # Where everything is kept
certificate        = $dir/cacert.pem        # The CA certificate
# For type CA, the listed attributes must be the same, and the optional
# For the CA policy
# This goes against PKIX guidelines but some CAs do it and some software
# requires this to avoid interpreting an end user certificate as a CA.
basicConstraints=CA:FALSE
basicConstraints = CA:FALSE
# Extensions for a typical CA
#basicConstraints = critical,CA:true
basicConstraints = CA:true
# Key usage: this is typical for a CA certificate. However since it will
# nsCertType = sslCA, emailCA
# This goes against PKIX guidelines but some CAs do it and some software
# requires this to avoid interpreting an end user certificate as a CA.
basicConstraints=CA:FALSE


Xanios 08-02-2010 04:50 AM

Quote:

Originally Posted by linuxlover.chaitanya (Post 4052418)
You are still deleting the file from /etc/ssl/CA directory. You need to delete file from demoCA directory.

cd to demoCA with
cd demoCA and now
rm -v cacert.pem

it gave me:

Code:

xanios@ubuntu:~$ cd demoCA
xanios@ubuntu:~/demoCA$ rm -v cacert.pem
rm: cannot remove `cacert.pem': No such file or directory


linuxlover.chaitanya 08-02-2010 04:52 AM

Now if you have already deleted it, you will get the error.

EricTRA 08-02-2010 04:54 AM

Hi,

Do another ls in the demoCA directory to check if it's gone or not.
Code:

ls -al
when in the demoCA directory.

Kind regards,

Eric

Xanios 08-02-2010 04:54 AM

Hi Chaitanya,

Nope, still not deleted. i check it using cat /etc/ssl/openssl.cnf | grep CA and it is still there:

Code:

[ CA_default ]
dir                = ./demoCA                # Where everything is kept
certificate        = $dir/cacert.pem        # The CA certificate


Xanios 08-02-2010 04:56 AM

Hi Eric,

it is still there

Code:

-rw-r--r--  1 xanios xanios  704 2010-08-02 00:43 careq.pem

EricTRA 08-02-2010 04:58 AM

Quote:

Originally Posted by Xanios (Post 4052431)
Hi Eric,

it is still there

Code:

-rw-r--r--  1 xanios xanios  704 2010-08-02 00:43 careq.pem

Hi,

That's another file. The certificate is cacert.pem. careq.pem is the file used for a certificate request.

If cacert.pem is not in the demoCA directory then you can create a new one as you did before.

Kind regards,

Eric

Xanios 08-02-2010 04:58 AM

Hi,

Code:

xanios@ubuntu:~/demoCA$ ls -al
total 40
drwxr-xr-x  6 xanios xanios 4096 2010-08-02 02:51 .
drwxr-xr-x 41 xanios xanios 4096 2010-08-02 00:44 ..
-rw-r--r--  1 xanios xanios  704 2010-08-02 00:43 careq.pem
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 certs
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 crl
-rw-r--r--  1 xanios xanios    3 2010-08-02 02:57 crlnumber
-rw-r--r--  1 xanios xanios    0 2010-08-02 02:57 index.txt
-rw-r--r--  1 xanios xanios  21 2010-08-02 00:43 index.txt.attr
-rw-r--r--  1 xanios xanios    0 2010-08-02 00:41 index.txt.old
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:43 newcerts
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 private
-rw-r--r--  1 xanios xanios  17 2010-08-02 00:43 serial

i still cannot create a new one, means it is still there.

EricTRA 08-02-2010 05:00 AM

Quote:

Originally Posted by Xanios (Post 4052428)
Hi Chaitanya,

Nope, still not deleted. i check it using cat /etc/ssl/openssl.cnf | grep CA and it is still there:

Code:

[ CA_default ]
dir                = ./demoCA                # Where everything is kept
certificate        = $dir/cacert.pem        # The CA certificate


Hello,

This command doesn't tell you anything about the file itself. The only thing this command:
Code:

cat /etc/ssl/openssl.cnf | grep CA
does is show you the content of openssl.conf (cat command) and only those lines that contain CA (the grep part) in them.

Kind regards,

Eric

EricTRA 08-02-2010 05:02 AM

Quote:

Originally Posted by Xanios (Post 4052437)
Hi,

Code:

xanios@ubuntu:~/demoCA$ ls -al
total 40
drwxr-xr-x  6 xanios xanios 4096 2010-08-02 02:51 .
drwxr-xr-x 41 xanios xanios 4096 2010-08-02 00:44 ..
-rw-r--r--  1 xanios xanios  704 2010-08-02 00:43 careq.pem
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 certs
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 crl
-rw-r--r--  1 xanios xanios    3 2010-08-02 02:57 crlnumber
-rw-r--r--  1 xanios xanios    0 2010-08-02 02:57 index.txt
-rw-r--r--  1 xanios xanios  21 2010-08-02 00:43 index.txt.attr
-rw-r--r--  1 xanios xanios    0 2010-08-02 00:41 index.txt.old
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:43 newcerts
drwxr-xr-x  2 xanios xanios 4096 2010-08-02 00:41 private
-rw-r--r--  1 xanios xanios  17 2010-08-02 00:43 serial

i still cannot create a new one, means it is still there.

Hello,

OK, the drastic approach then ;)

Run the following:
Code:

cd
followed by <ENTER> that takes you back to your home directory. Then:
Code:

sudo rm -r demoCA
That will delete the complete demoCA directory after which you will be able to recreate your certificate from zero.

Kind regards,

Eric

Xanios 08-02-2010 05:03 AM

Hi,

but i still can't create the certificate?

Code:

xanios@ubuntu:~$ /usr/lib/ssl/misc/CA.pl -newca
xanios@ubuntu:~$

by right it should ask me to 'create a certificate..' but it didn't

Xanios 08-02-2010 05:05 AM

Quote:

Originally Posted by EricTRA (Post 4052442)
Hello,

OK, the drastic approach then ;)

Run the following:
Code:

cd
followed by <ENTER> that takes you back to your home directory. Then:
Code:

sudo rm -r demoCA
That will delete the complete demoCA directory after which you will be able to recreate your certificate from zero.

Kind regards,

Eric

Hi,

Okay. That did it. :)
But i wonder how come in the earlier approaches we can't seem to get the certificate deleted. =/ it's so weird.

Anyway, will continue to configure gmail for postfix, hopefully it works :) do wait for my latest update LOL =X

Thank you to both Eric and Chaitanya *thumbs-up- (:

EricTRA 08-02-2010 05:10 AM

Quote:

Originally Posted by Xanios (Post 4052447)
Hi,

Okay. That did it. :)
But i wonder how come in the earlier approaches we can't seem to get the certificate deleted. =/ it's so weird.

Anyway, will continue to configure gmail for postfix, hopefully it works :) do wait for my latest update LOL =X

Thank you to both Eric and Chaitanya *thumbs-up- (:

Hi,

I don't know exactly what the CA.pl script controls (have to read it to find out) in order to determine if a certificate exists or not. Most important is that you got it deleted and can start over again.

Good luck and someone is always around here on LQ to help out, so don't worry about that :)

Kind regards,

Eric

Xanios 08-02-2010 05:14 AM

Hi again,

You guys are really helpful, appreciated it lots :)

Lol sorry for the trouble but now i encountered a problem:

Code:

1 out of 1 certificate requests certified, commit? [y/n]y
Write out database with 1 new entries
Data Base Updated
xanios@ubuntu:~$ cp demoCA/cacert.pem FOO-key.pem FOO-cert.pem /etc/postfix
cp: cannot create regular file `/etc/postfix/cacert.pem': Permission denied
cp: cannot create regular file `/etc/postfix/FOO-key.pem': Permission denied
cp: cannot create regular file `/etc/postfix/FOO-cert.pem': Permission denied
xanios@ubuntu:~$

Am supposed to copy them to the /etc/postfix directory as mentioned in the last link you've provided :)

Xanios 08-02-2010 05:19 AM

Oops, sorry i forgot to put 'sudo'. Too agitated while doing LOL

linuxlover.chaitanya 08-02-2010 05:21 AM

Quote:

Originally Posted by Xanios (Post 4052454)
Oops, sorry i forgot to put 'sudo'. Too agitated while doing LOL

Hmmmmm....You are learning.

Xanios 08-02-2010 05:27 AM

Hi again,

Sorry >.<

hmm there's a part about SASL file, we have to set passwords for it. How to get into the file? Is it:

Code:

/etc/postfix/sasl
in the links they didn't specify. i assumed it is the above cause for transport it is /etc/postfix/transport


Code:

SASL
You now need to set the SASL passwords. My file looks like this one:
# Contents of sasl_passwd
#
[smtp.gmail.com]:587            mattoxbeckman@gmail.com:password
Of course, replace password and the email address with something appropriate for your system. Again, note the 587... if you leave that off, you will get very confusing log messages like this one:
Jan  4 18:20:30 calvin postfix/smtp[31770]: 49D438A6F:
to=, orig_to=,
relay=smtp.gmail.com[64.233.163.109]:587, delay=7661,
delays=7660/0.1/0.19/0.03, dsn=5.5.1, status=bounced
(host smtp.gmail.com[64.233.163.109] said:
530 5.5.1 Authentication Required 16sm56842404nzo
(in reply to MAIL FROM command))


Xanios 08-02-2010 08:21 PM

Hello again,

i've done configuring postfix to work with Gmail from the help of this http://prantran.blogspot.com/2007/01...untu-with.html

But still, i don't receive emails.

I went to take a look at mailq, i got:

Code:

B2FEB43535    2383 Mon Aug  2 11:09:02  MAILER-DAEMON
(delivery temporarily suspended: Host or domain name not found. Name service error for name=ubuntu.com type=MX: Host not found, try again)
                                        nagios@ubuntu.com
...
-- 6904 Kbytes in 6090 Requests.

and i also went to check in sudo vi /var/log/mail.log

Code:

Aug  1 08:33:50 ubuntu postfix/error[31385]: 5864D4296E: to=<xanios91@gmail.com>, relay=none, delay=239884, delays=239864/20/0/0.02, dsn=4.4.3, status=deferred (delivery temporarily suspended: Host or domain name not found. Name service error for name=gmail.com type=MX: Host not found, try again)
There were like thousands of records in mail.log, i have to scroll down from TOP to BOTTOM to get the latest which is like so frustrating..


This is my /etc/postfix/main.cf:

Code:

xanios@ubuntu:~$ postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = ipv4
mailbox_size_limit = 0
mydestination = $myhostname, $mydomain, localhost.localdomain, localhost
myhostname = ubuntu
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost =
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noanonymous
smtp_sasl_tls_security_options = noanonymous
smtp_tls_CAfile = /etc/postfix/cacert.pem
smtp_tls_cert_file = /etc/postfix/FOO-cert.pem
smtp_tls_key_file = /etc/postfix/FOO-key.pem
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = hash:/etc/postfix/transport


What's wrong? I'm confused X_X

linuxlover.chaitanya 08-03-2010 12:13 AM

Can you turn off DNS lookups and see if the error goes. I used Zimbra, which in turn uses postfix, for sometime and disabling DNS lookups can sometime help.

Xanios 08-03-2010 12:36 AM

Hi,

i added

Code:

disable_dns_lookups = yes
in /etc/postfix/main.cf

Still the same result.

Code:

BCC5F42281    2407 Sat Jul 31 10:53:32  MAILER-DAEMON
(delivery temporarily suspended: Host or domain name not found. Name service error for name=ubuntu.com type=MX: Host not found, try again)
                                        nagios@ubuntu.com


/etc/postfix/main.cf:
Code:

xanios@ubuntu:~$ postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
disable_dns_lookups = yes
inet_interfaces = all
inet_protocols = ipv4
mailbox_size_limit = 0
mydestination = $myhostname, $mydomain, localhost.localdomain, localhost
myhostname = ubuntu
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost = [smtp.gmail.com]
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noanonymous
smtp_sasl_tls_security_options = noanonymous
smtp_tls_CAfile = /etc/postfix/cacert.pem
smtp_tls_cert_file = /etc/postfix/FOO-cert.pem
smtp_tls_key_file = /etc/postfix/FOO-key.pem
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = hash:/etc/postfix/transport



All times are GMT -5. The time now is 12:57 AM.