-   Linux - Newbie (
-   -   eth0 not found (

Damnit73 04-30-2004 06:28 PM

eth0 not found
I've always had some intrest in linux, but I never got the chance to use it, until recently I downloaded and installed slackware 9.1, and everything was working fine until I tried to connect to the internet and discovered to my absolute horror (not really) that my networking card was missing (In linux, not physically) !

Can someone please help me?

Peacedog 04-30-2004 06:34 PM

did you skip the network configuration part of the install? how do you normally connect to the net? post some system specs, and the output of /sbin/lspci -v, and the output of lsmod. we'll see if we can get you going.

Damnit73 04-30-2004 06:45 PM

How do I post the output of those?

And some system info:
CPU: 600mhz P3
Motherboard: Dunno, my computer's not working, so I'm using someone else's computer.
Sound: A c-media card, can't remeber exactly, works fine.
Video: Nvidia Geforce 2 mx 32mb
Networking card: "Realtek RTL8019 PnP Lan adapter or compatable" according to windows.
Oh, and I use DSL modem (SpeedStream 5260).

Mathieu 04-30-2004 07:10 PM


How do I post the output of those?
Highlight the text using your mouse.
The highlighted portions are saved to the system clipboard.
You can than paste it anywhere.


You can save the ouput of any command to a file. The following command will save the ouput of /sbin/lspci -v to the /tmp/out-lspci file

/sbin/lspci -v > /tmp/out-lspci
You can than view, copy and paste the contents of the file (out-lspci) with any text editor.

odious1 04-30-2004 07:11 PM

You can post the output of the commands Peacedog suggested by at the command prompt :

lspci -v > textfile.txt
lsmod >> textfile.txt

You can then open with any editor and copy/paste.


Damnit73 04-30-2004 07:27 PM

Sorry for the delay, I went to watch some tv, I'll post the output in a few minutes.

Damnit73 04-30-2004 07:52 PM

Again, I'm sorry about the delay...


00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
Flags: bus master, medium devsel, latency 64
Memory at ec000000 (32-bit, prefetchable) [size=64M]
Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03) (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, medium devsel, latency 128
Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
Memory behind bridge: 2a000000-2b0fffff
Prefetchable memory behind bridge: 30000000-37ffffff

00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
Flags: bus master, medium devsel, latency 0

00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80 [Master])
Flags: bus master, medium devsel, latency 64
I/O ports at 1000 [size=16]

00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00 [UHCI])
Flags: bus master, medium devsel, latency 64, IRQ 9
I/O ports at 1020 [size=32]

00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
Flags: medium devsel, IRQ 9

00:0e.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
Subsystem: C-Media Electronics Inc CMI8738/C3DX PCI Audio Device
Flags: bus master, medium devsel, latency 64, IRQ 10
I/O ports at 1400 [size=256]
Capabilities: [c0] Power Management version 2

01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev a1) (prog-if 00 [VGA])
Subsystem: Guillemot Corporation: Unknown device 7108
Flags: bus master, 66Mhz, medium devsel, latency 248, IRQ 11
Memory at 2a000000 (32-bit, non-prefetchable) [size=16M]
Memory at 30000000 (32-bit, prefetchable) [size=128M]
Expansion ROM at <unassigned> [disabled] [size=64K]
Capabilities: [60] Power Management version 2
Capabilities: [44] AGP version 2.0


Module Size Used by Tainted: P
nvidia 1965152 5 (autoclean)
snd-pcm-oss 37252 1
snd-mixer-oss 11992 1 [snd-pcm-oss]
uhci 24496 0 (unused)
usbcore 58400 1 [uhci]
snd-cmipci 17760 3
snd-pcm 55904 0 [snd-pcm-oss snd-cmipci]
snd-page-alloc 6004 0 [snd-pcm]
snd-opl3-lib 5764 0 [snd-cmipci]
snd-hwdep 4672 0 [snd-opl3-lib]
snd-timer 13252 0 [snd-pcm snd-opl3-lib]
snd-mpu401-uart 3136 0 [snd-cmipci]
snd-rawmidi 12512 0 [snd-mpu401-uart]
snd-seq-device 3920 0 [snd-opl3-lib snd-rawmidi]
snd 27460 1 [snd-pcm-oss snd-mixer-oss snd-cmipci snd-pcm snd-opl3-lib snd-hwdep snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 3332 7 [snd]
pcmcia_core 40032 0
ide-scsi 9424 0
agpgart 39576 0

odious1 04-30-2004 08:42 PM

Either your nic is faulty or not compatable. I am not familiar with Realtek but I assume it is a PCI. Have you tried shutting down, moving to another slot if available and restarting possibly allowing the card to be detected?

I know the 8129/8139 cards are supported I am not sure about yours. What kernel did you install; the bare.i?

IMHO I would slap another card in there, something definately compatable (via, intel)


Damnit73 04-30-2004 08:44 PM

Yes, I've restarted, yes, it's bare.i, and it's an ISA, not a PCI.

odious1 04-30-2004 08:49 PM


In that case I want to say that drivers may be difficult if at all possible to find. You can do some googling on this site or the net to see if someone has written drivers but it would be much easier based on my experience to get something that will work right out of the box. That is one thing I learned the hard way with linux is that when fighting hardware compatibility; I usually loose.


Damnit73 04-30-2004 08:54 PM

After a quick google, I found their website, I think I found some drivers here but I'm not sure how to install it...

EDIT: There seems to be a guide to get it working on linux, I'll try that and tell you if it works...

EDIT2: No luck, I'll try to find another way...

Boow 04-30-2004 09:49 PM

network cards are cheap as dirt check in hcl for any your insterested in.

Damnit73 04-30-2004 11:39 PM

Yay! After doing a bit of searching, I managed to get the ne2000 module loaded, and I'm very happy to say I'm posting this from linux!

Qucho 05-01-2004 01:14 AM

CHHERS for Damnit73 !!!! :D

All times are GMT -5. The time now is 11:11 PM.