LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   eth0 interface not auto starting (https://www.linuxquestions.org/questions/linux-newbie-8/eth0-interface-not-auto-starting-93358/)

Limelight 09-16-2003 09:04 AM

eth0 interface not auto starting
 
Hello...

I recently installed Red Hat Linux Enterprise Edition 2.1 WS. This is my first Linux OS install and I'm having a bit of trouble with my ethernet adapter.

When I boot the machine, the loader gives me two options, 2.4.9-e12smp or 2.4.9-e12. It's been defaulting to the smp option, so that's what I've been using.

I also have the machine configured to automatically go to a GUI login screen. So far, I've been using the KDE interface.

When I get logged in to the KDE desktop, at a shell prompt I type "ifconfig" and it will only list the lo interface.

Then, I'll type insmod e1000 (the ethernet adap. is an itegrated Intel) and the module will load. Then when I do an ifconfig, I'll see both the lo and the eth0 interface. Also, once the eth0 interface is active, it keeps all of the settings that I previously gave it such as IP address, default gateway, and DNS servers.

So I guess my question is, is there a way I can get the OS to automatically activate the eth0 interface upon boot? It seems to work just fine if I manually activate via the shell. Is there a file or files that work like a STARTUP.NCF file on a Novell server that tell the machine what to load?

Sorry for the long post...just trying to be thorough. Thanks!

Demonbane 09-16-2003 09:39 AM

Not sure if it's different for the enterprise edition, but do you have a /etc/sysconfig/network-scripts/ifcfg-eth0 file?

Limelight 09-16-2003 10:11 AM

Demonbane,

Yes, that files does exist on my system. There's a line in that file that reads ONBOOT=YES, so I figure
that because of that switch, the system should at least be trying to start the interface
upon boot. Is there a bootlog file that I could look at to see if the system even tried
to start it?

Thanks!

Demonbane 09-16-2003 10:40 AM

you can take a look at /var/log/messages, try adding

Alias eth0 e1000

to your /etc/modules.conf, if it's not at least trying to bring up the nic.

Limelight 09-16-2003 11:33 AM

Demonbane...

Okay, well, I checked the /var/log/messages file and saw some references to e1000 and something about an invalid parameter parm_irq.

Then, when I checked the /etc/modules.conf file, I saw two lines in there:

alias eth0 e1000
alias options irq=10

I got rid of the alias options line, rebooted the system, and all is now good.

Thank you very much for your suggestions!

another_eric 09-16-2003 07:52 PM

from linux admin textbook
 
Had replied with info but hadn't read all the other replys. looks like you figured it out.

There is a text that I found helpful:
Linux Administration, A Beginner's Guide, Third Edition
by Steve Graham and Steve Shaw
McGraw Hill


All times are GMT -5. The time now is 05:59 PM.