-   Linux - Newbie (
-   -   error while loading shared libraries: cannot open shared object file: (

Franziss 09-26-2005 08:12 PM

error while loading shared libraries: cannot open shared object file:
I got this problem when i try to install any new program in fedora 4. why is it so?

bertlef 09-26-2005 08:36 PM

If it happens when you go Make could be because of the folder you are working in, I haven't used FC since v1 but in slackware you are restricted to install software only in certain folders, for example /tmp

Please be more specific.

Franziss 09-26-2005 08:41 PM

i download thunderbird installation, extract out the folder. under the folder, i type "./thunderbird" and the error message appear.

Then i copy the folder into /tmp and type "./thunderbird", but the error message still appears..

thanks for your help! =)

tkedwards 09-26-2005 08:53 PM

There are already thunderbird packages for Fedora, you don't need to download it from Try using yum to install thunderbird.

If you still want to use the unpackaged version from make sure you install the compat-libstdc++-33 package (it may be compat-libstdc++ in fedora) using yum.

bertlef 09-26-2005 10:01 PM

Are you root?

May be out of your path: echo $PATH.
And find if the file is there, if not make a link.

Franziss 09-26-2005 10:08 PM

sorry, i'm a newbie. So i type "yum install compat-libstdc++"?
yes, i log in as root in Fedora

Franziss 09-26-2005 10:25 PM

i download the package libstdcc from some where and install its rpm package. it can work now! thanks guys! =)

tkedwards 09-26-2005 10:52 PM


yum install compat-libstdc++
is correct. You should read this section of the Fedora FAQ about installing software:

Using yum should help you avoid probs like this in future

Franziss 09-27-2005 12:27 AM

ok, thanks for the help guys! I appreciate it.

bzposse 09-24-2006 02:10 AM

This thread has helped me too!!!!!
yum install compat-lib* worked for me...This is on FC4

Thanks all...

WindsofTime 06-28-2010 05:47 AM

I don't mean to bump an old topic here but..

I recently found this post by searching with Google and decided to join in order to ask this:

I still am having troubles getting this to work with my game server files. The files were originally written in an RedHat Linux OS many years ago.

It requires the lib mentioned at the beginning of this topic (but is, yet when I tried installing via:

"yum install compat-libstdc++" it returned saying no such package. (This is in the current Fedora 13 OS)

I then tried the "yum install compat-lib*" and it proceeded to download and install a plethora of stuff. Which now when I tell the game server to start and it executes the daemonctl which uses the required library.. it just goes silent and nothing else happens.

I don't know what I am doing wrong or if perhaps I need that specific library instead of all these new updated ones.

Any suggestions would be appreciated :)

All times are GMT -5. The time now is 11:21 AM.