LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Error when trying to install java runtime library (https://www.linuxquestions.org/questions/linux-newbie-8/error-when-trying-to-install-java-runtime-library-77145/)

downinthemine 07-29-2003 09:30 PM

Error when trying to install java runtime library
 
I am trying to install the java plug-in for Firebird. I think that I need to download the runtime library as when I clicked to install the plug in, downloaded it, and then restarted the browser nothing happened. I tried to install the rpm by typing:
rpm -ivh j2re-1_4_1_04-linux-i586-rpm.bin

and I received this message:
j2re-1_4_1_04-linux-i586-rpm.bin: read manifest failed: Success

Can someone help me install it properly?
thanks in advance

Tinkster 07-29-2003 09:43 PM

.bin != .rpm

You'll have to
sh j2re-1_4_1_04-linux-i586-rpm.bin


Cheers,
Tink

downinthemine 07-30-2003 01:28 PM

I'm sorry to ask what I think is an obvious question, but I did some checking on the web and I am still not sure what .bin != .rpm means

Tinkster 07-30-2003 02:33 PM

.bin usually indicates something executable.
.rpm is a package format used by the redhat
package manager.

"!=" means "not equal"

Cheers,
Tink

ksgill 07-30-2003 02:35 PM

.bin != .rpm means:
.bin is not the equal to .rpm.
! is bang or not (sign) used in different programming languages. Seems to me that tinkster has been doing a lot of programming and now he talks in code...:P :)

SADANA 07-31-2003 02:49 AM

issue the following on your shell as root:
./j2re-1_4_1_04-linux-i586-rpm.bin

this should display a license agreement for the JRE, then you have to respond as yes! or no if u don't like the agreement ;)

this unpacks a file, the actual RPM file, to the same directory, as i recall with the following filename: j2re-1_4_1_04-linux-i586.rpm

issue the following as root, just check the exact filename:
rpm -ivh j2re-1_4_1_04-linux-i586.rpm
this installs JRE!

in order to use the java plugin in firebird issue the following:
ln -s /usr/java/j2re-1_4_1_04/plugin/i386/ns610/libjavaplugin_oji.so /path/to/firebird/plugins/

P.S: i'm really not sure about the exact filenames or the path names, since it differs a bit in each release of JRE!


All times are GMT -5. The time now is 09:30 AM.