LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   error processing package mysql server (--configure) (https://www.linuxquestions.org/questions/linux-newbie-8/error-processing-package-mysql-server-configure-4175603624/)

corneliusudeh 04-11-2017 04:57 AM

error processing package mysql server (--configure)
 
hi guys! i'm new (not my name, i'm cornelius. but i am new to debian and LQ) i've been trying to install XAMPP since yesterday.

since i am new to unix,linux as a wehole i've found every step difficult. i hope it gets better though.


so my error:

i got a depedncy error, then i did the "apt-get -f install" then i got another error, i can't remember, the i did this "dpkg --configure --pending"

this is the result:

Setting up mysql-server-5.5 (5.5.54-0+deb8u1) ...
Job for mysql.service failed. See 'systemctl status mysql.service' and 'journalctl -xn' for details.
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.5 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.5; however:
Package mysql-server-5.5 is not configured yet.

dpkg: error processing package mysql-server (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
mysql-server-5.5
mysql-server


what can i do. i havent even configured my computer to run java, this is just for my php and i'm this stuck. i don't wan tot go back to windows

r3sistance 04-11-2017 05:19 AM

MySQL 5.5? That seems a bit old... I'd suggest getting MariaDB 10.1 instead: https://downloads.mariadb.org/mariad...e&version=10.1

Looks like you are using Debian 8, It looks like mysql-server depends on mysql-server-5.5. If you want to continue with this instead of MariaDB, can you do an 'apt-get install mysql-server-5.5' and see if that returns any issues.

corneliusudeh 04-11-2017 05:32 AM

Quote:

Originally Posted by r3sistance (Post 5695516)
MySQL 5.5? That seems a bit old... I'd suggest getting MariaDB 10.1 instead: https://downloads.mariadb.org/mariad...e&version=10.1

Looks like you are using Debian 8, It looks like mysql-server depends on mysql-server-5.5. If you want to continue with this instead of MariaDB, can you do an 'apt-get install mysql-server-5.5' and see if that returns any issues.

i don't know about mariaDB- if it'll work well with phpmyadmin.

but i tried "apt-get install mysql-server-5.5" and it returns the exact same thing!

here, look:

Reading package lists... Done
Building dependency tree
Reading state information... Done
mysql-server-5.5 is already the newest version.
mysql-server-5.5 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up mysql-server-5.5 (5.5.54-0+deb8u1) ...
170411 11:26:34 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
170411 11:26:34 [Note] Ignoring --secure-file-priv value as server is running with --bootstrap.
170411 11:26:34 [Note] /usr/sbin/mysqld (mysqld 5.5.54-0+deb8u1) starting as process 27196 ...
Job for mysql.service failed. See 'systemctl status mysql.service' and 'journalctl -xn' for details.
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.5 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.5; however:
Package mysql-server-5.5 is not configured yet.

dpkg: error processing package mysql-server (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
mysql-server-5.5
mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)


--------------------------------------------------------

if mariaDB will work better for me (i can use it with phpmyadmin), can you please walk me through its installation?
please, i am new to all of these kindly, be patient in helping with specific solutions. THANK YOU for your reply!

r3sistance 04-11-2017 06:02 AM

MariaDB works with phpmyadmin, altho phpmyadmin isn't a very good package to use. You have to lock phpmyadmin down to such a degree that I'd just end out using something else like heidisql anyways, if I needed such a utility.

It sounds like you probably have a configuration issue with mysql then, I'd advise checking the mysql logs (probably in /var/log/mysql/) and see if any errors are shown there. It'll probably highlight a bad configuration setting which will most likely be set in /etc/my.cnf.


All times are GMT -5. The time now is 06:21 AM.