LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   error: parse error before "uint32_t" (https://www.linuxquestions.org/questions/linux-newbie-8/error-parse-error-before-uint32_t-235677/)

paicolman 09-27-2004 04:25 AM

error: parse error before "uint32_t"
 
Hi,

Posted a similar thread some days ago, with no luck... Maybe too much text?

Cutting to the max, my problem is as follows:

Trying to "make" a dloaded package for my USB modem, I had to install linux.atm, which is included in the compilation. When compiling, I get this:

/lib/modules/2.6.4-52-smp/build/include/linux/atm.h:211: error: parse error before "uint32_t"

Now my guess is, some type of gcc library missing, but not sure. Any clues anyone?

Thanks!

PenguinPwrdBox 09-27-2004 05:52 AM

You have an ugly problem.
It doesn't sound like you are missing a library, as it would tell you something to the effect of:
"Cannot stat <filename>: No such file or directory."
However, yours is different.
Basically, it sounds as though there is an error in the code of /lib/modules/2.6.4-52-smp/build/include/linux/atm.h on line 211.
I would open the file in a text editor, find line 211, and either fix the error, or comment it out altogether.
To comment the line out, simply add the following to the beginning of the line:
Code:

//*
See if that helps.

qwijibow 09-27-2004 06:57 AM

the problem with drivers, is they have to be written and compiled for your EXACT kernel version.

what kernel version is the driver for ? it should say on the website or maybe a readme ?

you can get the anme of your current kernel by running the command "uname -r"

please provide the URL or the webpage where you downloaded the driver. it will help us help you ;)

paicolman 09-27-2004 07:24 AM

HI,

The driver is in http://sourceforge.net/project/showf...ckage_id=86598

I took the latest version of it (amedyn-2004-08-04-src.tgz), and my kernel is 2.6.4-52-smp.

What looks strange to me, is that it complains about the atm.h file, which is included in the kernel source. I rebuilt the source with no changes, to see if I got a similar error, but it went OK. The complete error line is:

Code:

In file included from /lib/modules/2.6.4-52-smp/build/include/linux/atmdev.h:12,
                from br2684ctl.c:10:
/lib/modules/2.6.4-52-smp/build/include/linux/atm.h:211: error: parse error before "uint32_t"

I don't know why does it complain for the uint32_t type, that should be a standard type for C. I tried compiling by changing that for "int", and gcc swalloed it...

Thanks for the answers.

qwijibow 09-27-2004 10:13 AM

ahh okay.....

well...unless you are feeling brave and want to attempt to fix this yourself, the only advice i can think of is to mail the author of the driver with the problem and error codes, then try an older version of the driver hoping that the error is not in the older one.... AND / OR try a newer kernel from kernel.org

paicolman 09-27-2004 10:28 AM

Hi,

I'll go for the "brave" option. I read a note from a guy who replaced the "uint32_t" by "int" and says it worked... I'll try out and write a how-to (or how-not-to, if it blows) for any poor newbies out there ttying this out...

Thanks for the advice!


All times are GMT -5. The time now is 06:00 AM.