LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-01-2012, 10:43 AM   #1
l0l0
LQ Newbie
 
Registered: Dec 2010
Posts: 1

Rep: Reputation: 0
error on installing fastcgi on rhel 6.2/centos 6:(13)Permission denied: FastCGI: does


very hurry! Can some one help? I will very appreciate your help. Thank you very much!

I did the following to install fastcgi on CentOS release 6.2 (Final) on 64bit: --
1/ $ yum install libtool httpd-devel apr-devel apr
2/ download from cd mod_fastcgi-2.4.6/http://www.fastcgi.com/dist/mod_fastcgi-current.tar.gz
3/ $ tar -xvzf mod_fastcgi-current.tar.gz
4/ $ cd /opt/mod_fastcgi-2.4.6/
$ cp Makefile.AP2 Makefile
$ make top_dir=/usr/lib64/httpd
( here get warning msg such asn line 769,774,962,967: warning: format ‘%ld’ expects type ‘long int’, but argument 3 has type ‘gid_t’ . The solve these warning msg by "vi fcgi_config.c" to change '%ld' to '%ho' in line 769, 774, 962, 967 )
$ make install top_dir=/usr/lib64/httpd


---- configuration ---
5/ vi /etc/httpd/conf.d/mod_fastcgi.conf => create new file with one line
LoadModule fastcgi_module modules/mod_fastcgi.so
6/[root@laolong157 mod_fastcgi-2.4.6]# /etc/init.d/httpd restart
7/ # tail /var/log/httpd/error_log
[Sun Apr 01 09:45:44 2012] [error] (13)Permission denied: FastCGI: doesn't exist and can't be created: Permission denied
[Sun Apr 01 09:45:44 2012] [error] (2)No such file or directory: FastCGI: can't create dynamic directory "/etc/httpd/logs/fastcgi/dynamic": doesn't exist and can't be created: No such file or directory
[Sun Apr 01 09:45:44 2012] [notice] Digest: generating secret for digest authentication ...
[Sun Apr 01 09:45:44 2012] [notice] Digest: done
[Sun Apr 01 09:45:44 2012] [error] (13)Permission denied: FastCGI: doesn't exist and can't be created: Permission denied
[Sun Apr 01 09:45:44 2012] [error] (2)No such file or directory: FastCGI: can't create dynamic directory "/etc/httpd/logs/fastcgi/dynamic": doesn't exist and can't be created: No such file or directory
[Sun Apr 01 09:45:44 2012] [notice] FastCGI: process manager initialized (pid 29021)
[Sun Apr 01 09:45:44 2012] [warn] mod_wsgi: Compiled for Python/2.6.2.
[Sun Apr 01 09:45:44 2012] [warn] mod_wsgi: Runtime using Python/2.6.6.
[Sun Apr 01 09:45:44 2012] [notice] Apache/2.2.15 (Unix) DAV/2 mod_fastcgi/2.4.6 mod_ssl/2.2.15 OpenSSL/1.0.0-fips mod_wsgi/3.2 Python/2.6.6 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations

8/ ** To solve the above problem, I did following to create these directory and change owner:
# mkdir /var/log/httpd/fastcgi
# chown -R apache.apache /var/log/httpd/fastcgi
# mkdir /var/log/httpd/fastcgi/dynamic
# chown -R apache.apache /var/log/httpd/fastcgi/dynamic
# /etc/init.d/httpd restart
Stopping httpd: [FAILED]
Starting httpd: [ OK ]

9/ ** And got another error message as following:
# tail /var/log/httpd/error_log
[Sun Apr 01 11:57:56 2012] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
[Sun Apr 01 11:57:56 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sun Apr 01 11:57:56 2012] [error] (13)Permission denied: FastCGI: apr_dir_open() failed
[Sun Apr 01 11:57:56 2012] [notice] Digest: generating secret for digest authentication ...
[Sun Apr 01 11:57:56 2012] [notice] Digest: done
[Sun Apr 01 11:57:56 2012] [error] (13)Permission denied: FastCGI: apr_dir_open() failed
[Sun Apr 01 11:57:56 2012] [notice] FastCGI: process manager initialized (pid 30367)
[Sun Apr 01 11:57:56 2012] [warn] mod_wsgi: Compiled for Python/2.6.2.
[Sun Apr 01 11:57:56 2012] [warn] mod_wsgi: Runtime using Python/2.6.6.
[Sun Apr 01 11:57:56 2012] [notice] Apache/2.2.15 (Unix) DAV/2 mod_fastcgi/2.4.6 mod_ssl/2.2.15 OpenSSL/1.0.0-fips mod_wsgi/3.2 Python/2.6.6 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations

Last edited by l0l0; 04-01-2012 at 12:26 PM.
 
Old 06-05-2012, 05:37 AM   #2
saintlier
LQ Newbie
 
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
it seems should modify the apache configration ...
vim /etc/httpd/conf/httpd.conf
find "<Directory "/var/www/icons">"
change "Options Indexes FollowSymLinks" to "Options Indexes MultiViews FollowSymLinks"
then find "#AddHandler cgi-script .cgi"
also modify it, change it to "AddHandler cgi-script .cgi .pl"
save&quit
restart httpd service
it may work...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Installing FastCGI on Scientific Linux gezginrocker Linux - Newbie 4 03-04-2012 09:04 AM
[SOLVED] Installing FastCGI on Scientific Linux gezginrocker Linux - Server 1 02-17-2012 10:01 PM
Error php fastCGI vuit Linux - Server 1 02-28-2009 11:48 PM
Installing mod_perl and FastCGI on Apache 1.3 initself Linux - Server 0 09-08-2006 07:57 PM
PHP5 FastCGI session errors (Permission Denied) neocookie Linux - General 2 06-07-2005 01:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration