LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   error: nam not working (https://www.linuxquestions.org/questions/linux-newbie-8/error-nam-not-working-4175551514/)

AInx 08-23-2015 12:53 PM

error: nam not working
 
Kindly help plz.
I installed Ns-allinonw-2.35 version. and wrote a simple code to begin with.
but I got the error
ns: finish: couldn't execute "nam": no such file or directory
while executing
"exec nam out.nam &"
(procedure "finish" line 7)
invoked from within
"finish"

I found a solution on some site saying u should go to the name directory and then type the command 'sudo make install'
I tried that, the bash asked for root pasword, I provided that and got the following responce:
make: *** No rule to make target `install'. Stop.

what to do now.

knudfl 08-23-2015 01:50 PM

Welcome to LQ.

? May be the old (year 2011) ns-allinone-2.35.tar.gz doesn't build nam ?

Usually no problems with the 'Nov 2014 update' ns-allinone-2.35_gcc482.tar.gz
( Updated to use all gcc versions 4.4.x .. 5.1.0 , + etc. updates )
https://drive.google.com/file/d/0B7S...ew?usp=sharing
Code:

tar xvf ns-allinone-2.35_gcc482.tar.gz
cd ns-allinone-2.35/
./install
cd nam-1.15/
sudo make install
cd ../ns-2.35/
sudo make install

Note : You can have as many ns-allinone-2.xx as you want, installed at the same time.
But : Do never add any *PATH text to .bashrc . Not required.


-

AInx 08-23-2015 03:17 PM

thank you for replying,
1) I just wanted to clerify that the ns part is working fine.(as far as I understand). because I tried simple codes that did not include nam and they worked out fine.

2) I downloaded and installed the suggested version using the given code, the ns was installed correctly and for nam I was again asked for password....provided.... and same error.

[sudo] password for ainy:
make: *** No rule to make target `install'. Stop.

knudfl 08-23-2015 05:41 PM

? Which Ubuntu version are you using ?


* A 'nam' package could be the solution for you :
http://www.linuxquestions.org/questi...-4175524760/#2
.. Download a package that fits your version / architecture (i386 or amd64),
.. and click the downloaded package to install it.


-

AInx 08-25-2015 02:08 AM

I guess it doesn't matter now :( it got corrupted. But it was ubuntu 12.02 and I was using it in parallel with windows 7.


All times are GMT -5. The time now is 11:03 AM.