-   Linux - Newbie (
-   -   error: Failed dependencies: (

Greenman 09-29-2004 05:52 AM

error: Failed dependencies:

I have got two Red Hat servers one is running up2date and the other is not as it is not registered with Redhat. I have copied the RPM's onto my second box and tried doing a

rpm -ivh *.rpm
rpm -Uvh --force *.rpm but no joy

Also I have tried installing individual rpm's like the following but still no joy

rpm -Uvh --force httpd-2.0.46-40.ent.i386.rpm
warning: httpd-2.0.46-40.ent.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
httpd = 2.0.46-25.ent is needed by (installed) mod_ssl-2.0.46-25.ent

rpm -Uvh --force mod_ssl-2.0.46-40.ent.i386.rpm
warning: mod_ssl-2.0.46-40.ent.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60
error: Failed dependencies:
httpd = 2.0.46-40.ent is needed by mod_ssl-2.0.46-40.ent


Is there anyway I can get around this???

Thanks All!!

Greenman 09-29-2004 06:15 AM

This seems to work

rpm -Uvh --force --nodeps httpd-2.0.46-40.ent.i386.rpm

scuzzman 09-29-2004 06:28 AM

But you're installing them with disregard for the dependencies, which could cause the program to malfunction. What you need to do, is install
httpd = 2.0.46-25.ent
that package first.

bullwinkle 09-29-2004 07:23 AM

No point in doing nodeps. infact try to avoid using it.
Try to get the correct versin os mod_ssl or httpd and install.
Infact i think it would pull many more watch out.
also uninstall the previous version before installing the newer one or use -Uvh --force always and never use nodeps.

All times are GMT -5. The time now is 11:27 PM.