LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Error during Nvidia Install... help (https://www.linuxquestions.org/questions/linux-newbie-8/error-during-nvidia-install-help-12332/)

rbw 01-22-2002 01:54 AM

Error during Nvidia Install... help
 
I've only been using Mandrake 8.1 for a few days. I'm getting errors with my GeForce Ti500 video card when attempting to run anything with GL so I downloaded the latest drivers from Nvidia.

I have the Kernel and GLX RPM files needed but I'm receiving these two error messages when using the RPM command:

Can not open packages index using db3 - operation not permitted (1)

can not open packages database in /var/lib/rpm

Please point me in the right direction.... Should I place these files somewhere else or set some sort of path? I put the files under my home area in a Nvidia directory.

Thanks in advance for any help,
Brent

da Perp 01-22-2002 03:56 AM

Maybe installing the db3somethingsomething.rpm
file on the mandrake cd will help.

isajera 01-22-2002 04:21 AM

you could try installing from the source (.tar.gz) - the readme's and install instructions in the tarball are pretty good.

rbw 01-22-2002 12:10 PM

I tried Tar but "Make" gives me an error during install
 
Yes, Tar was what I tried first.... must "Make" wasn't installed so I had to go get it. Once I had make... I couldn't install it. I got in error when running ./configure about CC not in path or something. I will try and get the exact error message later.

If anyone can help me get my NVIDIA drivers installed using Tar or RPM that would be great. I understand the NVIDIA instructions but nothing is working... tar or rpm.

I feel like something is not set... (like a SET statement for Path in DOS) - I've been using DOS and Windows for 13 years... this is a new ball game to me.

neo77777 01-22-2002 01:07 PM

Are you doing it as root? I am just curious cause the generic error as you presented is usually triggered if you are not allowed to perform the operation, hence you are a normal user not root. Become root and do it over, just a note do it without X running , switch to run level 3.
in XTerm type:

[#bash] /bin/su
[#bash] Password: #type the password for superuser (root)
[bash#] /sbin/init 3

The system will go to the run level 3 (no X or GUI whatsoever)
login as root
type the password
and install the Nvidia drivers with rpm -ihv NVIDIA_kernel-xx.xx.rpm
rpm ihv NVIDIA_GLX-xx.xx.rpm
edit the /etc/X11/XF86Config-4 as described in NVIDIA installation guide (read it!) logout of root
exit
login as a regular user
at the prompt type
startx
and you should be up and running

rbw 01-22-2002 01:10 PM

Yeah, I left that part out but I am using SU and Run Level 3 when getting the errors. Console only...

Any other advice?

neo77777 01-22-2002 01:12 PM

Then something is locking your rpm database, I am not sure what could it be.

pperon 01-22-2002 01:53 PM

No problem has plagued me more. I'm still working it out on RH 7.2 and my GF3.

:study: I would check out evil3D and read their articles regarding installation on different distros.

I found the nVidia installation readme to be a bit too general IMHO.

Hope this helps.

rbw 01-22-2002 02:19 PM

Half way there...
 
Well, I fixed the initial problem with RPMs. For some reason, I wasn't in root like I thought. I think I was in root before going to run level 3 and didn't switch back or something... but my new problem is:

The NVIDIA kernel rpm installed without error... but the GLX rpm states a conflict with an existing version (even the readme file) - so is there a switch on the RPM command instead of -ivh to overwrite existing files?

Also, how do you pause a --help? at the console (no X running) so I can see everything?

neo77777 01-22-2002 02:28 PM

it is
rpm -Uhv NVIDIA_GLX-blah-blah.rpm
but probably you'll need to delete the package
use
rpm -e NVIDIA_GLX
without rpm extention and then use the
rpm -Uhv NVIDIA_GLX-blah-blah.rpm


All times are GMT -5. The time now is 03:21 AM.