LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Error compiling tcpflow 1.2 for Sguil (https://www.linuxquestions.org/questions/linux-newbie-8/error-compiling-tcpflow-1-2-for-sguil-692359/)

d4jtwvb 12-22-2008 09:53 PM

Error compiling tcpflow 1.2 for Sguil
 
Hello:

I get this error when I ran make:

[root@localhost tcpflow-0.12]# make
gcc -DHAVE_CONFIG_H -I. -I. -I. -I/usr/local/libpcap/include -I/usr/local/libpcap/include -Wall -Wno-unused -I/usr/local/libpcap/include -c flow.c
flow.c: In function ‘create_flow_state’:
flow.c:80: error: incompatible types in assignment
flow.c: In function ‘close_file’:
flow.c:212: error: incompatible types in assignment
make: *** [flow.o] Error 1


Any ideas??

Thanks

knudfl 12-23-2008 05:11 AM

Welcome to Linux Questions.

"tcpflow-0.12" is from last century ( 1999 ) and will
probably compile with "gcc-2.xx"
gcc-3.3.6, gcc-4.1.1 or later will not work with this.

Any reason not to use "tcpflow-0.21 ??
0.21 will compile with all the gcc-4.x.x .

http://www.linuxquestions.org/linux/...Ask_a_Question
http://linuxsilo.net/docs/smart-questions_en.html
( Please tell, which Linux you are using, when a
question is asked, or add it in "Edit Profile"
here at the LQ site ).
....

d4jtwvb 12-25-2008 10:50 PM

Thanks! I did used the 0.21 and it worked. I was able to compile.


All times are GMT -5. The time now is 08:26 PM.