-   Linux - Newbie (
-   -   Error compiling Mesa-8.0.4: Package requirements (glproto >= 1.4.14) were not met (

gewmba 10-11-2012 02:52 PM

Error compiling Mesa-8.0.4: Package requirements (glproto >= 1.4.14) were not met
I have installed CAELinux 2011 (based on Ubuntu 10.04, Linux 2.6.32-43-generic) onto my Toshiba Satellite L755-S5258 laptop. As far as I can understand, the laptop uses shared memory graphics using Mobile Intel HD Graphics. I have looked into this because I currently can only get a resolution of 1024x768 instead of the 1366x768 I should be getting and thus I want to install the appropriate driver to solve this problem.

This has lead me to try to install the Intel 12.07 graphics package and so far the only way I have found to do this is by getting the various components mentioned at and installing them. Thus I have been attempting to install Mesa-8.0.4, and while compiling it the following error eventually appears:

checking for GLPROTO... no
configure: error: Package requirements (glproto >= 1.4.14) were not met:

Requested 'glproto >= 1.4.14' but version of GLProto is 1.4.11

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLPROTO_CFLAGS
and GLPROTO_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

So I tried to install/upgrade to the most recent version of glproto (1.4.16) but I have failed to figure out how to do this. I have also spent much time googling ways to do this but I have been unsuccessful. Part of my failing is definitely due to the fact that I don't even understand what glproto is.

So my question: how do you install/upgrade to a newer version of glproto?

knudfl 10-11-2012 03:47 PM

'gl-proto' is 5 text files : <headers>.h .
And the text file /usr/lib/pkgconfig/glproto.pc

So it couldn't be easier : Nothing needs compiling, nothing to "make".
> x11proto-gl_1.4.16.orig.tar.gz > tar xvf x11proto-gl_1.4.16.orig.tar.gz ;
cd glproto-1.4.16/ && ./configure --prefix=/usr/ && sudo make install


gewmba 10-12-2012 03:30 PM

That worked, thanks!

All times are GMT -5. The time now is 11:35 PM.