-   Linux - Newbie (
-   -   errno 5) input/output error (

c j alex 05-02-2008 08:52 AM

errno 5) input/output error

after I put dvd in,it load to the screen.I click on accessories, terminal. ubuntu@ubuntucame up.I typeing instuctor.But it keep saying no such files or directory.
Try it other way, it say only root can do that .

So I click on the install icon,fill all field.instlation
system copying files up 32 percent then it fail as befor.

The install encountered on error copying files to hard disk. ERRNO 5) input/output error.
this particular error is aften due to faulty cd-dvddisk or drive or faulty hard disk, it may help to clean the cd/dvd to burn the cd/dvd at a lower speed. or clean lens.
To check whether the hard disk is old and need of replacemint.

I buy the dvd fromweb site, cd-rom is fine, I clean the
dvd the lens. The hard disk is 7 years old was running winwows me, I click on somthing that give this error report. lot of folder came up. Target show 3 of those folder. CD-ROM, INITRD.IMG.VMLINUZ. Showan arrow from on the top of the folder point up.

BY the way when i install ubuntu. I use the entertir drive. Do you think my hard disk is shot?

I never realize lenex givso much problem until I reed sum of those Q and A.

Any help would be welcome.
C J.

dci-Japan 11-05-2008 09:52 AM

Installing Ubuntu 8.10 [Errno 5] My Success Story
My solution to [Errno 5] on Ubuntu install was to remove some RAM modules.

I had great trouble installing 8.10 to my computer (model: HP d330). It took me three days and countless hours researching around the internet. Here is my success story.

I downloaded the ISO and attempted to install from the Live CD. The following error appeared at about 24% of install process:

[Errno 5] Input/output error

This particular error is often due to a faulty CD/DVD disk or drive, or a faulty hard disk. It may help to clean the CD/DVD, to burn the CD/DVD at a lower speed, to clean the CD/DVD drive lens (cleaning kits are often available from electronics suppliers), to check whether the hard disk is old and in need of replacement, or to move the system to a cooler environment.

1. Attempted reburn CD-R at slower speed. Same error.
2. Attempted install with "Alternate CD". Same problem (it froze up somewhere in "copy files to disk" process).
3. Attempted boot from Live CD and double click "Install". NO GO. Wouldn't even start process.
4. Repeated all the above in various ways. Same results.
5. Tried changing the various choices under F6 on boot-up. Freeze or same error.
6. Live CD then begin to hang on boot from CD. Couldn't get anything to do anything.
7. Attempted to install from Flash card (using separate PC to set it up). Booted fine, but same error on install.
8. Attempted many solutions offered on various forums online. Still no luck.
9. Tried noapic options and others to no avail.
10. Tried repartitioning hard drive, and wiping hard drive and etc. etc. etc.
11.Gave up and installed Windows XP. Hated it (as usual). Waited several hours. Kept repeating all the above plus anything I could think of. Redownload ISO. Burn at slower speeds. Try Alternate CD. Try Flash card again. NO LUCK. Fiddle with various settings again.

And then I used the little grey cells in my head (as Poirot would say in an Agatha Christie novel). I remembered someone somewhere suggested RAM error as the culprit. I ran the memory test without a problem (that took many hours!), but still I was supicious about the memory. My PC has four memory slots but with 3 actually memory sticks. 256Mb (original memory stick that came with computer) + 1Gb (cheap no brand stick added later) + 1GB (another added no brand stick). I simply took out the two 1Gb stick and left only the original 256Mb stick and attempted an install. Bang! It worked. No error. No problem (except it was as slow as molassis to install...). After the successful install, I replaced the 2Gb of memory and rebooted. Everything worked out. RAM modules might be faulty but everything seems fine.

I'm not sure if this solution will help everyone. The cause of [Errno 5] might be different for each machine, and sometimes just trying a million attempts leads to an eventual success. But in my case, removing most of the RAM solved the problem.

Finally I can get on with enjoying Ubuntu 8.10.

vc_lq 06-06-2009 09:58 PM

I initially rolled my eyes while looking at dci-Japan's response/solution to this.

"How the hell could memory affect an I/O error?"

Well. I humbly take it back. Because running out of other options, I tried it anyway.... and it worked!!!

I had 6GB of RAM on 3 DIMMs, couldn't get past 32% or so on the install of Ubuntu 9.04. I removed all but one, and everything worked perfectly. So strange.

I suppose there's something about the dual-channel or triple-channel mode that is causing the problem? Either that or the installer is having problems with the large size of RAM (since the installer Live CD is I think i386, even though I was installing the 64bit version of Ubuntu.

So thank you to dci-japan :-)

ericsingo 06-28-2009 03:18 PM

I have fixed mine
I burned the ISO CD at a speed of 20 X on Vertabim CD-R and it worked like charm. Other no-brands CDs were all failing at 29%. I am now enjoying Ubuntu 9.04.

gramound 07-21-2011 06:33 PM

Other solution for [Errno 5] Input/output error
Other possible solution: swapping SATA cables between HD and CD-ROM. It did the trick for my Dell Inspiron 530 with Ubuntu 11.04.

Twister512 07-29-2011 03:21 PM

I am having the same exact error with 11.04. Here is what I have done so far: I initially ran memtest overnight, and no errors came up, so then I swapped the sata cables for new ones, swapped in a known good cd-rom, swapped in a known good hard drive, then swapped in a known good IDE hard drive and still no luck at all. I tried to manually partition the drive with no success. I have a bootable diagnostic cd with a couple CPU tests and they all passed. Other than the motherboard being faulty somehow, I am kind of stumped!

ravidborse 12-29-2011 09:42 PM

write failed: Input/output error or Power Calibration Area Error
Hi All(Solved in my case)

- To Resolve Below Error related to my Sony DVD-RW Just Remove your DVD-RW player.
- In UBUNTU(10.10) you will get error related to Power Calibration Area Error. But in Fedora you
will get like shown below. You can use the below steps as mentioned below to resolve the error.
- Open it with the screwdriver(Its very Easy). Now you can see the Reader-Writer Lense .
- Take any solution(Prefer Alcoholic or the solution you use it to clean LCD) and cotton.
- Use a cotton swab and something like alcoholic solution(small) to gently wipe the lens. Just a quick scrub will do.

- Dry the laser pickup lens with the other end of the swab.Keep it 10-15 Mins to dry that lens.
- Do this carefully Please. I have done it on my own risk. you can also. below is the error
- Write the CD/DVD at the very Lowest Speed.


DVD-RW Sequential

SONY DVD RW AW-G170A 1.74 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump] [%7]

K3b Version: 2.0.2
KDE Version: 4.5.5 (KDE 4.5.5)
QT Version:  4.6.3

Used versions
growisofs: 7.1

Executing 'builtin_dd if=/dev/fd/0 of=/dev/sr0 obs=32k seek=0'
/dev/sr0: "Current Write Speed" is 2.0x1352KBps.
          0/669122560 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU  0.0%
=== last message repeated 20 times. ===
:-[ WRITE@LBA=0h failed with SK=0h/ASC=00h/ACQ=02h]: Input/output error
:-( attempt to re-run with -dvd-compat -dvd-compat to engage DAO or apply full blanking procedure
:-( write failed: Input/output error

growisofs command:
/usr/bin/growisofs -Z /dev/sr0=/dev/fd/0 -use-the-force-luke=notray -use-the-force-luke=tty -use-the-force-luke=4gms -use-the-force-luke=tracksize:326720 -dvd-compat -speed=2 -use-the-force-luke=bufsize:32m

pdany4 01-14-2013 04:33 AM

Hi all,

I just had the same problem, but solved now!

I re-burn the same iso image from the PC to my baby (another writer) still 4X and I put it on my PC with 8GB of RAM and it works perfectly!

My 2 DVD drives in the PC in question are engraved Optiarc AD-5260S (a shot list for lsscsi) (after installing the package: if you want to check ref of yours without removing the PC)

I had no idea a problem as stupid, they are becoming almost nine ALL!

Brand to avoid, and all done with these CD Drives: to repeat!


If you have any other CD / DVD which does not pass or kidding (I had two in my mp3 radio, I thought that was dirty look) it is made ​​by burning certainly missed, the effect and that means intermittent and that makes all the tracks on the CD!


All times are GMT -5. The time now is 03:23 AM.