LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-18-2001, 10:22 AM   #1
j-charles
Member
 
Registered: Sep 2001
Location: dunkerque, france
Distribution: mandrake 9.0 -> debian woody
Posts: 39

Rep: Reputation: 15
epson usb printer


I've just bought an EPSON STYLUS COLOR 580 printer and a pci card to plug my usb-printer on, since I had no usb port.

FIRST, using Printerdrake, i've set the printer on /dev/usb/lp0 , and then Cups understands it right.
Trouble arises at this point : I can't print anything !!!!!!

I read some advice on the forum, and here is the result*:

1) /proc/bus/usb/devices
-> it's empty !!!

2) /.../rc.modules
-> i've added : modprobe printer (shouldn't I also load usb-hci ?)

3) lsmod :
printer 3956 (unused)
usbcore 43632 [printer]


4) dmesg :
usb.c : registered new driver usbdevfs
usb.c : registered new driver hub
usb.c : registered new driver usblp
-> it looks like there's no bus number assigned and no port detected

5) lspcidrake :
OPTi Inc.I82C861 (SERIAL_USB usb-ohci) Subvendor=0*10456 Subdevice=...
-> I can't see the printer in /dev/usb/lp0

6) cat something > /dev/usb/lp0
-> I had something like "no such peripherical device"


I can't understand everything, but hope it will help you to telling me what happens.
 
Old 12-19-2001, 11:17 AM   #2
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Do "modprobe usb-ohci" and see if that helps, if it does, add it to rc.modules.

Last edited by Aussie; 12-19-2001 at 11:19 AM.
 
Old 01-07-2002, 03:48 AM   #3
j-charles
Member
 
Registered: Sep 2001
Location: dunkerque, france
Distribution: mandrake 9.0 -> debian woody
Posts: 39

Original Poster
Rep: Reputation: 15
Though I did modprobe usb-ohci, it won't work. Many changes I noticed :

1) lsdev :
Device : usb-ohci, DMA: /, IRQ:11, I/O ports: /
-> there's no port ?

2) lsmod :
usb-ohci 12624 0 (unused)
usbcore 43632 1[uxb-ohci printer]

3) demesg :
usb-ohci.c: usb ohci at membase 0*c6098000, IRQ 11
usb.c : new Usb bus registered, assigned bus number 1
usb.c : USB new device connect, assigned device number 1
usb.c : USB new device connect, assigned device number 2
printer.c : usblp0 : USB Bidirectional printer dev 2 if 0 alt 0

4) cups :
-> the printer didn't react at all. and the device /dev/usb/lp0 is still unknown. (cups tells me : "unable to open usb port device file : no such periqheical device")




Could someone also tell me how to configure cups options ? Each time I start Kups, I can read "can't connec to cups server, check your options" . The only way to have it right I found is to run printerdrake once (then , I can print on a parallel-port-printer). My options are :
- user:root
- cups host : localhost
-cups port : 631
- cups configuration file : /etc/cups/cupsd.conf
Where can I find an example of a configuration file ?
 
Old 01-07-2002, 04:08 AM   #4
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
There are three different usb chipset drivers, exactly which one to use depends on the chipset on your motherboard. If you can post the motherboard make and model I should be able to tell if usb-ohci is the correct module or weather you should be using another one.
 
Old 01-25-2002, 04:20 AM   #5
j-charles
Member
 
Registered: Sep 2001
Location: dunkerque, france
Distribution: mandrake 9.0 -> debian woody
Posts: 39

Original Poster
Rep: Reputation: 15
It's a dual-pentium PCI-ISA Bus Mainboard . The model is Ga-586DX, but it's without a usb port!

I've added a pci card to plug my printer on : I con read on it :
-> <CF> 04V0 94V-0 E119801
-> CE 1051P
-> Made in Taiwan FCC : H9MSER40XX VER:2.0
And on the chipset itself :
-> OPTi
-> FireLink
->82C861
-> 140119
-> 10UE
That's all...
 
Old 01-25-2002, 04:35 AM   #6
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Aha..an add on usb card..do "cat /proc/pci" and post the details of the usb card.
 
Old 01-28-2002, 07:32 AM   #7
j-charles
Member
 
Registered: Sep 2001
Location: dunkerque, france
Distribution: mandrake 9.0 -> debian woody
Posts: 39

Original Poster
Rep: Reputation: 15
I did a cat /proc/pci :

Bus 0, device 10, function 0:
USB Controller: OPTi Unknown device (rev 16).
Vendor id=1045. Device id=c861.
Medium devsel. Fast back-to-back capable. IRQ 11. Master Capable. Latency=32.
Non-prefetchable 32 bit memory at 0xe1004000 [0xe1004000].
 
Old 01-28-2002, 08:16 AM   #8
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Ok the OPTi cards use OHCI, do "modprobe usb-ohci" then try the printer.
 
Old 03-17-2002, 04:38 PM   #9
j-charles
Member
 
Registered: Sep 2001
Location: dunkerque, france
Distribution: mandrake 9.0 -> debian woody
Posts: 39

Original Poster
Rep: Reputation: 15
thanks.

I recently solved my problem by thinking a little bit : 'I' must be wrong somewhere...(everything looked all right)
I was. I had just to turn on my printer before launching linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Epson USB printer just stops arubin Slackware 8 09-25-2005 06:30 PM
Epson C84 USB Printer mdg Linux - Hardware 14 11-11-2004 03:05 PM
Installing Epson cx5200 usb printer lobo78 Debian 3 03-08-2004 11:17 PM
Epson C60 USB Printer not recognized jrgalan Linux - Newbie 0 08-21-2003 02:44 PM
how can i install my Epson C41UX - USB Printer in RH 8? kublador Linux - Hardware 2 03-02-2003 12:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration