LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Encrypted Debian USB OS Unable to Boot on Newer Machines (https://www.linuxquestions.org/questions/linux-newbie-8/encrypted-debian-usb-os-unable-to-boot-on-newer-machines-4175632192/)

Shadey 06-18-2018 06:06 PM

Encrypted Debian USB OS Unable to Boot on Newer Machines
 
Hello!

I have been using an encrypted debian disto on a thumb drive to separate confidential data from my personal computer usage for some time now. Recently, I upgraded to a new laptop and my boot process only goes to the GRUB when booting on the new laptop. I can select my distro, but do not get to a prompt for my password. Instead, it cycles through a series of lines over and over. Included is a BUG: soft lockup error that I have had some luck removing via edit function during the distro selection screen, but I have never been able to get to my password prompt. This distro boots fine on the old laptop, just not on the new. I'd rather not have to carry around both!

My best guess is that the problem is that the newer device is UEFI and my USB distro is a legacy-booting system. This new laptop has an option in its bios for supporting both legacy and UEFI, which I needed to turn on just to get to the first screen. So that is currently set at "both". I thought that would resolve this. But then again, my desktop can boot my USB distro and it is also a UEFI setup (with a few bios tweaks having to do with my sata controller). Could it have something to do with a driver or hardware incompatibility?

I have taken a picture of what goes across the screen, as I cannot find a way to get logs if I cannot boot the system:
https://imgur.com/a/JQYdzWk
NOTE: This screen shot is with an older distro option I tried to load from the bootloader, but the error appears to be the same to me regardless of the build I choose.

Is there any hope for this distro? Or do I need to start from scratch?

Thanks for your help!

jefro 06-18-2018 06:50 PM

I'd kind of think it has to do with grub naming or support for hardware maybe over any uefi issue. In truth uefi could present some set of devices but it usually allows you to set boot order in bios. Since you say you get to grub (hopefully on usb) then we have to assume a lot is correct? How did you encrypt this?

Ztcoracat 06-18-2018 07:09 PM

I'm with jefro; sounds like support for hardware and a uefi issue.

Disabeling the secure boot or the quick boot may help:-

Since the distribution boots on the other machine but not on your new laptop you may just need a newer kernel to support the newer hardware.:)

When a system won't boot to desktop it has to be xorg, the kernel or maybe a proprietary video driver most likely.
It could also be something in the init system (sysvinit, startup and systemd) but in testing it's xorg related.
Run a update, if that doesn't work try Recovery Mode and direct it to boot when it get's around to asking what you want.

What version of Debian are you running?

Ztcoracat 06-18-2018 07:23 PM

A 'soft lockup' is defined as a bug that causes the kernel to loop in kernel mode for more than 20 seconds, without giving other tasks a chance to run.

https://www.suse.com/support/kb/doc/?id=7017652

https://bugs.debian.org/cgi-bin/bugr...cgi?bug=864312

Shadey 06-19-2018 12:35 PM

To Jefro: I encrypted it through the installer at the time and put the unencrypted boot information on a small partition on the usb drive (as opposed to a dual boot system).

To Ztcoracat: Secure boot was already disabled. I should have mentioned that. My version of debian is 9.4 currently. I have relied on apt-get update and apt-get dist-upgrade for all updating and last updated the system in late May-- as I do not typically allow this system consistent access to the internet. I can certainly try to update that and see if it helps.

Could a video driver get loaded before my system gets unencrypted though? If I do not enter my password, the contents of the operating system shouldn't be accessible yet. I assumed it had something to do with whatever comes before the OS, but maybe that is my ignorance regarding how this works.

Shadey 06-19-2018 01:34 PM

I ran apt-get update and apt-get dist-upgrade using my old laptop. It still cannot boot to the new laptop. Same result. I disabled quick boot as recommended as well.

Booting into recovery mode results in the same repeating lines pictured above. It offers some variation though. At the end of each cycle, sooner or later, appears a message that states: "perf: interrupt took too long (##### > ####). Lowering kernel.perf_event_max_sample_rate to #######. NMI handler (perf_event_nmi_handler) took too long to run: 2.575 msecs." Other than that extra piece of information, it just cycles through this just as if I was not attempting to boot in recovery mode.

Ztcoracat 06-19-2018 01:58 PM

Quote:

Could a video driver get loaded before my system gets unencrypted though?
I think so, yes:-

Once modprobe has identified which module file (.ko) contains the requested driver, it loads the module file into the kernel: the module code is dynamically loaded into the kernel.

The automatic loading of modules happen when the kernel detects new hotpluggable hardware.

Modules can be found in lsmod.

jefro 06-19-2018 02:17 PM

Guess you could set bios to legacy/csm only. I'm not sure if you meant that you tried both uefi and csm apart from each other.

Guess you could build a simlar debian level usb from scratch and test new system.

When you select the usb drive, exactly how do you do it?

Exactly how is this OS installed by the way. I didn't get the part about usb separate.

Shadey 06-19-2018 03:50 PM

To Jefro:
My BIOS has two options: "UEFI Only" and "UEFI and Legacy". When it was set to UEFI Only (default), I could not get to GRUB. It is now set to UEFI and Legacy, which allows me to get to GRUB. But it does not allow me to get to my password.

I am not sure what you are asking for these other two questions, but I will try to explain better. The USB drive is a bootable device. It has its own master boot record and its own partition for GRUB on the USB drive (not on any host computer). The rest is encrypted. So, to access it, I must manually select to boot from the usb drive instead of the hard drive on the laptop or desktop I am using. In essence, everything related to this OS should be local on the USB.

To install this system, I ran a Debian installation USB and left most things stock through that install. The OS went into an encrypted logical volume that filled up the whole of the drive and the GRUB is in a small partition outside of that volume so it can boot. I am not sure what else you are looking for. That may have to do with my inexperience here.

Unfortunately, I do not have spare drives to make new operating systems with and test them on this machine. I was hoping to avoid remaking the distro, but unless you all can think of anything else to try, that is probably where I will end up.

jefro 06-19-2018 05:00 PM

Go to bios and set the usb as a hard drive option above the internal drive if you would. Boot to a hard drive order choice.

Shadey 06-19-2018 05:24 PM

I have moved the usb drive up to the top priority in booting. The result is the same repeating lines and no password option. If I boot to the boot menu, it is listed first.

jefro 06-19-2018 07:12 PM

Exactly what version of Debian do you have? What is kernel level?

If you can access the command line in grub it may help eventually.

Ztcoracat 06-19-2018 07:15 PM

Debian 9.4.

What's the ouput of:
Code:

uname -a

Shadey 06-20-2018 02:31 AM

Debian version is 9.4.
Kernel is 4.9.0-6-686-pae

Output of uname -a:
"Linux user 4.9.0-6-686-pae #1 SMP Debian 4.9.88-1+deb9ul (2018-05-07) i686 GNU/Linux"

jefro 06-20-2018 02:43 PM

Still I'd think some issue with how grub views this drive.

Do you have a way to boot linux outside of this usb? Use it to copy off data maybe to start. Then I'd see about auto fix grub maybe. https://www.howtogeek.com/114884/how...ntu-wont-boot/


All times are GMT -5. The time now is 09:14 AM.