Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-02-2006, 01:27 PM   #1
LQ Newbie
Registered: Feb 2004
Distribution: Debian 3.x etch (testing)
Posts: 24

Rep: Reputation: 0
Enabling Disabled Kernel Option


I'm trying to compile my 2.6.15 kernel to support hotplug firmware loading, but in menuconfig I seem unable to select it, there's "---" instead of "< >" next to it. The same is also true of HOTPLUG. Neither seem to be dependant on anything, compiling the kernel appears to leave it out. How do I select Y or M for these?!?
Old 03-02-2006, 01:51 PM   #2
Registered: Apr 2004
Location: new york
Distribution: win2k,ubuntu,sw13,arch,centos5.3
Posts: 815

Rep: Reputation: 31
There's a key you press for help on any particular kernel config option.Some have [ ] which you can click on to expand and others have( ). The kernel has KMOD option,not the same as hotplug support for devices, should be enabled with (*)that allows it to load modules it sees as needed. Make sure you also have(*) for support for hotpluggable devices. You choose *,M or blank for any option.
Any way go step by step thru each section and look thru help files to get the optimal kernel config. And then go back and review your steps. If you have another 2.6 kernel config file you can use that as guide(or use make old config); or your friendly neighborhood linux user(LOL) may help. Ask again if you have a question.
Old 03-02-2006, 01:58 PM   #3
LQ Newbie
Registered: Feb 2004
Distribution: Debian 3.x etch (testing)
Posts: 24

Original Poster
Rep: Reputation: 0
I have read the help, it doesn't actually mention what to do when there's "---" next to an option.

As for what you mentioned, on menuconfig it looks like:-

Loadable module support
\[*] Enable loadable module support

General setup
--- Support for hot-pluggable devices

Last edited by SMurf7; 03-02-2006 at 01:59 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Irq 10 disabled after kernel switch Taikon Slackware 3 02-08-2006 01:10 PM
enabling command option completion s_deepblue Debian 4 12-02-2005 05:42 PM
Nicotine - connect option is disabled Tremendo Linux - Software 5 10-19-2004 12:13 PM
"PNP" Option Disabled/Configuring 2.6.3 robbow52 Linux - Software 0 02-24-2004 07:04 AM
kernel compiling disabled my printer? doublefailure Linux - Hardware 2 09-11-2002 07:23 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:45 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration