Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-28-2009, 09:18 AM   #1
LQ Newbie
Registered: Nov 2006
Posts: 5

Rep: Reputation: 0
Question Enable rsh service on RedHat Enterprise version 5


I would like to enable rsh service on redhat enterprise version 5.
My system is a DELL quadricore 64 bit system and I would like to run
mpich compiled parallel applications.

However I have rsh installed but when I run rsh -n <hostname> ls
under root I get the error message
connect to port 544 : connection refused
krb4 rsh
connect to port 544 : connection refused
trying normal rsh (/usr/bin/rsh)
permission denied

I have added the hostname and user name in the hosts.equiv file under/etc
I have also edited the rsh file under /etc/xinetd.d folder and
have changed the value of rsh disable to no
I have created a .rhosts file under my user home folder and have
specified the hostname & username

can you please help

Old 05-28-2009, 09:35 AM   #2
LQ Guru
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,406
Blog Entries: 15

Rep: Reputation: 1424Reputation: 1424Reputation: 1424Reputation: 1424Reputation: 1424Reputation: 1424Reputation: 1424Reputation: 1424Reputation: 1424Reputation: 1424
First verify that xinetd is listening on port 544.
lsof -i :544
This will show you any activity on port 544.

You probably need to open up port 544 in the firewall which iptables.

Try running "service iptables stop" then doing your test. If it works then it confirms it was iptables blocking it.

Once you've confirmed that you need to "service iptables start" to restart iptables. You can then open up the port with the following procedure:

1) cd /etc/sysconfig

2) cp -p iptables iptables.CCYYMMDD

3) iptables-save >iptables-save.CCYYMMDD

4) iptables -D RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited
### Deletes the icmp rule from end of rules.

5) -A RH-Firewall-1-INPUT -p tcp -m state --state NEW,ESTABLISHED -m tcp --dport 544 -j ACCEPT
### Opens port 544

6) iptables -A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited
### Readds the icmp rule as last rule.

7) iptables-save >iptables
### Saves to file read on iptables start - insures new rule is loaded during reboot and bounces.

Steps 2 and 3 save existing configuration and can be used to back out if there are any issues.
Old 06-05-2009, 03:33 AM   #3
LQ Newbie
Registered: Nov 2006
Posts: 5

Original Poster
Rep: Reputation: 0

I have been able to enable rsh services.

Now I am facing another problem
I want to run mpich parallel application.

My system is a quadcore and I am trying to run mpirun on 4 processors.
However when I run I get the error message
p0_24205: p4_error: Could not gethostbyname for host NASSAU; may be invalid name
: 61

Here NASSAU is the hostname
I have specified the hostname in users home folder in .bashrc & .bash_profile file
I have also specified the hostname and no.of processors in mpich/share folder in file
machines.LINUX file

Is it possible to get a solution



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to enable rsh service in linux? mathavi Linux - Newbie 3 10-14-2012 02:57 PM
How to reinstall the DNS Service on RedHat Enterprise Linux v4 LotharIrausquin Linux - Server 3 04-22-2009 05:19 PM
Linux REDHAT Enterprise Version 4 Skulldeath9000 Linux - Newbie 3 12-05-2007 06:32 AM
Enable DOM in PHP5, Redhat Enterprise 4 pxumsgdxpcvjm Programming 0 09-14-2006 04:19 AM
how to enable pop3 service in redhat advaced server 3 ehpserver Linux - Networking 1 12-15-2003 10:29 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:34 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration