Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-05-2003, 09:44 AM   #1
LQ Newbie
Registered: Mar 2003
Distribution: Rethat 8.0
Posts: 23

Rep: Reputation: 15
emu-config digital outup, I'm lost HELP!

Ok this guy has the exact setup as me, Only I don't even know how to get my turn digital ouptut on in linux, let alone on boot LOL Guess that is why I'm a linux newbie. Anyhow, was wondering if someone could explain the emu-config -d to me. I ran it in a terminal and nothing happend just command not found so i'm aperently dooing somthing wrong and then after that if you kind enough could you explain what I have to do to /etc/rc.local host, to get my speakers to boot on digital insted of analog.

Thanx alot,

P.S. here is the message i found.
I am using a SoundblasterLive sound card, and Boston Acoustic digital speakers. Using emu10k, I get output to headphone on analog, and used emu-config -d to switch to digital output for the speakers.

I have no idea how to set this up so that the output is digital on boot up.

Can anyone help me here?

can your put the neccessary commands in /etc/rc.local ?
Old 04-03-2003, 09:28 AM   #2
LQ Newbie
Registered: Apr 2003
Location: Earth
Distribution: Fedora 6
Posts: 28

Rep: Reputation: 15
I have the same setup as you. Here is the process that I under went to get the driver and digital out working on my Redhat 8 system.

Drivers/tools installed(


1) extract emu10k1-v0.20a.tar.bz2
cd to emu10k1-v0.20a
make install

2) Install emu-tools-0.9.4-1.i386.rpm or tarball(whichever you prefer.

3) edit /etc/modules.conf and add the line:
alias sound emu10k1

This is enough to get the driver working. Now lets work on digital out and loading the proper scripts on startup.

4) cd /usr/local/etc. You should see:

5) edit emu10k1.conf and change <USE_DIGITAL_OUTPUT=no> to <USE_DIGITAL_OUTPUT=yes>.

6) Now add the proper lines to /etc/modules.conf so the script will load on startup and also save the mixer settings.

#Loads script on startup
post-install emu10k1 /usr/local/etc/emu-script
#Saves mixer levels
post-install emu10k1 /usr/local/etc/emu-script restore
pre-remove emu10k1 /usr/local/etc/emu-script save

Example of modules.conf file:

alias sound emu10k1
post-install emu10k1 /usr/local/etc/emu-script
post-install emu10k1 /usr/local/etc/emu-script restore
pre-remove emu10k1 /usr/local/etc/emu-script save

7) Enjoy!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
wlan config lost after reboot dblklk Mandriva 2 08-14-2005 02:10 PM
kernel .config for G4 733 Powermac (Digital Audio) pandoraX Linux - Hardware 0 12-23-2004 10:45 PM
emu-config digital outup, I'm lost HELP! Zeth_htp Linux - General 2 03-05-2003 10:54 AM
Digital output using emu-tools jburford Linux - Hardware 5 09-08-2002 07:37 AM
Lost kernel .config file... severedhead Linux - Software 2 07-11-2002 06:38 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:16 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration